Subject: [Bimi] Guidance Document - Refactor input

From: "Brotman, Alex" <[email-masked]>
Date: Wed, 7 Apr 2021 20:55:39 +0000

Hello folks,

We're looking to refactor the existing Receiver Guidance document to be more general purpose.  We thought we'd reach out to others on the list to see what areas they believe we should touch on.  We wanted the new iteration of the document to be something that can be referenced by all parties involved with BIMI such as Receivers, Senders, ESPs, Logo Designers, MUA authors, and so on.   We do intend to move over some of the existing content, so those have been included below.

We started a rough outline of sections to cover, and we'd welcome feedback.  Thanks for any input you could provide.

# Abstract
# Introduction
# Goals for BIMI
# Should you implement BIMI?
## As a Receivers
## As a Brands
# Terms
# Sections covered below (definitions of each group)
## Receivers
### Site implementation
### Validation of a BIMI message
#### Additional requirements
### Retrieval of image files
#### TTL for cached images
### VMC Root of Trust
## Senders/ESPs
### DMARC for Customers
## Brands
### Obtaining a VMC
### Logo Hosting Considerations
#### CDN Considerations
## MVAs
## Logo Designers
### Known Issues
### Adherence to SVG P/S
### Tools and Caveats
## MUA Creators
### Image Dispay
# Privacy Concerns
# FAQ

--
Alex Brotman
Sr. Engineer, Anti-Abuse & Messaging Policy
Comcast

---

From: Zack Aab <[email-masked]>
Date: Thu, 8 Apr 2021 12:49:56 -0400

$0.02 worth:
The info is already there in various places, but since BIMI might require
some organizations to add brand new code, an explicit "example mail agent
workflows" section that is simply all of the BIMI-related actions (*what*
action, not *how*) taken by the MTA, MUA, etc., would probably be helpful.
I also think something along the lines of the "minimum implementations"
section in the DMARC RFC https://tools.ietf.org/html/rfc7489#section-8
would be valuable.

*Zack Aab* (He/Him)
Senior Consultant, Trendline Interactive
*O* +1 (512) 717-4097 <+15127174097> | *C* +1 (404) 317-6729 <+14043176729>
| *W* trendlinei.com <https://www.trendlineinteractive.com/>

On Wed, Apr 7, 2021 at 4:56 PM Brotman, Alex <Alex_Brotman=
[email-masked]> wrote:

> Hello folks,
>
> We're looking to refactor the existing Receiver Guidance document to be
> more general purpose.  We thought we'd reach out to others on the list to
> see what areas they believe we should touch on.  We wanted the new
> iteration of the document to be something that can be referenced by all
> parties involved with BIMI such as Receivers, Senders, ESPs, Logo
> Designers, MUA authors, and so on.   We do intend to move over some of the
> existing content, so those have been included below.
>
> We started a rough outline of sections to cover, and we'd welcome
> feedback.  Thanks for any input you could provide.
>
>
> # Abstract
> # Introduction
> # Goals for BIMI
> bimi mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bimi
>

---

From: "Brotman, Alex" <[email-masked]>
Date: Fri, 9 Apr 2021 00:35:38 +0000

That's reasonable to have somewhere.  You're suggesting something akin to a flowchart, correct?  Would you be looking for this to include configuration from the brand side of things?

--
Alex Brotman
Sr. Engineer, Anti-Abuse
Comcast
x5364

________________________________________
From: Zack Aab <[email-masked]>
Sent: Thursday, April 8, 2021 12:49 PM
To: Brotman, Alex
Cc: BIMI (IETF) ([email-masked])
Subject: Re: [Bimi] Guidance Document - Refactor input

$0.02 worth:
The info is already there in various places, but since BIMI might require some organizations to add brand new code, an explicit "example mail agent workflows" section that is simply all of the BIMI-related actions (what action, not how) taken by the MTA, MUA, etc., would probably be helpful.
I also think something along the lines of the "minimum implementations" section in the DMARC RFC https://tools.ietf.org/html/rfc7489#section-8<https://urldefense.com/v3/__https://tools.ietf.org/html/rfc7489*section-8__;Iw!!CQl3mcHX2A!X3UO3VkKSbc6MN2ESm5qWFWS7YvvuDK8-92NiYNMCl72P3FkuRQSG5qLcA3aL5hmV7eX$> would be valuable.

Zack Aab (He/Him)
Senior Consultant, Trendline Interactive
O +1 (512) 717-4097<tel:+15127174097> | C +1 (404) 317-6729<tel:+14043176729> | W trendlinei.com<https://urldefense.com/v3/__https://www.trendlineinteractive.com/__;!!CQl3mcHX2A!X3UO3VkKSbc6MN2ESm5qWFWS7YvvuDK8-92NiYNMCl72P3FkuRQSG5qLcA3aL_o0FRg0$>

On Wed, Apr 7, 2021 at 4:56 PM Brotman, Alex <Alex_Brotman=[email-masked]<mailto:[email-masked]>> wrote:
Hello folks,

# Abstract
# Introduction
# Goals for BIMI

--
bimi mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bimi<https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bimi__;!!CQl3mcHX2A!X3UO3VkKSbc6MN2ESm5qWFWS7YvvuDK8-92NiYNMCl72P3FkuRQSG5qLcA3aL0Fw-o8d$>

---

From: Zack Aab <[email-masked]>
Date: Fri, 9 Apr 2021 09:26:47 -0400

Yes, I was thinking of something that simply shows each BIMI-related event
in an email's life.  Essentially so a sender or receiver who is
developing from scratch knows they haven't missed any crucial step.  I
don't know if everyone would consider the reward worth the work, so I'm
definitely open to opinions/discussion.
*Zack Aab* (He/Him)
Senior Consultant, Trendline Interactive
*O* +1 (512) 717-4097 <+15127174097> | *C* +1 (404) 317-6729 <+14043176729>
| *W* trendlinei.com <https://www.trendlineinteractive.com/>

On Thu, Apr 8, 2021 at 8:36 PM Brotman, Alex <[email-masked]>
wrote:

> That's reasonable to have somewhere.  You're suggesting something akin to
> a flowchart, correct?  Would you be looking for this to include
> configuration from the brand side of things?
>
> --
> Alex Brotman
> Sr. Engineer, Anti-Abuse
> Comcast
> x5364
>
> workflows" section that is simply all of the BIMI-related actions (what
> action, not how) taken by the MTA, MUA, etc., would probably be helpful.
> section in the DMARC RFC https://tools.ietf.org/html/rfc7489#section-8<
> https://urldefense.com/v3/__https://tools.ietf.org/html/rfc7489*section-8__;Iw!!CQl3mcHX2A!X3UO3VkKSbc6MN2ESm5qWFWS7YvvuDK8-92NiYNMCl72P3FkuRQSG5qLcA3aL5hmV7eX$>
> would be valuable.
>
> Zack Aab (He/Him)
> O +1 (512) 717-4097<tel:+15127174097> | C +1 (404)
> 317-6729<tel:+14043176729> | W trendlinei.com<
> https://urldefense.com/v3/__https://www.trendlineinteractive.com/__;!!CQl3mcHX2A!X3UO3VkKSbc6MN2ESm5qWFWS7YvvuDK8-92NiYNMCl72P3FkuRQSG5qLcA3aL_o0FRg0$
> >
>
>
> [email-masked]<mailto:[email-masked]>> wrote:
> Hello folks,
>
> https://www.ietf.org/mailman/listinfo/bimi<
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/bimi__;!!CQl3mcHX2A!X3UO3VkKSbc6MN2ESm5qWFWS7YvvuDK8-92NiYNMCl72P3FkuRQSG5qLcA3aL0Fw-o8d$
> >
>