Subject: [BLISS] call-completion issue 2004: Failure codes for CC SUBSCRIBE

From: "WORLEY, Dale R (Dale)" <[email-masked]>
Date: Wed, 7 Jul 2010 22:53:20 -0400

> > ** Technical
> > 
> > 
> > * 2004 Failure codes for CC SUBSCRIBE
> > 
> > [New for -05.]  The text is inconsistent regarding the 
> > failure code for a CC SUBSCRIBE for a call that the monitor 
> > has no record of:  7.2 says 404, 9.7 says 481.  It seems to 
> > me that 404 should be reserved for SUBSCRIBEs for which the 
> > monitor cannot identify the managed AOR, and 481 used for 
> > SUBSCRIBEs that designate a proper AOR but not a known call 
> > for that AOR.
> 
> I agree with your analysis. My proposal is to solve this inconsistency
> with a clear definition in subclause 9.7, and delete the regarding
> definitions from subclause 7.2, in order to avoid redundant
> specification.

Given that we are giving up on "call correlation", the monitor no longer produces 481 responses to new SUBSCRIBEs.  Removing that case from the two sections eliminates the inconsistency.

However, I think removing the redundancy is a good idea; the titles of the two sections make it clear that they are related, so a reader will have no difficulty finding the specification of response codes.

Dale

---

From: <[email-masked]>
Date: Tue, 20 Jul 2010 10:13:59 +0200

Hi all,
We propose the following text under 7.2, 4th paragraph.

Old text: 
The continuation of the caller's agent's subscription indicates that the caller's agent is prepared to initiate the CC call when it is selected by the callee's monitor. If the callee's monitor becomes aware that, according to its policy, the original call referenced by a subscription will never be selected for call-completion, it SHOULD terminate the subscription and respond to any attempt to start a new subscription for that original call with 404.

New proposed Text:
The continuation of the caller's agent's subscription indicates that the caller's agent is prepared to initiate the CC call when it is selected by the callee's monitor. If the callee's monitor cannot identify the AOR indicated by the SUBSCRIBE request as one of the AORs managed by the monitor, it SHOULD terminate the subscription and respond to any attempt to start a new subscription for that original call with 404.

We think that 404 under such circumstances is the correct response. Meaning the entity does not find a addressed AOR.

Views?

Best Regards

Roland and Martin

-----Ursprüngliche Nachricht-----
Von: [email-masked] [mailto:[email-masked]] Im Auftrag von WORLEY, Dale R (Dale)
Gesendet: Donnerstag, 8. Juli 2010 04:53
An: [email-masked]
Betreff: [BLISS] call-completion issue 2004: Failure codes for CC SUBSCRIBE

Dale
_______________________________________________
BLISS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bliss