Subject: Re: [BLISS] WGLC for draft-ietf-bliss-call-completion-07

From: Christer Holmberg <[email-masked]>
Date: Tue, 2 Nov 2010 09:05:36 +0100

Hi,

Below are my comments (I appologise that they are a few days late). Most are editorial, but there are also a few questions.

Section      Comment
----------------------------------------------------------------------

3                "CC indicator: a iniction" -> "CC indicator: an indication"
 
3                CC queue, is definition correct? Sounds like all failed calls.
 
4.1             "or be provided by a centralized application server" seems to suggest one (for both agent and monitor). Wouldn't "or be provided by centralized application servers" be more general?
 
4.1             Usage of the word "agent" is more general than in the definition where it is caller's agent. Example (3rd para): "Though it is expected that a UA that "implements call completion" will have both types of agents..."
 
4.1             Last para: I think the words "that have been" shall be removed from the following sentence " The monitor maintains information about the set of INVITEs that have been received by the UA(s) 
                  that may not have been considered successful by the calling user." otherwise I think the "considered succesful" refers to the UAs, not the INVITEs.
 
5                3rd para: "the the monitor"->"the monitor"
 
5                Para describing algorithm: Although there is no normative text, it suggests a FIFO queue since it is the entry that "has resided in the queue the longest" that is selected. Is this not a subject of local policy? Para 7.3 also describes this as a policy.
 
5                3rd para from the end: "an CC INVITE"->"a CC INVITE"
 
7.2             2nd para first sentence: "The callee's monitor(s) that receive the SUBSCRIBE establish subscriptions." Something is missing. to establish??
 
7.2             Last para. What do the underscores mean? 
 
7.3             2nd para. An extra ' in "'cc-service-retention".
 
7.3             Last para: "also contain also"->"contain also".
 
8                2nd para below figure: "is the where the"->"is where the"
 
9.11           "to to avoid"->"to avoid"
 
11              What does ">" mean in 3rd line?
 
12.1           There is a missing reference at second line.

Regards,

Christer

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Shida Schubert [[email-masked]]
Sent: Thursday, October 14, 2010 8:12 AM
To: BLISS
Subject: [BLISS] WGLC for draft-ietf-bliss-call-completion-07

This is an announcement of BLISS WG last call on
"Call Completion" prior to requesting publication the
document as a proposed standard.

This is a two week working group last call so please send your
comments to the list including nits by the 29th of October.

http://tools.ietf.org/html/draft-ietf-bliss-call-completion-07.txt

Regards
Shida Schubert (As WG chair)
_______________________________________________
BLISS mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bliss

---

From: "Kevin P. Fleming" <[email-masked]>
Date: Thu, 04 Nov 2010 17:12:23 -0500

> http://tools.ietf.org/html/draft-ietf-bliss-call-completion-07.txt

Given the amount of changes to this draft posted in the last week, is
there going to be an -08 draft and another WGLC on that draft? If not,
it's going to be hard for additional people to review the current draft,
since there such substantial changes already in the works.

-- 
Kevin P. Fleming
Digium, Inc. | Director of Software Technologies
445 Jan Davis Drive NW - Huntsville, AL 35806 - USA
skype: kpfleming | jabber: [email-masked]
Check us out at www.digium.com & www.asterisk.org

---

From: Shida Schubert <[email-masked]>
Date: Fri, 5 Nov 2010 15:03:41 +0800

I had the intention to call for another round of 
WGLC after draft is revised reflecting all the 
comments and issues raised during WGLC. 

 Regards
  Shida

---

From: "Hutton, Andrew" <[email-masked]>
Date: Wed, 10 Nov 2010 04:13:51 +0100

Hi Martin,

See below.

Regards
Andy
 
> > Hi,
> > 
> > The following comments are based on feedback I obtained from 
> > some developers. Sorry that they are sent last minute.
> > 
> > 1. Section 4.2 "Call-Completion procedures" (1st Para.). The 
> > text indicates that call completion procedures are not 
> > required if the callee's UAs return a success response. This 
> > is incorrect and in conflict with the definition of "Failed 
> > Call" in the definitions. The requirement for call completion 
> > is independent of the success/failure of the SIP INVITE request.
> > 
> > 
> > 2. Section 4.2. (2nd para.) Again it is implied that the call 
> > completion procedures seems tied to the state of the 
> > preceding INVITE initiated dialog with the statement 
> > "Eventually, the INVITE fails, or the resulting dialog(s) are 
> > terminated". However it is not the case that the call 
> > completion procedures are independent of the state any 
> > proceeding dialog. For example it should be possible to 
> > initiate call completion even before the original INVITE 
> > dialog is terminated.
> 
> I've tried to combine the 2 paragrapgs: 
> 
> "The caller's UA sends an INVITE to a request URI. One or 
> more forks of this request reach one or more of the callee's 
> UAs. However there might be the situation that the calling 
> user considers the result of the call insufficient to satisfy 
> his needs, e.g. the INVITE fails and the resulting dialog(s) 
> are terminated, or the INVITE might succeed at some other UA."
> 

[AndyHutton] - I think it needs to be made clear that the SUBSCRIBE for call completion can be initiated whatever the state of the original INVITE dialog. For example a 180 or 200OK response could be received to the original INVITE request and the user decides to invoke call completion before terminating the INVITE dialog. Maybe a statement to this effect could be made in section 4.2 and/or section 6.2.

---

From: "Kevin P. Fleming" <[email-masked]>
Date: Sun, 21 Nov 2010 10:10:33 -0700

> [AndyHutton] - I think it needs to be made clear that the SUBSCRIBE for call completion can be initiated whatever the state of the original INVITE dialog. For example a 180 or 200OK response could…

I agree. When the UAS sends any response that includes the 
call-completion information, the UAC is free to SUBSCRIBE for call 
completion services.