Subject: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

From: "Singh, Gurpreet" <[email-masked]>
Date: Wed, 24 Apr 2002 13:18:34 -1000

Section 9.1 Forming adjacencies on Point-to-Point Link Initialization

For this test the topology is 

o    Reference Topology 2

                                           		(
)
           Collector-----DUT-----Generator--(  emulated topology  )
                  \             		 / 	  (
)
                   \--------------------------	/

1. First the Generator comes in Full state with Collector and DUT with
Collector
2. Generator injects the set of LSAs to DUT.
3. The collector floods the LSAs to DUT.
4. Link between DUT and Generator is brought up. 

Since there is no change in the LSAs and the DUT already has the injected
LSAs so it will not request the Generator for the LSAs in the database
exchange process. Is that True ?

In that case the Generator will not send any LSAs to DUT and thus DUT will
not send any acknowledgement to the Generator except for the Router LSA and
the network LSA for the link between DUT and Generator .

Should the test be modified or i am misinterpretting it ?

Regards

Gurpreet

_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

---

From: "Manral, Vishwas" <[email-masked]>
Date: Thu, 25 Apr 2002 08:21:41 -0400

Gurpreet,

The draft clearly states to use the reference topology is 1 and not 2.

         o    Use reference topology 1, beginning with the link between
              the generator and DUT disabled on the DUT. OSPF should be
              configured and operating on both devices.

So the case you talk about does not occur.

Thanks a lot,
Vishwas

-----Original Message-----
From: Singh, Gurpreet [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 4:49 AM
To: [email-masked]'
Subject: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

o    Reference Topology 2

                                           		(
)

Regards

Gurpreet

---

From: "Manral, Vishwas" <[email-masked]>
Date: Thu, 25 Apr 2002 08:21:41 -0400

Gurpreet,

Thanks a lot,
Vishwas

-----Original Message-----
From: Singh, Gurpreet [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 4:49 AM
To: [email-masked]'
Subject: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

o    Reference Topology 2

                                           		(
)

Regards

Gurpreet

---

From: "Singh, Gurpreet" <[email-masked]>
Date: Thu, 25 Apr 2002 03:47:50 -1000

i apologise. I meant to say Section 9.3, not Section 9.1. Section 9.1 does
use Topology 2.

Gurpreet

-----Original Message-----
From: Manral, Vishwas [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 8:22 AM
To: 'Singh, Gurpreet'; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet,

Thanks a lot,
Vishwas

-----Original Message-----
From: Singh, Gurpreet [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 4:49 AM
To: [email-masked]'
Subject: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

o    Reference Topology 2

                                           		(
)

Regards

Gurpreet

---

From: "Singh, Gurpreet" <[email-masked]>
Date: Thu, 25 Apr 2002 03:47:50 -1000

Gurpreet

-----Original Message-----
From: Manral, Vishwas [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 8:22 AM
To: 'Singh, Gurpreet'; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet,

Thanks a lot,
Vishwas

-----Original Message-----
From: Singh, Gurpreet [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 4:49 AM
To: [email-masked]'
Subject: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

o    Reference Topology 2

                                           		(
)

Regards

Gurpreet

---

From: "Manral, Vishwas" <[email-masked]>
Date: Thu, 25 Apr 2002 13:42:16 -0400

Gurpreet,

The test talks about Link Up with Information Already in the Database, and
that is exactly the thing we are measuring(you understand the thing well).
Actually we have included this case because this happens very often in real
world, because topologies are highly meshed and the database has already
been exchanged on some other link. So what you say is correct, and that is
the exact intent of the test. However the ACK is for the router LSA
generated once the link is up and the router LSA is regenerated.(thats what
we regard the termination of the process entire process, where the new LSA
is flooded and has been received by the neighbor)

Maybe we will clarify the intent of the test to explain things better. 

Gurpreet, I do not know whether you were there at Minneapolis, but it was
decided we will have an applicability statement which will further explain
what tests can be useful for, what the test cases tell and what they dont,
etc. I am sure that document will be very helpful for you, and we are
actively working on it.

Thanks a lot,
Vishwas

-----Original Message-----
From: Singh, Gurpreet [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 7:18 PM
To: 'Manral, Vishwas'; Singh, Gurpreet; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet

-----Original Message-----
From: Manral, Vishwas [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 8:22 AM
To: 'Singh, Gurpreet'; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet,

Thanks a lot,
Vishwas

-----Original Message-----
From: Singh, Gurpreet [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 4:49 AM
To: [email-masked]'
Subject: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

o    Reference Topology 2

                                           		(
)

Regards

Gurpreet

---

From: "Manral, Vishwas" <[email-masked]>
Date: Thu, 25 Apr 2002 13:42:16 -0400

Gurpreet,

Thanks a lot,
Vishwas

-----Original Message-----
From: Singh, Gurpreet [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 7:18 PM
To: 'Manral, Vishwas'; Singh, Gurpreet; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet

-----Original Message-----
From: Manral, Vishwas [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 8:22 AM
To: 'Singh, Gurpreet'; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet,

Thanks a lot,
Vishwas

-----Original Message-----
From: Singh, Gurpreet [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 4:49 AM
To: [email-masked]'
Subject: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

o    Reference Topology 2

                                           		(
)

Regards

Gurpreet

---

From: "Singh, Gurpreet" <[email-masked]>
Date: Thu, 25 Apr 2002 08:04:36 -1000

Hmm. The following text from the draft does not seem to convey that the
acknowledgement for last LSA is for the router LSA. 

"the time required should only include the processing of each LSA from the
generator and transmitting an acknowledgement."

"The time between the hello received from the DUT by the generator and the
acknowledgement for the last LSA transmitted by the generator should be
taken as the total amount of time required for the OSPF process on the DUT
to build a FULL neighbor adjacency with the set of LSAs injected. In this
test, the DUT is already aware of the entire network topology, so the time
required should only include the processing of each LSA from the generator
and transmitting an acknowledgement. The acknowledgement for the last LSA
transmitted is used instead of the last acknowledgement received in order to
prevent timing skews due to retransmitted acknowledgements or LSAs"

-----Original Message-----
From: Manral, Vishwas [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 1:42 PM
To: 'Singh, Gurpreet'; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet,

Thanks a lot,
Vishwas

-----Original Message-----
From: Singh, Gurpreet [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 7:18 PM
To: 'Manral, Vishwas'; Singh, Gurpreet; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet

-----Original Message-----
From: Manral, Vishwas [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 8:22 AM
To: 'Singh, Gurpreet'; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet,

Thanks a lot,
Vishwas

-----Original Message-----
From: Singh, Gurpreet [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 4:49 AM
To: [email-masked]'
Subject: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

o    Reference Topology 2

                                           		(
)

Regards

Gurpreet

---

From: "Singh, Gurpreet" <[email-masked]>
Date: Thu, 25 Apr 2002 08:04:36 -1000

-----Original Message-----
From: Manral, Vishwas [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 1:42 PM
To: 'Singh, Gurpreet'; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet,

Thanks a lot,
Vishwas

-----Original Message-----
From: Singh, Gurpreet [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 7:18 PM
To: 'Manral, Vishwas'; Singh, Gurpreet; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet

-----Original Message-----
From: Manral, Vishwas [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 8:22 AM
To: 'Singh, Gurpreet'; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet,

Thanks a lot,
Vishwas

-----Original Message-----
From: Singh, Gurpreet [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 4:49 AM
To: [email-masked]'
Subject: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

o    Reference Topology 2

                                           		(
)

Regards

Gurpreet

---

From: "Manral, Vishwas" <[email-masked]>
Date: Thu, 25 Apr 2002 14:06:18 -0400

Gurpreet,

This does seem to be a bit amiss(and can cause confusion), I will clarify
the text.

Thanks a lot for the comments. They have been really helpful in improving
the draft.

- Vishwas

-----Original Message-----
From: Manral, Vishwas [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 1:42 PM
To: 'Singh, Gurpreet'; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet,

Thanks a lot,
Vishwas

-----Original Message-----
From: Singh, Gurpreet [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 7:18 PM
To: 'Manral, Vishwas'; Singh, Gurpreet; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet

-----Original Message-----
From: Manral, Vishwas [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 8:22 AM
To: 'Singh, Gurpreet'; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet,

Thanks a lot,
Vishwas

-----Original Message-----
From: Singh, Gurpreet [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 4:49 AM
To: [email-masked]'
Subject: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

o    Reference Topology 2

                                           		(
)

Regards

Gurpreet

---

From: "Manral, Vishwas" <[email-masked]>
Date: Thu, 25 Apr 2002 14:06:18 -0400

Gurpreet,

- Vishwas

-----Original Message-----
From: Manral, Vishwas [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 1:42 PM
To: 'Singh, Gurpreet'; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet,

Thanks a lot,
Vishwas

-----Original Message-----
From: Singh, Gurpreet [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 7:18 PM
To: 'Manral, Vishwas'; Singh, Gurpreet; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet

-----Original Message-----
From: Manral, Vishwas [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 8:22 AM
To: 'Singh, Gurpreet'; [email-masked]'
Subject: RE: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

Gurpreet,

Thanks a lot,
Vishwas

-----Original Message-----
From: Singh, Gurpreet [mailto:[email-masked]]
Sent: Thursday, April 25, 2002 4:49 AM
To: [email-masked]'
Subject: [bmwg] draft-manral-ospfconv-intraarea-00 OSPF Convergence

o    Reference Topology 2

                                           		(
)

Regards

Gurpreet