Subject: RE: [bmwg] Is the BMWG a proper home for this I-D?ch

From: Russ White <[email-masked]>
Date: Mon, 4 Oct 2004 11:00:03 -0400 (Eastern Daylight Time)

Okay, it's been a couple of months since we've talked about this.... Have 
we reached any concensus on it? If BMWG isn't going to take it on, I need 
to get with the ADs and see what can be done about pushing it as an 
individual contribution (though I still think it's more benchmarking 
related than real world testing, after re-reading it).

If anyone would like to contribute more considerations, to make the draft 
"wider," those would be welcome, too.

:-)

Russ

On Wed, 7 Apr 2004, Jim McQuaid wrote:

> You make an excellent point (can it be tested with created traffic or does
> it require live network traffic in some form).  That's the "bench" in
> benchmark; it can be done with lab equipment.
>
> I would agree with that distinction.  On the other hand, if there is
> enthusiasm to do this work within BMWG, tthat may be more important than
> legalisms, however sound.
>
> Jim McQuaid
>
> -----Original Message-----
> From: Howard C. Berkowitz [mailto:[email-masked]]
> Sent: Wednesday, April 07, 2004 9:29 AM
> To: [email-masked]
> Subject: RE: [bmwg] Is the BMWG a proper home for this I-D?
>
>
> At 10:56 AM +0000 4/7/04, Jim McQuaid wrote:
>> <sorry for the blank reply>
>>
>> At the time the IPPM was "spun off" of the BMWG, the general understanding
>> was that BMWG would look at "things" more or less in isolation, although
>> that concept is somewhat elastic.  IPPM would look at end to end network
>> kinds of performance issues.
>>
>> It seems clear to me that convergence is a performance characteristic of
>> complete networks and primarily an end to end or at least, core element to
>> core element characteristic.
>>
>> My thought would be that this is interesting and useful work but not
>> necessarily for BMWG.
>>
>> Jim McQuaid
>
>
> I don't completely disagree with you.  I do feel that single-platform
> performance definition and benchmarking is definitely within the
> scope of BMWG, and some of my comments relating to clarifying test
> methods (e.g., black box vs. white box vs. passive analysis)
> definitely can be applied to one box.  BMWG has always looked at
> forwarding plane performance of single boxes, and I really don't
> think we are straying far to look at there control plane performance.
>
> You are correct that IPPM, as well as some of the internet
> scalability issues both in the IETF and IRTF, are probably better
> places for end-to-end convergence.
>
> At least in the case of BGP, however, there is a meaningful
> intermediate level that isn't single box and isn't end-to-end:
> convergence within an AS, and conceivably subsets thereof such as
> route reflector clusters.  Similar points can be made about
> intra-area convergence in OSPF and ISIS.  Where do these fit?
>
> I'm inclined to say BMWG, and let me suggest what might be a very
> crude rule of thumb in saying BMWG or not-BMWG.  Many of the
> Internet-wide experiments have to rely on sampling live data, with
> perhaps some selective probes.  Single-box, or small-system-of-boxes
> measurement, plausibly can be done with an artificial benchmark in a
> testing lab.
>
> Given the name of this group, perhaps, then, the decision if
> something belongs here depends on asking the question early, "can the
> measurement be made with a synthetic benchmark and test equipment,"
> or does some of it really have to come from sampling and probing live
> networks?  If the former, it's BMWG eligible. If the latter, it's
> interesting, might even warrant BMWG liaison and/or help in placing
> it elsewhere, but shouldn't stay in BMWG.
>
>
>
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/bmwg
>
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/bmwg
>

__________________________________
[email-masked] CCIE <>< Grace Alone

_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

---

From: Michele Bustos <[email-masked]>
Date: Tue, 5 Oct 2004 09:42:46 -0700

Isn't this considered a "plug-in"??  I don't see the issue if we are
allowing other plug-ins.

============================================= 
Michele Bustos 
Support Engineer 
Ixia Communications

26601 W. Agoura Road 
Calabasas, CA 91302 
Tel: (818) 871-1800 (US), ext. 1 
+1 (818) 871-1800 (international) 
<http://www.ixiacom.com> 
[email-masked]

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Russ White
Sent: Tuesday, October 05, 2004 8:24 AM
To: Jim McQuaid
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [bmwg] Is the BMWG a proper home for this I-D?ch

> Isn't there a "best practices" genre of RFC which might pertain?

Actually, you've hit the nail on the head. What would hte WG think of 
taking on creating a BCP for testing, and using this doc as the core of 
that effort? That fits what this doc is driving at better than an 
informational, and it certainly doesn't fit into the concept of an actual 
set of tests, defined, etc.

Thoughts?

:-)

Russ

---

From: [email-masked]
Date: Tue, 5 Oct 2004 12:44:31 -0400

This is not a plug-in.  It is very specific to measuring network convergence
and does not plug-in to any other documents..

Scott

-----Original Message-----
From: Michele Bustos [mailto:[email-masked]]
Sent: Tuesday, October 05, 2004 12:43 PM
To: 'Russ White'; Jim McQuaid
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [bmwg] Is the BMWG a proper home for this I-D?ch

26601 W. Agoura Road 
Calabasas, CA 91302 

-----Original Message-----

Thoughts?

:-)

Russ

---

From: Michele Bustos <[email-masked]>
Date: Tue, 5 Oct 2004 10:02:48 -0700

That's fair, however....
Not all currently entertained papers ARE terminology and methodology.  
The root issue here is a question of BMWG scope?  Are all papers in this
forum mandated to be terminology and methodology?  Are we only writing test
plans?  

26601 W. Agoura Road 
Calabasas, CA 91302 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, October 05, 2004 9:45 AM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [bmwg] Is the BMWG a proper home for this I-D?ch

Scott

-----Original Message-----
From: Michele Bustos [mailto:[email-masked]]
Sent: Tuesday, October 05, 2004 12:43 PM
To: 'Russ White'; Jim McQuaid
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [bmwg] Is the BMWG a proper home for this I-D?ch

26601 W. Agoura Road 
Calabasas, CA 91302 

-----Original Message-----

Thoughts?

:-)

Russ