Subject: [bmwg] Methodology for benchmarking fast failover time with local protection Part 1

From: "Samir Vapiwala \(svapiwal\)" <[email-masked]>
Date: Thu, 13 Oct 2005 09:42:03 -0400

Scott,

I read your draft draft-poretsky-mpls-protection-meth-04.txt and
realized that we could expand on the FRR benchmarking of the failover
times with all possible combination of topologies and additional test
cases.

So Jay and I came up with a write-up that could be merged to the
existing work of yours. Please take a look at this and let us know what
you and the co-authors of draft-poretsky-mpls-protection-meth-04.txt
think ? 

I'm sending my draft  fragmented into 2 text files and attached in 2
different emails to stay within the limit of  25K mail size. 

Thanks,

Samir

_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

---

From: "The Poretsky Family" <[email-masked]>
Date: Thu, 13 Oct 2005 17:51:11 -0700

Samir and Jay,

Thank you very much for your comments in this email and the one that immediately followed it.  MPLS Protection Performance is an area in which service providers have expressed a tremendous amount of interest and we as vendors need to know what we are delivering.  I do see the BMWG as the ideal place to define the benchmark metrics and methodologies.  

Some of the suggestions you provided in the emails can be incorporated into the existing MPLS Protection Mechanisms Methodology Draft. For example, tunnel scaling could be added to the Test Considerations and Test Reporting sections.  Your suggestion to add test cases for FRR with LDP over RSVP-TE is right on.  Jean-Louis LeRoux suggested the same with strong support from Rajiv Papneja.  We discussed this and decided while it is the right thing to do, it would be best to make this a methodology document separate from the MPLS Protection Mechanisms Benchmarking.  I hope you agree.

If the proposed Sub-IP Protection Mechanism Benchmarking moves ahead to be a BWMG work item, then I would suggest that Jean-Louis, Rajiv, you, (and others?) author the LDP over RSVP-TE Protection Benchmarking Methodology.  Another alternative could be to reduce the scope of the Sub-IP Protection Mechanism work item to MPLS Protection only.  This would mean that there would need to be a separate work item proposal for the HA Benchmarking that was intended to be covered under Sub-IP.  If the AD and WG Chairs were fine with two separate work items for MPLS and HA then I think that would be best to facilitate progress on the documents.

The discussions of both technical issues specific to MPLS Protection benchmarking and the BMWG work item agenda are both very worthwhile.  I hope we can discuss this on the Vancouver agenda.  Of course email is great until then.

Scott
  ----- Original Message ----- 
  From: Samir Vapiwala (svapiwal) 
  To: [email-masked] ; [email-masked] ; [email-masked] 
  Sent: Thursday, October 13, 2005 6:42 AM
  Subject: [bmwg] Methodology for benchmarking fast failover time with localprotection Part 1

   Scott,
  I read your draft draft-poretsky-mpls-protection-meth-04.txt and realized that we could expand on the FRR benchmarking of the failover times with all possible combination of topologies and additional test cases.

  So Jay and I came up with a write-up that could be merged to the existing work of yours. Please take a look at this and let us know what you and the co-authors of draft-poretsky-mpls-protection-meth-04.txt think ? 

  I'm sending my draft  fragmented into 2 text files and attached in 2 different emails to stay within the limit of  25K mail size. 

  Thanks,

  Samir

------------------------------------------------------------------------------