Subject: RE: [bmwg] Re: BMWG Last Call: draft-ietf-bmwg-igp-dataplane-conv -***-10

From: [email-masked]
Date: Mon, 10 Apr 2006 17:10:12 -0400

Yes.  We had discussion at 2 BMWG meetings (check meeting minutes) regarding
this.  We came up arbitrarily with the factor 5 as suggested by Jerry
Perser.  If someone has a good reason to select another factor then I am
acceptable to using it.

Scott

-----Original Message-----
From: Al Morton [mailto:[email-masked]]
Sent: Monday, April 10, 2006 5:07 PM
To: [email-masked]
Subject: [bmwg] Re: BMWG Last Call:
draft-ietf-bmwg-igp-dataplane-conv-***-10

Scott,

Here's another sticky point in the terms draft.  I think I tried
to help you clarify this, and it appears we fixed the "units" problem
that existed in version 08, but muddied other water in doing so:

>    3.12 Sustained Forwarding Convergence Time
>
>         Definition:
>         The amount of time for which Full Convergence is maintained
>         without additional packet loss.
>
>         Discussion:
>         The purpose of the Sustained Forwarding Convergence Time is to
>         produce Convergence benchmarks protected against fluctuation
>         in Throughput after Full Convergence is observed.  The
>         Sustained  Forwarding Convergence Time to be used is calculated
>         as shown in Equation 3.
>
>         (eq 3)
>         Sustained Forwarding Convergence Time = 5 packets/Offered Load
>             units are packets/pps = sec
>
>         for which at least one packet per route in the FIB for all
>         routes in the FIB MUST be offered to the DUT per second.

Something seems missing in (eq 3),  because 5 pkts/Offered Load
will be a very short time interval, and it's not clear how to apply
the qualifying sentence below the equation.

Are we trying to quantify the time needed to observe 5 packets on
every route?      Then we might just say:

Sustained Forwarding Convergence Time =
= Time required to observe 5 packets on every route in the FIB

For example, if the test device sends a packet on every route each second,
then the Sustained Forwarding Convergence time will be 5 seconds
under loss-free conditions.

or something like that.

I also noted an Editorial comment.

In Section 3.2    s/Forwaridng/Forwarding/

Al

_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

---

From: Al Morton <[email-masked]>
Date: Tue, 11 Apr 2006 08:10:16 -0400

>Perser.  If someone has a good reason to select another factor then I am

I'm not suggesting a different factor, I'm just seeking
a clear specification of the Sustained Forwarding Convergence Time.
IOW, five times what?

Al