Subject: [bmwg] BMWG Last Call: draft-ietf-bmwg-igp-dataplane-conv-***-10

From: Al Morton <[email-masked]>
Date: Mon, 03 Apr 2006 11:44:56 -0400

BMWG:

A WG Last Call period for the Internet-Drafts titled:

Benchmarking Methodology for IGP Data Plane Route Convergence
http://www.ietf.cnri.reston.va.us/internet-drafts/draft-ietf-bmwg-igp-dataplane-conv-meth-10.txt

Terminology for Benchmarking IGP Data Plane Route Convergence
http://www.ietf.cnri.reston.va.us/internet-drafts/draft-ietf-bmwg-igp-dataplane-conv-term-10.txt

Benchmarking Applicability for IGP Data Plane Route Convergence
http://www.ietf.cnri.reston.va.us/internet-drafts/draft-ietf-bmwg-igp-dataplane-conv-app-10.txt

will be open from 3 April through 10 April 2006.

This may be the "last" in a series of WG Last Calls.
These three drafts entered the BMWG Last Call Process
on May 10, 2004 at version 02, and have been revised
substantially to reflect the WG and cross-area comments received.
Versions numbered -09 and -10 capture the changes following
the October 2005 WGLC, where there was a strong show of support
for these drafts.

******************************************************
* We are asking that previous reviewers please check *
* that their comments have been addressed.           *
******************************************************

Changes/diffs can easily be checked on the IETF tools website:
http://tools.ietf.org/wg/bmwg/

Please weigh-in on whether or not you feel that these Internet-Drafts
should be given to the Area Directors for consideration in
progressing the Drafts to Informational RFCs.  Send your comments
to this list or [email-masked] .

Al
BMWG Co-Chair

_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

---

From: Al Morton <[email-masked]>
Date: Mon, 10 Apr 2006 17:06:52 -0400

Scott,

Here's another sticky point in the terms draft.  I think I tried
to help you clarify this, and it appears we fixed the "units" problem
that existed in version 08, but muddied other water in doing so:

>    3.12 Sustained Forwarding Convergence Time
>
>         Definition:
>         The amount of time for which Full Convergence is maintained
>         without additional packet loss.
>
>         Discussion:
>         The purpose of the Sustained Forwarding Convergence Time is to
>         produce Convergence benchmarks protected against fluctuation
>         in Throughput after Full Convergence is observed.  The
>         Sustained  Forwarding Convergence Time to be used is calculated
>         as shown in Equation 3.
>
>         (eq 3)
>         Sustained Forwarding Convergence Time = 5 packets/Offered Load
>             units are packets/pps = sec
>
>         for which at least one packet per route in the FIB for all
>         routes in the FIB MUST be offered to the DUT per second.

Something seems missing in (eq 3),  because 5 pkts/Offered Load
will be a very short time interval, and it's not clear how to apply
the qualifying sentence below the equation.

Are we trying to quantify the time needed to observe 5 packets on
every route?      Then we might just say:

Sustained Forwarding Convergence Time =
= Time required to observe 5 packets on every route in the FIB

For example, if the test device sends a packet on every route each second,
then the Sustained Forwarding Convergence time will be 5 seconds
under loss-free conditions.

or something like that.

I also noted an Editorial comment.

In Section 3.2    s/Forwaridng/Forwarding/

Al