Subject: RE: [bmwg] FW: IETF BMWG Work Item Proposal forSIP PerformanceBenchmarking

From: "Player, Timmons" <[email-masked]>
Date: Wed, 24 May 2006 09:46:10 -0700

While I realise that RTP has some extra fields and such for the
endpoints to track end to end performance, how would benchmarking RTP
flows be different than sending a bunch of UDP streams through a
device/network?

Seems like the useful metrics for RTP streams (packet loss, jitter,
latency/delay) are the same as what most test tools give you.
Or am I missing some useful RTP stream metrics?

Timmons 

> -----Original Message-----
> From: Vijay K. Gurbani [mailto:[email-masked]] 
> Sent: Wednesday, May 24, 2006 10:55 AM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; Moore,Sean (Sean); [email-masked]
> Subject: Re: [bmwg] FW: IETF BMWG Work Item Proposal forSIP 
> PerformanceBenchmarking
> 
> Romascanu, Dan (Dan) wrote:
> > I hear what you are saying but I am not sure that I can agree. The 
> > question is why should RTP plane benchmarking be within SIP 
> > Performance Benchmarking scope. What does SIP have to do with media 
> > plane performance anyway?  SIP can be used to establish 
> sessions with 
> > a different data plane than RTP, and we may want to benchmark RTP 
> > performance even if signaling is not SIP.
> 
> Dan: You are absolutely right.
> 
> > I am not saying that RTP media plane benchmarking is not 
> useful, but I 
> > believe that it should be within the scope of a different document.
> 
> I am curious: is there such an existing document?  Has there 
> been any work in avt or mmusic for RTP benchmarking?  Would 
> the bench- mark be specific to a codec?
> 
> It would be nice to gauge some consensus in the WG around 
> whether the "Media Plane" is inline with the notion of SIP 
> benchmarking or not.
> 
> Thanks,
> 
> - vijay
> --
> Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
> Bell Laboratories, Lucent Technologies, Inc.
> 2701 Lucent Lane, Rm. 9F-546, Lisle, Illinois 60532 (USA)
> 
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/bmwg
> 

<DIV><FONT size="1">

E-mail confidentiality.
--------------------------------
This e-mail contains confidential and / or privileged information belonging to Spirent plc, its affiliates and / or subsidiaries. If you are not the intended recipient, you are hereby notified that any disclosure, copying, distribution and / or the taking of any action based upon reliance on the contents of this transmission is strictly forbidden. If you have received this message in error please notify the sender by return e-mail and delete it from your system. If you require assistance, please contact our IT department.

Spirent plc,
Spirent House, Crawley Business Quarter, Fleming Way, Crawley, West Sussex, RH10 9QL, United Kingdom.
Tel No. +44 (0) 1293 767676
Fax No. +44 (0) 1293 767677

Registered in England Number 470893
Registered at Spirent House, Crawley Business Quarter, Fleming Way, Crawley, West Sussex, RH10 9QL, United Kingdom 

OR

Spirent Communications,
26750 Agoura Road, Calabasas, CA, 91302, USA.
Tel No. 1-818-676-2586

</FONT></DIV>

_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

---

From: "Player, Timmons" <[email-masked]>
Date: Wed, 24 May 2006 11:20:54 -0700

Yep, I know that.  I was asking about the RTP specific benchmarking
documentation query in the email before
mine.

However, I would say that the only time media is relevant is when the
device/system that is performing the call setup is also forwarding the
media packets.  It might not be, in which case it doesn't really make
sense to benchmark with media, cuz the DUT/SUT never would see it
anyway.

Timmons 

> From: [email-masked] [mailto:[email-masked]] 
> Sent: Wednesday, May 24, 2006 1:52 PM
> To: Player, Timmons; [email-masked]; [email-masked]
> [email-masked]; [email-masked]; [email-masked]
> Subject: RE: [bmwg] FW: IETF BMWG Work Item Proposal forSIP 
> PerformanceBenchmarking
> 
> Timmons
> 
> SIP control sessions without media is not a voice call.  
> Those of us now performing SIP benchmarking are observing 
> that call load is impacting media performance, in certain 
> devices, and media load is impacting call performance, in 
> certain devices.  We are even noticing this behavior in some 
> test equipment ;-)  To fully benchmark a SIP implementation 
> it is necessary to measure the benchmark metrics with 
> variation to call and media load.  
> 
> Scott
> 
> From: Player, Timmons [mailto:[email-masked]]
> Sent: Wednesday, May 24, 2006 12:46 PM
> To: Vijay K. Gurbani; Romascanu, Dan (Dan)
> Cc: [email-masked]; [email-masked]; Moore, 
> Sean (Sean); [email-masked]; [email-masked]
> Subject: RE: [bmwg] FW: IETF BMWG Work Item Proposal forSIP 
> PerformanceBenchmarking
> 
> 
> While I realise that RTP has some extra fields and such for 
> the endpoints to track end to end performance, how would 
> benchmarking RTP flows be different than sending a bunch of 
> UDP streams through a device/network?
> 
> > I am curious: is there such an existing document?  Has 
> there been any 
> > work in avt or mmusic for RTP benchmarking?  Would the 
> bench- mark be 
> > specific to a codec?
> > 
> whether the 
> > "Media Plane" is inline with the notion of SIP benchmarking or not.
> > 
> > Thanks,
> > 
> > - vijay
> > --
> This e-mail contains confidential and / or privileged 
> information belonging to Spirent plc, its affiliates and / or 
> subsidiaries. If you are not the intended recipient, you are 
> hereby notified that any disclosure, copying, distribution 
> and / or the taking of any action based upon reliance on the 
> contents of this transmission is strictly forbidden. If you 
> have received this message in error please notify the sender 
> by return e-mail and delete it from your system. If you 
> require assistance, please contact our IT department.
> 
> Spirent plc,
> Spirent House, Crawley Business Quarter, Fleming Way, 
> Crawley, West Sussex, RH10 9QL, United Kingdom.
> Registered at Spirent House, Crawley Business Quarter, 
> Fleming Way, Crawley, West Sussex, RH10 9QL, United Kingdom 
> 
> OR
> 
> Spirent Communications,

<DIV><FONT size="1">

E-mail confidentiality.

Spirent plc,

OR

Spirent Communications,

</FONT></DIV>