Subject: RE: [bmwg] Proposal on Protection Benchmarking

From: "Romascanu, Dan \(Dan\)" <[email-masked]>
Date: Thu, 4 May 2006 13:17:37 +0300

I have a couple of clarification questions:

- How will the WG identify the different protection mechanisms within
the scope of the work. There are a couple of references to ' include but
are not limited to MPLS Fast Reroute, SONET APS, and High  Availability'
which for me reads into being able to support and identify other similar
mechanisms within the scope in the future. Do you have in mind some kind
of registry to identify protection mechanisms?
- In the schedule and deliverable list why is the result of the merge of
individual submission labeled 'Methodology for MPLS Protection
Benchmarking'. I would expect the outcome to deal with different
protection mechanisms and not to be MPLS specific, or am I missing
something? 

Dan

> -----Original Message-----
> From: Al Morton [mailto:[email-masked]] 
> Sent: Wednesday, May 03, 2006 10:30 PM
> To: [email-masked]
> Subject: [bmwg] Proposal on Protection Benchmarking
> 
> BMWG,
> 
> The proponents of the Protection Benchmarking Work Proposal 
> have prepared the description of this work effort, below.
> 
> BMWG discussed this work at the Dallas IETF-65 session, where 
> there was strong support and involved membership (see meeting 
> minutes).
> 
> Please weigh-in on whether this topic should become part of 
> BMWG's chartered work, by
> 
>                     June 2, 2006
> 
> And, if you support the work, please say:
> 
> +  HOW you intend to support the development in BMWG,
>     (by reviewing draft X by MM/DD/YY, for example),  or
> 
> +  WHY this work will be beneficial to BMWG's user community, or
> 
> +  Modifications that would make the proposal more useful
>     (which we will discuss on the list), and
> 
> +  (anything else that's constructive)
> 
> And remember, we'd like to hear your opinion on the list, 
> even if you spoke in favor of this proposal at the meeting.
> 
> Thanks in advance for your efforts and commitment to BMWG!
> 
> Al
> bmwg co-chair
> 
> ==============================================================
> ===========
> 
> Proposal for Protection Benchmarking
> 
> 
> Summary:
> 
> This is a proposal for a BMWG work item for black-box 
> benchmarking of sub-IP protection mechanisms at the IP Layer. 
> These mechanisms function at sub-IP layers with the purpose 
> of protecting IP traffic, making it possible to develop 
> benchmarks for these mechanisms by measuring the data plane 
> at the IP layer.  This work item will develop a common 
> terminology to be used for protection benchmarking at the 
> data plane of the IP Layer and multiple methodology documents 
> for each sub-IP protection mechanism.  Such mechanisms 
> include but are not limited to MPLS Fast Reroute, SONET APS, 
> and High Availability.  The methodologies and benchmarks can 
> be used to compare performance of a protection mechanism on 
> one device to another or to compare performance of two or 
> more protection mechanisms.
> 
> 
> Goal:
> 
> The objective is to produce a terminology document for 
> protection benchmarking at the IP Layer and methodology 
> documents for benchmarking protection mechanisms at the IP 
> layer.  Path failures and rerouting are benchmarked through 
> packet loss measurement on the data plane.  There will be a 
> common terminology to be used for protection benchmarking at 
> the IP Layer and multiple methodology documents for each 
> sub-IP protection mechanism.
> 
> 
> Scope:
> 
> The focus of this effort is to benchmark Sub-IP protection 
> mechanisms at 
> the IP Layer for a DUT or SUT.   Such mechanisms include but are not 
> limited to MPLS Fast Reroute, SONET APS, and High 
> Availability.  The benchmark parameters that are measured are 
> independent of the layer 3 routing protocol being run.  The 
> data plane is measured to obtain the IP layer benchmarks. 
> Control Plane scaling will be considered in the test 
> methodologies to measure its impact to the IP Layer 
> benchmarks. In addition, this effort will characterize the 
> duplicate and reordered packets within the definition of 
> recovery time. The presence of duplicate and errored packets 
> may be tied to the failover event.
> 
> 
> Motivation:
> 
> Service Providers are currently deploying sub-IP protection 
> mechanisms to minimize or eliminate IP layer packet loss and 
> control plane failure.  The networking device failover 
> performance times have become critical metrics for deployment 
> selection.  Faster networking device failover times have 
> directly led to faster network failure recovery times.
> 
>   Network users consider packet loss a key service metric. 
> Intervals of high packet loss are externally observable 
> events having direct impact on user application performance. 
> Numerous sub-IP protection mechanisms have been developed and 
> are now being deployed to minimize IP packet loss upon a 
> failure.  For this reason it is very important to develop 
> uniform protection mechanism benchmarks for comparing 
> networking device performance.  Service providers can use 
> these benchmarks to compare performance of a protection 
> mechanism on one device to another or to compare performance 
> of two or more protection mechanisms.
> 
> 
> Schedule:
> 
> "Terminology For Protection Benchmarking,"
> 
> draft-poretsky-protection-term-01.txt, Ready for WGLC 07/06 
> and Ready for IESG 10/06.
> 
> 
> "Methodology For MPLS Protection Benchmarking,"
> 
> draft-poretsky-mpls-protection-meth-05.txt
> 
> 
> MERGE WITH
> 
> "Methodology for benchmarking fast fail-overtime with local 
> protection,"
> 
> draft-vapiwala-bmwg-frr-failover-meth-00.txt
> 
> 
> TO CREATE
> 
> "Methodology for MPLS Protection Benchmarking,"
> 
> draft-ietf-bmwg-mpls-protection-meth-00.txt
> 
> 
> FIRST SUBMITTAL 06/06 and Ready for WGLC 12/06 and Ready for 
> IESG 04/07.
> 
> 
> These documents (Terminology and Methodology) have already undergone 
> extensive working group review.
> 
> 
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/bmwg
> 

_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

---

From: Al Morton <[email-masked]>
Date: Thu, 04 May 2006 08:25:51 -0400

Dan, thanks for your questions, please see below:

>of registry to identify protection mechanisms?

The proposal is to adopt two drafts on the charter in this
work area at present, the terminology and a methodology for MPLS.
The terminology is intended to be "common" to all protection technologies,
while methodology drafts will be technology-specific.
For future methodology drafts, the WG will have this project description,
in addition to BMWG's charter (and AD advice), to help determine
if the proposed draft is appropriate for BMWG.

The current proposal does not involve a registry. Methodology
drafts would simply refer to protection mechanisms by reference to
the standards that describe them.

>protection mechanisms and not to be MPLS specific, or am I missing

The methodologies that are merging are both MPLS-specific,
and therefore an MPLS-specific method will result. The plan is to have
different methodology documents for each sub-IP protection mechanism,
not a common methodology for all.

hope this helps,
Al