Subject: RE: [bmwg] Updated draft on MPLS forwarding Benchmarking:draft-akhter-bmwg-mpls-meth-03.txt

From: "Jay Karthik (jakarthi)" <[email-masked]>
Date: Mon, 3 Dec 2007 17:28:59 -0500

Aamer, Rajiv,

IMO version 3 is in a good shape and more readable than the original
version.

Is forwarding benchmarking in load-balancing scenarios, "in" scope or
"out" w.r.t this memo ?

Also I wanted to highlight that MPLS-to-MPLS is not a "swap" all the
time. In a locally repaired LSP, MPLS-to-MPLS would need another
"imposition". Is it not ?

Cheers,
Jay

-----Original Message-----
From: Aamer Akhter (aakhter) 
Sent: Monday, November 26, 2007 12:06 PM
To: [email-masked]
Subject: [bmwg] Updated draft on MPLS forwarding
Benchmarking:draft-akhter-bmwg-mpls-meth-03.txt

Hello BMWG,

We would like to bring to your attention the updated draft on basic MPLS
forwarding that we will be submitting to the IETF as an individual
submission (once submissions opens up again). There have been
significant changes since the last version of the draft including:

* removal of many test cases thought to be out of scope
* rewriting of many cases to be less verbose
* addition of reload tests

http://www.employees.org/~aamer/draft-akhter-bmwg-mpls-meth-03.txt

   Over the past several years MPLS networks have gained greater 
   popularity. However, there is no standard method to compare and 
   contrast the varying implementations and their strong and weak 
   points. This document proposes a methodology using common criteria 
   for the comparison of various implementations of basic MPLS 
   forwarding devices.

If there are any concerns or changes that need to be made please do not
hesitate to contact us.

Regards,

Aamer Akhter
Rajiv Asati

==================

	Title		: MPLS Benchmarking Methodology
	Author(s)	: Aamer Akhter and Rajiv Asati
	Filename	: draft-akhter-bmwg-mpls-meth-03.txt
	Pages		: 21
	Date		: 2007-11-25
	
   The purpose of this draft is to describe a methodology specific to 
   the benchmarking of MPLS forwarding devices. The scope of this 
   benchmarking will be limited to various types of packet-forwarding 
   and delay measurements. It builds upon the tenets set forth in 
   RFC2544 [RFC2544], RFC1242 [RFC1242] and other IETF Benchmarking 
 
   The BMWG produces two major classes of documents: Benchmarking 
   Terminology documents and Benchmarking Methodology documents.  The 
   Terminology documents present the benchmarks and other related 
   terms. The Methodology documents define the procedures required to 
   collect the benchmarks cited in the corresponding Terminology 
   documents.

A temporary URL for this Internet-Draft is:
http://www.employees.org/~aamer/draft-akhter-bmwg-mpls-meth-03.txt

--
Aamer Akhter / [email-masked]
Rajiv Asati / [email-masked]

_______________________________________________
bmwg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bmwg

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Thu, 6 Dec 2007 11:04:21 -0500

Hi Jay,

Thank you so much for your support for this draft.

Please see inline,

> Is forwarding benchmarking in load-balancing scenarios, "in" 
> scope or "out" w.r.t this memo ?

Out. This is in spirit of RFC2544.

> Also I wanted to highlight that MPLS-to-MPLS is not a "swap" 
> all the time. In a locally repaired LSP, MPLS-to-MPLS would 
> need another "imposition". Is it not ?

In that case, it would still be a "swap" of one label with a label stack
(with >1 label). 

Cheers,
Rajiv

> From: Jay Karthik (jakarthi) 
> Sent: Monday, December 03, 2007 5:29 PM
> To: Aamer Akhter (aakhter); [email-masked]
> Cc: Rajiv Asati (rajiva); Jay Karthik (jakarthi)
> Subject: RE: [bmwg] Updated draft on MPLS forwarding 
> IMO version 3 is in a good shape and more readable than the 
> original version.
> 
> Is forwarding benchmarking in load-balancing scenarios, "in" 
> scope or "out" w.r.t this memo ?
> 
> Also I wanted to highlight that MPLS-to-MPLS is not a "swap" 
> all the time. In a locally repaired LSP, MPLS-to-MPLS would 
> need another "imposition". Is it not ?
> 
> Cheers,
> Jay
> 
> We would like to bring to your attention the updated draft on 
> basic MPLS forwarding that we will be submitting to the IETF 
> as an individual submission (once submissions opens up 
> again). There have been significant changes since the last 
> version of the draft including:
> 
> If there are any concerns or changes that need to be made 
> please do not hesitate to contact us.
> 
> Regards,
> 
> Aamer Akhter
> Rajiv Asati
> 
> ==================
>