Subject: [bmwg] Draft Liaison to IEEE 802.1 on DCB proposal

From: Al Morton <[email-masked]>
Date: Mon, 12 Apr 2010 12:08:18 -0400

BMWG,

The first draft Liaison to IEEE 802.1 describing
the proposal to update RFCs 2544 and 2889 to address the Per-Flow Control
capabilities of IEEE 802.1Qbb is below. Thanks to David Newman
and Eric Gray (IETF Liaison Manager for 802.1)
for suggested text and/or background info shared off-list.

Comments by April 26, 2010, on the bmwg-list, please.

Al
bmwg chair

---------------------------------------------------------------
To: IEEE 802.1
Tony Jeffrey, WG Chair [email-masked]
and Pat Thaler, DCB TG Chair [email-masked]
From: IETF-BMWG
Al Morton, WG Chair [email-masked]
For Action/Comment
Deadline: August 1, 2010

Title: Proposal to update RFCs 2544 and 2889 to address the
Per-Flow Control capabilities of IEEE 802.1Qbb

The purpose of this Liaison is to inform you of a new work proposal
in the Benchmarking Methodology Working Group (BMWG) of the IETF, and seek
your comments.

BMWG is considering adding a charter work item to update several of our
fundamental RFCs, described in detail in the memo by D.Newman and T.Player:
http://tools.ietf.org/html/draft-player-dcb-benchmarking-01
In this proposal, there is an intersection between IETF benchmarking
practice and new IEEE standardization work.

Benchmarks for Ethernet switch performance based on RFCs 1242, 2285,
2544 and 2889 are recognized as industry standards. The
terminology and methodology described in these memos has been in
widespread use by test equipment vendors, networking device manufacturers,
enterprises and service providers for more than a decade.

Some concepts in these RFCs are not meaningful when testing switches
that implement new IEEE specifications in the area of data center
bridging. For example, throughput as defined in RFC 1242 cannot be
measured when testing devices that implement three new IEEE
specifications: priority-based flow control (802.1Qbb); priority groups
(802.1Qaz); and congestion notification (802.1Qau).

Since devices that implement these new congestion-management
specifications should never drop frames, and since the metric of
throughput distinguishes between non-zero and zero drop rates, no
throughput measurement is possible using the existing methodology.
There are related cases where other existing metrics can be extended
or replaced.

The Internet-Draft seeks to recognize the importance of these new IEEE
specifications in the context of data center switch benchmarking.
The draft seeks to extend rather than replace existing
industry standard practices for benchmarking switch performance
characteristics in the lab, and it does so by defining new terms
and metrics relevant to recent IEEE work on data center bridging.

The charter of BMWG strictly limits our work to laboratory characterization.
Therefore, live network performance testing, manageability, MIB module
development, and other operational/functional testing is beyond our scope.
http://www.ietf.org/dyn/wg/charter/bmwg-charter

Before considering this work proposal further, we seek your comments on:
  - whether there is overlapping work planned in 802.1
  - whether a liaison relationship could be beneficial to complete this work
  - the proposal details, as currently described

sincerely,
Al Morton
bmwg chair

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 13 Apr 2010 12:09:54 +0200

Looks good, editorial comments in-line. 

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Al Morton
> Sent: Monday, April 12, 2010 7:08 PM
> To: [email-masked]
> Cc: Romascanu, Dan (Dan); Eric Gray
> Subject: [bmwg] Draft Liaison to IEEE 802.1 on DCB proposal
> 
> BMWG,
> 
> The first draft Liaison to IEEE 802.1 describing the proposal 
> to update RFCs 2544 and 2889 to address the Per-Flow Control 
> capabilities of IEEE 802.1Qbb is below. Thanks to David 
> Newman and Eric Gray (IETF Liaison Manager for 802.1) for 
> suggested text and/or background info shared off-list.
> 
> Tony Jeffrey, WG Chair [email-masked] and Pat Thaler, DCB 
> TG Chair [email-masked]
> From: IETF-BMWG
> The purpose of this Liaison is to inform you of a new work 
> proposal in the Benchmarking Methodology Working Group (BMWG) 
> of the IETF, and seek your comments.
> 
> BMWG is considering adding a charter work item to update 
> several of our fundamental RFCs, described in detail in the 

I do not really know what a 'fundamental RFC' is so I suggest to strike
this out or use a more clear term. 

> memo by D.Newman and T.Player:
> In this proposal, there is an intersection between IETF 
> benchmarking practice and new IEEE standardization work.
> 
> terminology and methodology described in these memos has been 

s/has been/have been/

> in widespread use by test equipment vendors, networking 
> device manufacturers, enterprises and service providers for 
> more than a decade.
> 
> Some concepts in these RFCs are not meaningful when testing 
> switches that implement new IEEE specifications in the area 
> of data center bridging. For example, throughput as defined 
> in RFC 1242 cannot be measured when testing devices that 
> implement three new IEEE
> specifications: priority-based flow control (802.1Qbb); 
> priority groups (802.1Qaz); and congestion notification (802.1Qau).
> 
> specifications should never drop frames, and since the metric 
> of throughput distinguishes between non-zero and zero drop 
> rates, no throughput measurement is possible using the 
> existing methodology.
> There are related cases where other existing metrics can be 
> extended or replaced.
> 
> The Internet-Draft seeks to recognize the importance of these 
> new IEEE specifications in the context of data center switch 
> benchmarking.
> industry standard practices for benchmarking switch 
> performance characteristics in the lab, and it does so by 
> defining new terms and metrics relevant to recent IEEE work 
> on data center bridging.
> 
> Therefore, live network performance testing, manageability, 
> MIB module development, and other operational/functional 
> testing is beyond our scope.

s/is beyond/are beyond/

>   - whether a liaison relationship could be beneficial to 

It would be useful to specify what liaison we are asking about -
probably between the BMWG and the IEEE 802.1 (?)

> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bmwg
>

---

From: Al Morton <[email-masked]>
Date: Tue, 13 Apr 2010 10:23:30 -0400

>this out or use a more clear term.

It might be better to say "foundation RFCs", or some other
adjective, but the point is that these RFCs are key ones.

Al

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 13 Apr 2010 16:32:54 +0200

> From: Al Morton [mailto:[email-masked]] 
> Sent: Tuesday, April 13, 2010 5:24 PM
> To: Romascanu, Dan (Dan); [email-masked]
> Cc: Eric Gray
> Subject: RE: [bmwg] Draft Liaison to IEEE 802.1 on DCB proposal
> 
> several of 
> > > our fundamental RFCs, described in detail in the
> >
I think that you mean the RFCs that define the basic metrics and
methodology of IPPM. It would be good to find some exact words around
this definition to be sure that our IEEE 802.1 partners understand
correctly what we mean.

Dan

---

From: David Newman <[email-masked]>
Date: Tue, 13 Apr 2010 08:36:43 -0700

> this definition to be sure that our IEEE 802.1 partners understand

The key concepts from past bmwg work this ID include:

- throughput, as defined in 1242 and described in procedures in 2544 and
2889. In this ID we suggest a replacement metric, queueput, since
throughput measurement is not possible in a DCB device context

- various traffic classification concepts described in 4689

But throughput is the big one, given its widespread use.

dn

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 15 Apr 2010 09:19:06 +0200

> From: Eric Gray [mailto:[email-masked]] 

> 	Never-the-less, it is probably best to include a list 
> of the RFCs referred to in the text Al proposes - especially 
> if it is (as I believe) just these two RFCs.

This would be my preference too. It's good to be clear, especially when
communication with another organization whose participants are not that
familiar with the BMWG core work. 

Dan

---

From: [email-masked]
Date: Thu, 15 Apr 2010 09:16:55 -0700

> familiar with the BMWG core work.

OK. The throughput definition in 1242 -- the one we're saying is not
meaningful for DCB devices -- gets referenced in quite a lot of bmwg work.

RFC1242-style throughput is a significant metric in at least these RFCs,
and possibly others:

1242
2285
2432
2544
2889
3511
3918

And the tests proposed in this ID use concepts discussed in:

1242
2285
2544
2889
4689

dn

---

From: Al Morton <[email-masked]>
Date: Thu, 15 Apr 2010 12:48:50 -0400

Also worth noting, the Title of the Liaison calls-out
2544 and 2889 (both methodologies that depend on terms).

I'll try a revised paragraph later today...

Al