Subject: [bmwg] Fwd: Power measurement

From: Vishwas Manral <[email-masked]>
Date: Sat, 29 May 2010 11:41:17 -0700

Some comments I have got on the draft.

-Vishwas
---------- Forwarded message ----------
From: Vishwas Manral <[email-masked]>
Date: Sat, May 29, 2010 at 11:30 AM
Subject: Re: Power measurement
To: Gordon Brebner <[email-masked]>

Hi Gordon,

Thanks a lot for reading through the draft.

The Benchmarking WG of the IETF, actually specifies 3 drafts -
methodology, terminology and scope. The draft we have will also be
divided into the 3 parts, but the current draft is to start getting
input regarding the same.

For NEPI it is equal to M values as different traffic rates and
average of that would be the NEPI. In a live system if we assume we
take the sample every 5 minutes and use it, it will give the correct
NEPI of the system (the most often used value) if we average out the
last 1 day worth of data.

NECR is something not necessarily there in the paper. It is the metric
I think we can use to do some traffic engineering in the network and
thus optimize power on the global level.

Thanks,
Vishwas

On Sat, May 29, 2010 at 11:14 AM, Gordon Brebner
<[email-masked]> wrote:
> I had a look at this, and also the paper mentioned in the acknowledgements, and see the trajectory from the paper to this draft.  I notice that the draft is really just focusing on the definitions of metrics, as opposed to actual modeling and benchmarking methodology as considered in the paper.  Is the intent just to focus on establishing metrics here?  (I wondered about this, given the title included the word "benchmarking" explicitly.)
>
> In section 5, where you define NEPI, you have a generalized definition compared with the paper, in that you compute an average over n different EPIs.  The text didn't explain what the n different pieces were - I was assuming n different components that constitute the overall system, but then I thought another reading might mean that you establish n different M values at different traffic rates.  What is the intention?
>
> In section 4, you define NECR, which wasn't something that appeared explicitly in the paper.  However, I'm assuming this is basically the "normalized power" metric that is mentioned in the paper.  Is this correct?
>
> Gordon.
>

---

From: Al Morton <[email-masked]>
Date: Sun, 30 May 2010 06:21:41 -0400

Thanks for passing this along, Vishwas.

I think in this specialized case, terms and method could be combined
into one draft and there's certainly no need for a separate scope.
But many other projects have been separated as terms and method.
It's up to you for now (while still an individual submission)...

Al
bmwg chair

At 02:41 PM 5/29/2010, Vishwas Manral wrote:
> > I had a look at this, and also the paper mentioned in the 
> acknowledgements, and see the trajectory from the paper to this 
> draft.  I notice that the draft is really just focusing on the 
> definitions of metrics, as opposed to actual modeling and 
> benchmarking methodology as considered in the paper.  Is the intent 
> just to focus on establishing metrics here?  (I wondered about 
> this, given the title included the word "benchmarking" explicitly.)
> >
> > In section 5, where you define NEPI, you have a generalized 
> definition compared with the paper, in that you compute an average 
> over n different EPIs.  The text didn't explain what the n 
> different pieces were - I was assuming n different components that 
> constitute the overall system, but then I thought another reading 
> might mean that you establish n different M values at different 
> traffic rates.  What is the intention?
> >
> > In section 4, you define NECR, which wasn't something that 
> appeared explicitly in the paper.  However, I'm assuming this is 
> basically the "normalized power" metric that is mentioned in the 
> paper.  Is this correct?
> >
> > Gordon.
> >
>_______________________________________________
>bmwg mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/bmwg