Subject: [bmwg] Traffic Management Submission

From: Barry Constantine <[email-masked]>
Date: Wed, 9 Jan 2013 19:24:22 +0000

Hi BMWG,

On behalf of myself and the co-authors, we prepared a personal submission for Traffic Management benchmarking per our presentation at the Atlanta meeting.

>From the intro section:

This framework describes a practical methodology for benchmarking the traffic management capabilities of networking devices (i.e. policing,  shaping, etc.). The goal is to provide a repeatable test method that objectively compares performance of the device&#39;s traffic management capabilities and to specify the means to benchmark traffic management with representative application traffic.

http://www.ietf.org/internet-drafts/draft-constantine-bmwg-traffic-management-00.txt

We continue to work on this and you will see placeholders in areas that we have work in progress, but we wanted to get this submitted to better facilitate early feedback.

We would like to present this at the next IETF meeting in Orlando and hopefully be accepted as formal work within BMWG.

Thank you,
Barry Constantine
Tim Copley
Ramki Krishnan

---

From: "MORTON JR., ALFRED (AL)" <[email-masked]>
Date: Wed, 9 Jan 2013 14:44:15 -0500

BMWG,

Please take a look at this draft, and give your impressions on relevance or other comments
on the list.  We'll be undertaking re-chartering discussions soon.

regards,
Al
bmwg chair

From: [email-masked] [mailto:[email-masked]] On Behalf Of Barry Constantine
Sent: Wednesday, January 09, 2013 2:24 PM
To: [email-masked]
Subject: [bmwg] Traffic Management Submission

Hi BMWG,

Thank you,
Barry Constantine
Tim Copley
Ramki Krishnan

---

From: Barry Constantine <[email-masked]>
Date: Thu, 10 Jan 2013 13:02:46 +0000

Hi Al,

I seem to recall you mentioned re-chartering during the Atlanta meeting; can you summarize the general topic and how BMWG might be re-chartered / expanded?

Thank you,
Barry Constantine

JDSU Communications Test
Principal Member Technical Staff
301-325-7069

From: MORTON JR., ALFRED (AL) [mailto:[email-masked]]
Sent: Wednesday, January 09, 2013 2:44 PM
To: Barry Constantine; [email-masked]
Subject: RE: Traffic Management Submission

BMWG,

regards,
Al
bmwg chair

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Barry Constantine
Sent: Wednesday, January 09, 2013 2:24 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [bmwg] Traffic Management Submission

Hi BMWG,

Thank you,
Barry Constantine
Tim Copley
Ramki Krishnan

---

From: "MORTON JR., ALFRED (AL)" <[email-masked]>
Date: Thu, 10 Jan 2013 08:29:45 -0500

In one sentence, we delete the bullet items describing specific work
we've completed, and add new ones the wg agrees on.

Al
bmwg chair

From: Barry Constantine [mailto:[email-masked]]
Sent: Thursday, January 10, 2013 8:03 AM
To: MORTON JR., ALFRED (AL); [email-masked]
Subject: RE: Traffic Management Submission

Hi Al,

Thank you,
Barry Constantine

JDSU Communications Test

BMWG,

regards,
Al
bmwg chair

Hi BMWG,

Thank you,
Barry Constantine
Tim Copley
Ramki Krishnan

---

From: Barry Constantine <[email-masked]>
Date: Fri, 11 Jan 2013 12:18:27 +0000

OK Al, that makes sense.

I'll use this email to explore a topic that probably has been discussed in BMWG before.

First some background.  It's common for a network provider to conduct lab based benchmarking and pre-deployment testing during the design phase of a new network.  In many cases, the network engineer responsible for lab testing, writes the operational installation tests for the field technicians.

This explains how RFC 2544 made it's way into field testing.

Another example is the SIP metrics developed by this group.  Those metrics (even in draft form) were an excellent means to establish common measurements and are also used in operational management systems.

I realize the core charter of BMWG is to produce test processes and benchmarks in a lab environment, but as I said above, in practice the lab network engineers are also responsible for field test procedures.

So here is the rub; even though BMWG charter does not cover operational networks, should we consider language (perhaps a dedicated paragraph) that explicitly states which components would be harmful to production networks?  It may save the headache that RFC 6815 tried to correct and this would also provide guidance for those readers who may seek to adopt portions of the test to operational networks.

OK, hope this makes sense and am trying to be proactive.

Thank you,
Barry Constantine

JDSU Communications Test

From: MORTON JR., ALFRED (AL) [mailto:[email-masked]]
Sent: Thursday, January 10, 2013 8:30 AM
To: Barry Constantine; [email-masked]
Subject: RE: Traffic Management Submission

Al
bmwg chair

From: Barry Constantine [mailto:[email-masked]]
Sent: Thursday, January 10, 2013 8:03 AM
To: MORTON JR., ALFRED (AL); [email-masked]<mailto:[email-masked]>
Subject: RE: Traffic Management Submission

Hi Al,

Thank you,
Barry Constantine

JDSU Communications Test

From: MORTON JR., ALFRED (AL) [mailto:[email-masked]]
Sent: Wednesday, January 09, 2013 2:44 PM
To: Barry Constantine; [email-masked]<mailto:[email-masked]>
Subject: RE: Traffic Management Submission

BMWG,

regards,
Al
bmwg chair

Hi BMWG,

Thank you,
Barry Constantine
Tim Copley
Ramki Krishnan

---

From: "MORTON JR., ALFRED (AL)" <[email-masked]>
Date: Fri, 11 Jan 2013 07:50:38 -0500

That's an interesting idea, a standard section of bmwg memos that

-    points to RFC 6815 http://tools.ietf.org/html/rfc6815

-    indicates ways that application of the described lab methods

could be harmful if used beyond their scope

-    emphasizes that these are non-exhaustive examples

-    suggests that application of these lab methods should

result in development of a new standard intended for production nets

What do others think?

Al
bmwg chair

From: Barry Constantine [mailto:[email-masked]]
Sent: Friday, January 11, 2013 7:18 AM
To: MORTON JR., ALFRED (AL); [email-masked]
Subject: RE: Traffic Management Submission

OK Al, that makes sense.

Thank you,
Barry Constantine

JDSU Communications Test

Al
bmwg chair

Hi Al,

Thank you,
Barry Constantine

JDSU Communications Test

BMWG,

regards,
Al
bmwg chair

Hi BMWG,

Thank you,
Barry Constantine
Tim Copley
Ramki Krishnan