Subject: [bmwg] new draft for data center benchmarking: draft-dcbench-def

From: "Lucien Avramov (lavramov)" <[email-masked]>
Date: Wed, 05 Jun 2013 11:06:56 -0700

Hi BMWG,

At IETF 86, Jacob presented the idea for a data center benchmarking 
definition and methodology. Our goal is to create data center specific 
benchmarking guidance as this differs in multiple areas from usual 
general purpose benchmarking.

Thanks to the feedback, we adopted the recommendation to break our work 
into multiple drafts.

The first draft explaining the concepts and definitions relative to data 
center benchmarking of network equipment is posted here:
http://www.ietf.org/id/draft-dcbench-def-00.txt

Please provide non-editorial comments to the list and editorial comments 
directly to me.

We are looking forward to hear from you.

Cheers,
Lucien

---

From: ramki Krishnan <[email-masked]>
Date: Tue, 18 Jun 2013 10:37:18 -0700

Thanks Lucien -- this draft is certainly useful. Please find comments below.

>> For bit forwarding devices: The time interval starting when the end
   of the first bit of the input frame reaches the input port and ending
   when the start of the first bit of the output frame is seen on the
   output port.

Please add the cut-through switching aspect for additional clarity.

>> section 7.2., 7.3

Given the wide variation in servers, adapters, OS, Virtualized/non-virtualized  environments etc. it may be hard to benchmark goodput. Perhaps a useful metric to benchmark would be the tcp performance in a pure test environment.

>> 6.1 buffer size

Need to cover buffering per priority (typically 8 priorities) besides port and global.

Thanks,
Ramki

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Lucien Avramov (lavramov)
Sent: Wednesday, June 05, 2013 11:07 AM
To: [email-masked]
Subject: [bmwg] new draft for data center benchmarking: draft-dcbench-def

Hi BMWG,

At IETF 86, Jacob presented the idea for a data center benchmarking definition and methodology. Our goal is to create data center specific benchmarking guidance as this differs in multiple areas from usual general purpose benchmarking.

Thanks to the feedback, we adopted the recommendation to break our work into multiple drafts.

The first draft explaining the concepts and definitions relative to data center benchmarking of network equipment is posted here:
http://www.ietf.org/id/draft-dcbench-def-00.txt

Please provide non-editorial comments to the list and editorial comments directly to me.

Cheers,
Lucien

_______________________________________________
bmwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bmwg