Subject: [bmwg] draft-morton-bmwg-virtual-net-00

From: Bhavani Parise <[email-masked]>
Date: Wed, 19 Mar 2014 00:02:49 -0700

Al,
    including the WG list also for my comments/Qs for this draft. These 
are a few
things which we can look into including as considerations for this draft.

- do we need to consider or compare performance with the real/physical 
network vs. the virtual network
- in 3.2 do we need Virtual Switch
- also for 3.2 - for VNF itself, do we need location of the VNF - guest 
VM,separate process, appliance etc
- for 3.2 how about load balancers, firewalls - do we need to consider, 
what kind of DPI
    - firewalls - stateful vs stateless
    - what kind of considerations we need to note when testing a Virtual
Firewall Function
- how many Tenants can a VNF support?
- for 3.3 - how about VM mobility or VNF mobility itself

thanks,
Bhavani
________________________________________

---

From: Muhammad Durrani <[email-masked]>
Date: Wed, 19 Mar 2014 00:27:14 -0700

Hi Bhavani,

- do we need to consider or compare performance with the real/physical network vs. the virtual network
- in 3.2 do we need Virtual Switch

[MD] We do need to provide methodologies to benchmark for three architectures vSwitch/SR-IOV and PCI bypass.
Regarding comparing performance only PCI bypass can be compared with physical world.  Again we are not benchmarking networks here but the virtual appliance and wherever needed comparison will be laid out for both Physical and virtual appliance.

for 3.2 how about load balancers, firewalls - do we need to consider, what kind of DPI
    - firewalls - stateful vs stateless
[MD] Virtual appliance is broader term - it means virtual Load balancer  and firewalls (both state full and stateless)
We won't be suggesting "kind of DPI" - Standard method will be provided to qualify appliance for any type of DPI  

Regards,
Muhammad
-----Original Message-----
From: bmwg [mailto:[email-masked]] On Behalf Of Bhavani Parise
Sent: Wednesday, March 19, 2014 12:03 AM
To: [email-masked]
Subject: [bmwg] draft-morton-bmwg-virtual-net-00

Al,
    including the WG list also for my comments/Qs for this draft. These are a few things which we can look into including as considerations for this draft.

- also for 3.2 - for VNF itself, do we need location of the VNF - guest VM,separate process, appliance etc
- 
    - what kind of considerations we need to note when testing a Virtual Firewall Function
- how many Tenants can a VNF support?
- for 3.3 - how about VM mobility or VNF mobility itself

thanks,
Bhavani

_______________________________________________
bmwg mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/bmwg

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 19 Mar 2014 20:25:29 -0400

Let me just add that the physical-virtual function comparisons *should*
be a part of this where it makes sense - but for VNF configurations which do not
match-up we should be able to say why.

Also, I've seen the "tenant" terminology applied at a fairly high level of 
participation in cloud computing environments - below are "active" tenants
who have requested some number of VMs to serve their apps. But now things
become more vague (cloudy?) because the design of the VNF and it's components
could serve multiple parties, span  multiple VMs, etc.

Al

________________________________________
From: bmwg [[email-masked]] On Behalf Of Muhammad Durrani [[email-masked]]
Sent: Wednesday, March 19, 2014 3:27 AM
To: Bhavani Parise; [email-masked]
Subject: Re: [bmwg] draft-morton-bmwg-virtual-net-00

Hi Bhavani,

Regards,
Muhammad
-----Original Message-----
From: bmwg [mailto:[email-masked]] On Behalf Of Bhavani Parise
Sent: Wednesday, March 19, 2014 12:03 AM
To: [email-masked]
Subject: [bmwg] draft-morton-bmwg-virtual-net-00

Al,

thanks,
Bhavani