Subject: Re: [bmwg] first WGLC on draft-ietf-bmwg-traffic

From: "Bhuvaneswaran Vengainathan" <[email-masked]>
Date: Tue, 7 Oct 2014 16:42:51 +0530

Hello Authors,

It is nice to see a set of tests defined for benchmarking traffic management
functions. I quickly browse through the draft and the draft is in good shape
except some fine tuning aspects. 
I have a few comments and queries on this draft which I believe would help
to fine tune the draft.

1. Section 1.1 - Page 5 refers MEF specification. It is good to add some
references for this.
2. It would be good to provide definitions for some of the terms e.g BDP, BB
used in this draft.
3. Section 4 - It would be good to provide measurement unit for the metrics
defined in this section e.g, Packet Delay, expressed in millisecond.
4. Section 4.1 - Assume the Packet Delay is computed based on timestamp in
the packet's payload. If yes, suggest including a cautionary note that the
transmitting host and receiving host time must be in SYNC. Probably the
methods of time sync could be out of this document's scope.
5. Section 4.2 Page 10 - While calculating TCP efficiency, the calculation
subtracts the retransmission bytes from the transmitted bytes. But the
retransmission can be either due to issue with the traffic management
function, NDE element or Receiver TCP/IP. It would be good to add more
clarity on the measurement point.
6. Section 6 - The draft assumes the scheduling and shaping functionalities
are applied on physical port. But there are cases especially in service
provider environment, these functionalities are applied on logical ports as
well. A note capturing this would be of help.
7. Are you planning to cover tests for AQM, Color Aware mode etc., as part
of this draft or in a separate draft?

Regards,
Bhuvan | Cloud and SDN Solutions
Phone: +91 44 4567 2222 x242
Mobile: +91 988 428 6693 
www.veryxtech.com

> -----Original Message-----
> From: bmwg [mailto:[email-masked]] On Behalf Of MORTON,
> ALFRED C (AL)
> Sent: Tuesday, September 23, 2014 6:26 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [bmwg] first WGLC on draft-ietf-bmwg-traffic
> 
> BMWG (and AQM):
> 
> A WG Last Call period for the Internet-Draft on Traffic Management
> Benchmarking:
> 
>    http://tools.ietf.org/html/draft-ietf-bmwg-traffic-management
> 
> will be open from 23 September 2014 through October 21 2014.
> 
> These drafts are beginning the BMWG Last Call Process. See
> http://www1.ietf.org/mail-archive/web/bmwg/current/msg00846.html
> 
> which says:
> ...
> The primary change is a requirement that approximately four WG members
> complete a review template for the draft (or set of drafts), upon entry to
the
> Last Call Process. The WG reviewers should be outside the body of active
> contributors (editors + authors).
> The goal is to produce a quality review with valuable feedback on the
> draft(s), and not to set a minimum number of people willing to complete
the
> review template. Directed feedback, regardless of quantity, is a better
> condition by which BMWG can more clearly assess a draft's readiness to
> advance.
> (the template is appended to the archived message)
> 
> Please read and express your opinion on whether or not these Internet-
> Drafts should be forwarded to the Area Directors for publication as
> Informational RFCs.  Send your comments to this list or [email-masked]
> and [email-masked]
> 
> Al
> bmwg co-chair
> 
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bmwg

---

From: ramki Krishnan <[email-masked]>
Date: Fri, 10 Oct 2014 08:50:00 -0700

Hi Bhuvan,

Many thanks for your detailed comments, we will address them in the next revision. Our desire is to address AQM in a separate draft.

Thanks,
Ramki

-----Original Message-----
From: Bhuvaneswaran Vengainathan [mailto:[email-masked]] 
Sent: Tuesday, October 07, 2014 4:13 AM
To: [email-masked]
Cc: ramki Krishnan; 'Anton Basil'
Subject: RE: [bmwg] first WGLC on draft-ietf-bmwg-traffic

Hello Authors,

It is nice to see a set of tests defined for benchmarking traffic management functions. I quickly browse through the draft and the draft is in good shape except some fine tuning aspects. 
I have a few comments and queries on this draft which I believe would help to fine tune the draft.

1. Section 1.1 - Page 5 refers MEF specification. It is good to add some references for this.
2. It would be good to provide definitions for some of the terms e.g BDP, BB used in this draft.
3. Section 4 - It would be good to provide measurement unit for the metrics defined in this section e.g, Packet Delay, expressed in millisecond.
4. Section 4.1 - Assume the Packet Delay is computed based on timestamp in the packet's payload. If yes, suggest including a cautionary note that the transmitting host and receiving host time must be in SYNC. Probably the methods of time sync could be out of this document's scope.
5. Section 4.2 Page 10 - While calculating TCP efficiency, the calculation subtracts the retransmission bytes from the transmitted bytes. But the retransmission can be either due to issue with the traffic management function, NDE element or Receiver TCP/IP. It would be good to add more clarity on the measurement point.
6. Section 6 - The draft assumes the scheduling and shaping functionalities are applied on physical port. But there are cases especially in service provider environment, these functionalities are applied on logical ports as well. A note capturing this would be of help.
7. Are you planning to cover tests for AQM, Color Aware mode etc., as part of this draft or in a separate draft?

Regards,

> From: bmwg [mailto:[email-masked]] On Behalf Of MORTON, ALFRED 
> C (AL)
the
> Last Call Process. The WG reviewers should be outside the body of 
> active contributors (editors + authors).
the
> review template. Directed feedback, regardless of quantity, is a 
> better condition by which BMWG can more clearly assess a draft's 
> readiness to advance.
> Informational RFCs.  Send your comments to this list or 
> [email-masked] and [email-masked]
> 
> Al
> bmwg co-chair
>