Subject: [bmwg] FW: I-D Action: draft-banks-bmwg-issu-meth-05.txt

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Mon, 27 Oct 2014 11:42:24 -0400

BMWG,

We've been discussing a draft for In Service Software Upgrade
for quite some time.

Now that our new charter is approved (and ISSU is included), we ask
everyone to take a look (by Nov 13th) and express comments/support.

The latest draft is here:
http://tools.ietf.org/html/draft-banks-bmwg-issu-meth-05

regards,
Al
bmwg co-chair

> -----Original Message-----
> From: I-D-Announce [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Wednesday, October 08, 2014 8:16 PM
> To: [email-masked]
> Subject: I-D Action: draft-banks-bmwg-issu-meth-05.txt
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> 
> 
>         Title           : ISSU Benchmarking Methodology
>         Authors         : Sarah Banks
>                           Fernando Calabria
>                           Gery Czirjak
>                           Ramdas Machat
> 	Filename        : draft-banks-bmwg-issu-meth-05.txt
> 	Pages           : 19
> 	Date            : 2014-10-08
> 
> Abstract:
>    Modern forwarding devices attempt to minimize any control and data
>    plane disruptions while performing planned software changes, by
>    implementing a technique commonly known as an In Service Software
>    Upgrade (ISSU).
> 
>    This document specifies a set of common methodologies and procedures
>    designed to characterize the overall behavior of a Device Under Test
>    (DUT), subject to an ISSU event.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-banks-bmwg-issu-meth/
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-banks-bmwg-issu-meth-05
> 
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-banks-bmwg-issu-meth-05
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Lucien Avramov (lavramov)" <[email-masked]>
Date: Tue, 28 Oct 2014 13:17:50 +0100

BMWG,

I support this draft. It addresses the ISSU requirements and is clearly
defined for the SP market, my comments earlier in the mailer were
regarding Data Center devices and clearly that is not the scope of this
document. I would like to see this adopted moving forward.

Cheers,
Lucien

On 10/27/14, 4:42 PM, MORTON, ALFRED C (AL) wrote:
> bmwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bmwg
>

---

From: Isaiah Weiner <[email-masked]>
Date: Tue, 28 Oct 2014 08:54:55 -0700

BMWG,

    I've read this draft and I think it is very useful to the industry.  It
will help level set testing of vendors in my lab.  I support this draft.

On Mon, Oct 27, 2014 at 8:42 AM, MORTON, ALFRED C (AL) <[email-masked]
> wrote:

> --
    - Isaiah

---

From: Sarah Banks <[email-masked]>
Date: Tue, 28 Oct 2014 10:51:29 -0700

Hello BMWG,
	As an author, I clearly have no problem with the draft, and support it. I appreciate any further reviews and comments here to the list.

Kind regards,
Sarah

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 29 Oct 2014 15:43:26 +0000

Hi, Al,

I support adoption of this draft.

It seems like a great starting point at addressing the ISSU milestone, which rapidly approaching:
  Mar 2015 - Draft on In-Service Software Upgrade Benchmarking to IESG Review

Thanks,

Carlos.

> On Oct 27, 2014, at 11:42 AM, MORTON, ALFRED C (AL) <[email-masked]> wrote:
> 
> BMWG,
>