Subject: Re: [bmwg] WG ADOPTION: draft-bhuvan-bmwg-of-controller-benchmarking (terms and meth)

From: Jacob Rapp <[email-masked]>
Date: Mon, 12 Oct 2015 14:27:53 +0000

As I mentioned during the meetings, I still do not agree with the use of “SDN Controller” here. SDN is a broad term and the drafts seem to be focused on OpenFlow controllers. If there is a more concise definition, why not use it (OpenFlow vs. SDN)?

—
Jacob

On 9/22/15, 10:08 PM, "bmwg on behalf of MORTON, ALFRED C (AL)" <[email-masked] on behalf of [email-masked]> wrote:

>BMWG,
>
>According to our minutes of IETF-93:
>https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_proceedings_93_minutes_minutes-2D93-2Dbmwg&d=BQICAg&c=Sqcl0Ez6M0X8aeM67LKIiDJAXVeAw-YihVMNtXt-uEs&r=4eVZvh2C5Un5N5XXv1rh7g&m=3oSHyL4yf3qce7gHDk6RRcFlnDn0fE7E4x4ZrAE4ciU&s=yHLFC_S7xKVwxUTrxkgAO2Wv6TERINPx3asK-NV5mes&e= 
>
>those present expressed support to adopt:
>
>Benchmarking Terminology and Methodology for SDN Controller Performance	
>https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org_html_draft-2Dbhuvan-2Dbmwg-2Dsdn-2Dcontroller-2Dbenchmark-2Dterm-2D00&d=BQICAg&c=Sqcl0Ez6M0X8aeM67LKIiDJAXVeAw-YihVMNtXt-uEs&r=4eVZvh2C5Un5N5XXv1rh7g&m=3oSHyL4yf3qce7gHDk6RRcFlnDn0fE7E4x4ZrAE4ciU&s=rNtr6etgVTlWeAJHy5326lR9hl3-6rAyfu95MVs8UPI&e= 
>https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org_html_draft-2Dbhuvan-2Dbmwg-2Dof-2Dcontroller-2Dbenchmarking-2D01&d=BQICAg&c=Sqcl0Ez6M0X8aeM67LKIiDJAXVeAw-YihVMNtXt-uEs&r=4eVZvh2C5Un5N5XXv1rh7g&m=3oSHyL4yf3qce7gHDk6RRcFlnDn0fE7E4x4ZrAE4ciU&s=4Xz1K2D3X45eEIjJF3HXEGwLlR2UB8-mrrWG8dsdA7k&e= 
>
>as a chartered work item.
>
>We now seek to confirm that support on the mailing list.
>
>Please reply with your opinion whether the BMWG should adopt
>these drafts, whether you have read the drafts, and any comments
>on the drafts or this call for adoption.
>
>Deadline: October 13, 2015
>
>thanks for your attention,
>Al
>bmwg co-chair
>
>_______________________________________________
>bmwg mailing list
>[email-masked]
>https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bmwg&d=BQICAg&c=Sqcl0Ez6M0X8aeM67LKIiDJAXVeAw-YihVMNtXt-uEs&r=4eVZvh2C5Un5N5XXv1rh7g&m=3oSHyL4yf3qce7gHDk6RRcFlnDn0fE7E4x4ZrAE4ciU&s=-3y2976SCSn9LYAEU6lrZ_ZMDeocMmZ3ByRSBw5qFSw&e=

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Mon, 12 Oct 2015 10:46:11 -0400

Hi Jacob, Thanks for your comment.

There may be a way to resolve your comment through better definitions.
However, when the draft was first introduced, one of my comments
(with which several people agreed) was to avoid making this 
Openflow-specific.  

We could say, "For the purposes of this memo,
SDN Controller is defined as..."
or
We could choose some name more specific to the role the 
controller performs "...in SDN"

I'll re-post part of the thread I'm referring to.

regards,
Al
(as a participant)

> -----Original Message-----
> From: Jacob Rapp [mailto:[email-masked]]
> Sent: Monday, October 12, 2015 10:28 AM
> To: MORTON, ALFRED C (AL); [email-masked]
> Subject: Re: [bmwg] WG ADOPTION: draft-bhuvan-bmwg-of-controller-
> benchmarking (terms and meth)
> 
> As I mentioned during the meetings, I still do not agree with the use of
> “SDN Controller” here. SDN is a broad term and the drafts seem to be
> focused on OpenFlow controllers. If there is a more concise definition,
> why not use it (OpenFlow vs. SDN)?
> 
> —
> Jacob
> 
> 
> 
> On 9/22/15, 10:08 PM, "bmwg on behalf of MORTON, ALFRED C (AL)" <bmwg-
> [email-masked] on behalf of [email-masked]> wrote:
> 
> >BMWG,
> >
> >https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_proce
> >edings_93_minutes_minutes-2D93-2Dbmwg&d=BQICAg&c=Sqcl0Ez6M0X8aeM67LKIiD
> >JAXVeAw-YihVMNtXt-uEs&r=4eVZvh2C5Un5N5XXv1rh7g&m=3oSHyL4yf3qce7gHDk6RRc
> >FlnDn0fE7E4x4ZrAE4ciU&s=yHLFC_S7xKVwxUTrxkgAO2Wv6TERINPx3asK-NV5mes&e=
> >
> >https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org_html
> >_draft-2Dbhuvan-2Dbmwg-2Dsdn-2Dcontroller-2Dbenchmark-2Dterm-2D00&d=BQI
> >CAg&c=Sqcl0Ez6M0X8aeM67LKIiDJAXVeAw-YihVMNtXt-uEs&r=4eVZvh2C5Un5N5XXv1r
> >h7g&m=3oSHyL4yf3qce7gHDk6RRcFlnDn0fE7E4x4ZrAE4ciU&s=rNtr6etgVTlWeAJHy53
> >26lR9hl3-6rAyfu95MVs8UPI&e=
> >https://urldefense.proofpoint.com/v2/url?u=http-3A__tools.ietf.org_html
> >_draft-2Dbhuvan-2Dbmwg-2Dof-2Dcontroller-2Dbenchmarking-2D01&d=BQICAg&c
> >=Sqcl0Ez6M0X8aeM67LKIiDJAXVeAw-YihVMNtXt-uEs&r=4eVZvh2C5Un5N5XXv1rh7g&m
> >=3oSHyL4yf3qce7gHDk6RRcFlnDn0fE7E4x4ZrAE4ciU&s=4Xz1K2D3X45eEIjJF3HXEGwL
> >lR2UB8-mrrWG8dsdA7k&e=
> >
> >Please reply with your opinion whether the BMWG should adopt these
> >drafts, whether you have read the drafts, and any comments on the
> >drafts or this call for adoption.
> >
> >https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailm
> >an_listinfo_bmwg&d=BQICAg&c=Sqcl0Ez6M0X8aeM67LKIiDJAXVeAw-YihVMNtXt-
> uEs&r=4eVZvh2C5Un5N5XXv1rh7g&m=3oSHyL4yf3qce7gHDk6RRcFlnDn0fE7E4x4ZrAE4c
> iU&s=-3y2976SCSn9LYAEU6lrZ_ZMDeocMmZ3ByRSBw5qFSw&e=

---

From: Vishwas Manral <[email-masked]>
Date: Mon, 12 Oct 2015 07:58:20 -0700

Al,

I support the effort.

Jacob, I think we may need to further sharpen the term SDN Controller - I
however agree with Al we don't want to be focused on OF only

Thanks,
Vishwas
On Oct 12, 2015 7:29 AM, "Jacob Rapp" <[email-masked]> wrote:

> focused on OpenFlow controllers. If there is a more concise definition, why
> not use it (OpenFlow vs. SDN)?
>
> —
> Jacob
>
>
>
> On 9/22/15, 10:08 PM, "bmwg on behalf of MORTON, ALFRED C (AL)" <
> [email-masked] on behalf of [email-masked]> wrote:
>
> >BMWG,
> >
> https://www.ietf.org/mailman/listinfo/bmwg
>