Subject: [bmwg] REG: draft-vsperf-bmwg-vswitch-opnfv-02

From: Sudhin Jacob <[email-masked]>
Date: Sat, 9 Jul 2016 05:39:51 +0000

Respected Authors,

 The draft is comprehensive and covers most of the aspects the benchmarking parameters. However I have some queries kindly clarify.

In section 5.9 contains matrix of scale  in activation and operation.

Could you please let me know whether benchmarking the  Vswitch performance by  measuring the time taken to learn the maximum capacity of switch mac address, clear it and relearn.

Could you please let me know the stressful scenarios mentioned in section 2 of the draft.

Could you please let me know, correct me if I am wrong  the Vswitch must be benchmarked with negative scenarios.

Regards,
Sudhin

---

From: "Tahhan, Maryam" <[email-masked]>
Date: Wed, 13 Jul 2016 10:53:32 +0000

Hi Sudhin

Comments inline below.

Best Regards,
Maryam

From: bmwg [mailto:[email-masked]] On Behalf Of Sudhin Jacob
Sent: Saturday, July 9, 2016 6:40 AM
To: [email-masked]
Subject: [bmwg] REG: draft-vsperf-bmwg-vswitch-opnfv-02

Respected Authors,

<MT> I'm not sure I understand the question here was there a missing part to the question above? can you please clarify what you are asking?

Could you please let me know the stressful scenarios mentioned in section 2 of the draft.
<MT> Scenarios where you stress the CPU, Memory, scaling the number of flows and VNFs attached to the vswitch, bringing up a number of VNFs together... while the vswitch is in operation.

Regards,
Sudhin

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 13 Jul 2016 08:01:17 -0400

Hi Sudhin and Maryam,

Thanks for your review and comments so far.

In addition to Maryam's request below,
I want to ask for an additional clarification, Sudhin,

You last question mentions "negative scenarios".
What sort of things are you imagining?
(the term is unfamiliar to me).

thanks,
Al

From: bmwg [mailto:[email-masked]] On Behalf Of Tahhan, Maryam
Sent: Wednesday, July 13, 2016 6:54 AM
To: Sudhin Jacob; [email-masked]
Subject: Re: [bmwg] REG: draft-vsperf-bmwg-vswitch-opnfv-02

Hi Sudhin

Comments inline below.

Best Regards,
Maryam

From: bmwg [mailto:[email-masked]] On Behalf Of Sudhin Jacob
Sent: Saturday, July 9, 2016 6:40 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [bmwg] REG: draft-vsperf-bmwg-vswitch-opnfv-02

Respected Authors,

Regards,
Sudhin

---

From: Sudhin Jacob <[email-masked]>
Date: Wed, 13 Jul 2016 12:36:48 +0000

Hi Maryam,

Apologies for the confusion.  Let me explain.

Let  the Vswitch mac address table limit is "X"  macs , measure the time taken to learn "X" in steady state. Normally in switches there is a command to clear all mac address  by executing "clear mac address table" to clear all the entries.
After that measure the time taken to relearn "X" macs let it be t'.

Couple of scenarios are there but not sure which is applicable to Vswitch.

Regards,
Sudhin

From: Tahhan, Maryam [mailto:[email-masked]]
Sent: Wednesday, July 13, 2016 4:24 PM
To: Sudhin Jacob <[email-masked]>; [email-masked]
Subject: RE: REG: draft-vsperf-bmwg-vswitch-opnfv-02

Hi Sudhin

Comments inline below.

Best Regards,
Maryam

Respected Authors,

Regards,
Sudhin

---

From: Sudhin Jacob <[email-masked]>
Date: Wed, 13 Jul 2016 12:48:48 +0000

Hi Al,

Apologies for the confusion.

In performance testing, negative scenarios are considered as the paramount . Let me explain, this scenarios includes wide range of tests like link flap, reboot, reset line cards,  scale to maximum mac limits and then forcibly clear the entries and then relearn etc.
In Vswitch which is an instance created in a server so the scenarios can be tailored made to cater the virtual environment. Correct me if I am wrong.

Regards,
Sudhin

From: MORTON, ALFRED C (AL) [mailto:[email-masked]]
Sent: Wednesday, July 13, 2016 5:31 PM
To: Tahhan, Maryam <[email-masked]>; Sudhin Jacob <[email-masked]>; [email-masked]
Subject: RE: REG: draft-vsperf-bmwg-vswitch-opnfv-02

Hi Sudhin and Maryam,

thanks,
Al

From: bmwg [mailto:[email-masked]] On Behalf Of Tahhan, Maryam
Sent: Wednesday, July 13, 2016 6:54 AM
To: Sudhin Jacob; [email-masked]<mailto:[email-masked]>
Subject: Re: [bmwg] REG: draft-vsperf-bmwg-vswitch-opnfv-02

Hi Sudhin

Comments inline below.

Best Regards,
Maryam

Respected Authors,

Regards,
Sudhin

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 13 Jul 2016 18:13:16 -0400

Hi Sudhin,

VSPERF has address caching capacity and address learning rate
(see https://wiki.opnfv.org/display/vsperf/LTD+Test+Spec+Overview)
but this doesn't include clear and re-learning.

You've also listed a series of tests where the performance
measurement is "recovery time", and implicitly determine if
recovery from link flap, NIC reset, reboot, etc., is successful.
But the recovery times may not be very interesting for virtual functions
(so *many* operations have to happen in the case of reboot)
and they may involve manual operations in some cases.

Also, we don't include pass/fail functional tests in BMWG's charter,
we're all about performance.

Al

From: Sudhin Jacob [mailto:[email-masked]]
Sent: Wednesday, July 13, 2016 8:49 AM
To: MORTON, ALFRED C (AL)
Cc: Tahhan, Maryam; [email-masked]
Subject: RE: REG: draft-vsperf-bmwg-vswitch-opnfv-02

Hi Al,

Regards,
Sudhin

From: MORTON, ALFRED C (AL) [mailto:[email-masked]]
Sent: Wednesday, July 13, 2016 5:31 PM
To: Tahhan, Maryam <[email-masked]<mailto:[email-masked]>>; Sudhin Jacob <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: REG: draft-vsperf-bmwg-vswitch-opnfv-02

Hi Sudhin and Maryam,

thanks,
Al

Hi Sudhin

Comments inline below.

Best Regards,
Maryam

Respected Authors,

Regards,
Sudhin

---

From: joel jaeggli <[email-masked]>
Date: Wed, 13 Jul 2016 18:41:57 -0700

On 7/13/16 5:48 AM, Sudhin Jacob wrote:
> In performance testing, negative scenarios are considered as the
> paramount . Let me explain, this scenarios includes wide range of tests
> like link flap, reboot, reset line cards,  scale to maximum mac limits
> and then forcibly clear the entries and then relearn etc.

I am not sure these are negative scenarios, so much as they are scenarios.

Being interested in measurement both of limits and performance at the
limits as well as case of faliure and restoration is certainly fair game
but not obligatory.

> In Vswitch which is an instance created in a server so the scenarios can
> be tailored made to cater the virtual environment. Correct me if I am wrong.
> 
>  
> 
> Regards,
> 
> Sudhin
> 
>  
> 
> *From:*MORTON, ALFRED C (AL) [mailto:[email-masked]]
> *Sent:* Wednesday, July 13, 2016 5:31 PM
> *To:* Tahhan, Maryam <[email-masked]>; Sudhin Jacob
> <[email-masked]>; [email-masked]
> *Subject:* RE: REG: draft-vsperf-bmwg-vswitch-opnfv-02
> 
>  
> 
> Hi Sudhin and Maryam,
> 
>  
> 
> In addition to Maryam’s request below,
> 
> You last question mentions “negative scenarios”.
> 
> *From:*bmwg [mailto:[email-masked]] *On Behalf Of *Tahhan, Maryam
> *Sent:* Wednesday, July 13, 2016 6:54 AM
> *To:* Sudhin Jacob; [email-masked] <mailto:[email-masked]>
> *Subject:* Re: [bmwg] REG: draft-vsperf-bmwg-vswitch-opnfv-02
> 
>  
> 
> Hi Sudhin
> 
>  
> 
> Comments inline below.
> 
>  
> 
> Best Regards,
> Maryam
> 
>  
> 
> *From:*bmwg [mailto:[email-masked]] *On Behalf Of *Sudhin Jacob
> *Sent:* Saturday, July 9, 2016 6:40 AM
> *To:* [email-masked] <mailto:[email-masked]>
> *Subject:* [bmwg] REG: draft-vsperf-bmwg-vswitch-opnfv-02
> 
>  
> 
> Respected Authors,
> 
>  
> 
> The draft is comprehensive and covers most of the aspects the
> benchmarking parameters. However I have some queries kindly clarify.
> 
>  
> 
> Could you please let me know whether benchmarking the  Vswitch
> performance by  measuring the time taken to learn the maximum capacity
> of switch mac address, clear it and relearn.
> 
>  
> 
> <MT> I’m not sure I understand the question here was there a missing
> part to the question above? can you please clarify what you are asking?
> 
>  
> 
> <MT> Scenarios where you stress the CPU, Memory, scaling the number of
> flows and VNFs attached to the vswitch, bringing up a number of VNFs
> together… while the vswitch is in operation.
> 
>  
> 
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bmwg
>