Subject: [bmwg] IETF-96 session: Agenda requests and Remote Participation

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Sat, 2 Jul 2016 14:18:57 -0400

BMWG,

Please send requests for agenda time, along with the issues
you wish to discuss and the related drafts, to the chairs:
[email-masked] and [email-masked] 

IOW, if you have an issue you'd like to discuss on 
*any* WG draft, this is a chance to spend some 
valuable face2face time to resolve it efficiently!

Also, for folks participating remotely, or those who
would like to present remotely, please let us know who you
are (and other details). The WG chairs must take some 
steps with our friends at Meetecho to make this possible.

thanks,
bmwg co-chairs

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Mon, 11 Jul 2016 12:58:26 -0400

BMWG,
The first draft agenda is uploaded:
https://www.ietf.org/proceedings/96/agenda/agenda-96-bmwg

contact me with any changes or omissions,
Al
bmwg co-chair

> -----Original Message-----
> From: bmwg [mailto:[email-masked]] On Behalf Of MORTON, ALFRED C
> (AL)
> Sent: Saturday, July 02, 2016 2:19 PM
> To: [email-masked]
> Subject: [bmwg] IETF-96 session: Agenda requests and Remote
> Participation
> 
> *** Security Advisory: This Message Originated Outside of AT&T ***.
> Reference http://cso.att.com/EmailSecurity/IDSP.html for more
> information.
> 
> BMWG,
> 
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bmwg

---

From: "Maciek Konstantynowicz (mkonstan)" <[email-masked]>
Date: Wed, 13 Jul 2016 16:30:40 +0000

Al et al,

I know I’m late with a request for a short slot in bmwg meeting next week, but I give it a go anyways just in case :)

I would like to ask for a 10min slot to provide an overview of the work done in the Linux Foundation collaborative project FD.io CSIT.

We have been alive in the open-source for quite a few months now, got our hands “dirty” and “bruised" with cutting edge virtual networking tech (aka NFV) - pun intended :)
We now have first LF FD.io CSIT fully-automated func and perf benchmarking report published for vpp-1606 - with all tests are executed within Linux Foundation infra.
https://wiki.fd.io/view/CSIT/VPP-16.06_Test_Report

Abstract: I would like to cover a summary of the good, the bad and the ugly, of squeezing "the last juice out of computers" for forwarding and processing packets.
"the last juice out of computers” = 
    cpu core cycles-per-packet - aka CPP (experience and examples on x86_64 microarchitecture)
    instructions-per-packet - aka IPP
    instructions-per-cycle - aka IPC

Pls let me know what’s possible.

-Maciek

FD.io CSIT Tech Project Lead hat on
https://wiki.fd.io/view/CSIT 

> On 11 Jul 2016, at 17:58, MORTON, ALFRED C (AL) <[email-masked]> wrote:
> 
> BMWG,

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 13 Jul 2016 15:18:33 -0400

Hi Maciek,

This is an interesting proposal, so I'd like to make a few
suggestions to focus on what would be most relevant to BMWG
as we develop new / revise our RFCs to more accurately measure
virtual internetworking functions:

Procedures you and your team used when measuring classic
benchmarks like Throughput and Latency: what measurement problems
did you encounter and how did you resolve them?
What did you try that didn't work?

What new black-box benchmarks and other metrics did you find
to be relevant, and why?

If you give us a brief background on CSIT 
(Continuous System Integration and Testing) in FD.io
and try to answer the questions above, your presentation
would be well-worth our meeting time (and introduce you
to many participants who can pursue more details with
you after our session).

BMWG: any other questions, comments, agenda bashes?

More info on the project here:
https://wiki.fd.io/view/CSIT

Al
bmwg co-chair

> From: Maciek Konstantynowicz (mkonstan) [mailto:[email-masked]]
> Sent: Wednesday, July 13, 2016 12:31 PM
> To: MORTON, ALFRED C (AL)
> Cc: [email-masked]; [email-masked]
> Subject: Re: [bmwg] IETF-96 session: Agenda requests and Remote
> Participation
> 
> Al et al,
> 
> I know I’m late with a request for a short slot in bmwg meeting next
> week, but I give it a go anyways just in case :)
> 
> I would like to ask for a 10min slot to provide an overview of the work
> done in the Linux Foundation collaborative project FD.io CSIT.
> 
> We have been alive in the open-source for quite a few months now, got
> our hands “dirty” and “bruised" with cutting edge virtual networking
> tech (aka NFV) - pun intended :)
> We now have first LF FD.io CSIT fully-automated func and perf
> benchmarking report published for vpp-1606 - with all tests are executed
> within Linux Foundation infra.
> Abstract: I would like to cover a summary of the good, the bad and the
> ugly, of squeezing "the last juice out of computers" for forwarding and
> processing packets.

---

From: "Maciek Konstantynowicz (mkonstan)" <[email-masked]>
Date: Wed, 13 Jul 2016 19:48:25 +0000

Al,

Thanks for feedback, good suggestions, will ensure to include all of them. 
Will add challenges with measurement tools, and how we’re going about it too.
(read: developing our own a.o.).

-Maciek

> On 13 Jul 2016, at 20:18, MORTON, ALFRED C (AL) <[email-masked]> wrote:
> 
> Hi Maciek,
>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 19 Jul 2016 07:05:41 -0400

Presenters,
If you haven't already sent slides (thanks again to those who did),
I need the final versions by 1800 CEST today.

thanks,
Al

> Sent: Monday, July 11, 2016 12:58 PM
> To: [email-masked]