Subject: [bmwg] Alvaro Retana's Discuss on draft-ietf-bmwg-dcbench-methodology-12: (with DISCUSS and COMMENT)

From: Alvaro Retana <[email-masked]>
Date: Mon, 19 Jun 2017 14:32:22 -0700

Alvaro Retana has entered the following ballot position for
draft-ietf-bmwg-dcbench-methodology-12: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-bmwg-dcbench-methodology/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

This document contains both the RFC2119 boilerplate and specific definitions
for MUST, SHOULD/RECOMMENDED and MAY. Even though the additional definitions
are close enough to RFC2119, I think that one of them should be taken off to
avoid any type of confusion.

Note that the (new) definitions in this document are focused around "metrics",
which would not apply to text such as (from 2.2) "A traffic generator SHOULD be
connected to all ports on the DUT. Two tests MUST be conducted...".

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I support Mirja's DISCUSS.  The authors recognize that the applicability of the
tests described may go beyond the DC, so it should be reflected appropriately
(starting with the title of the document).  From the Abstract:

   The purpose of this informational document is to establish test and
   evaluation methodology and measurement techniques for physical
   network equipment in the data center. Many of these terms and methods
   may be applicable beyond this publication's scope as the technologies
   originally applied in the data center are deployed elsewhere.

---

From: Lucien Avramov <[email-masked]>
Date: Mon, 19 Jun 2017 18:17:49 -0700

Hi Alvaro,

In the context of the tests we describe in this publication, it's key to
keep the words we have chosen, therefore I don't plan to make further
changes on that.

Thanks!
Lucien

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Tue, 20 Jun 2017 16:35:25 +0000

On 6/20/17, 3:17 AM, "Lucien Avramov" <[email-masked]<mailto:[email-masked]>> wrote:

Lucien:

Hi!

> In the context of the tests we describe in this publication, it's key to keep
> the words we have chosen…

I don’t have a problem with the words themselves – the point of my DISCUSS is the fact that each word (“MUST”, for example) has two different definitions.  Yes, they are close, but different.  In fact, they are so close that I think you could take out the definitions in 1.2 and not lose anything.

Regards,

Alvaro.

---

From: Lucien <[email-masked]>
Date: Tue, 20 Jun 2017 09:40:49 -0700

Thanks for clarifying Alvaro!! Much appreciate it.

Got it, i'd like to keep 1.2 add-on as it makes it more clear for the
reader to understand what I want to convey when I use this language in the
doc, instead of having them go read another RFC.

On Tue, Jun 20, 2017 at 9:35 AM, Alvaro Retana (aretana) <[email-masked]>
wrote:

> On 6/20/17, 3:17 AM, "Lucien Avramov" <[email-masked]> wrote:
>
>
>
> Lucien:
>
>
>
> Hi!
>
>
>
> keep
> I don’t have a problem with the words themselves – the point of my DISCUSS
> is the fact that each word (“MUST”, for example) has two different
> definitions.  Yes, they are close, but different.  In fact, they are so
> close that I think you could take out the definitions in 1.2 and not lose
> anything.
>
>
>
> Regards,
>
>
>
> Alvaro.
>

---

From: Lucien <[email-masked]>
Date: Wed, 21 Jun 2017 21:58:04 -0700

Hi Alvaro,

I removed 1.2 per your suggestion. It's now all consistent.

Please confirm it's good for you?

Thanks for insisting on this change.

Lucien

On Tue, Jun 20, 2017 at 9:40 AM, Lucien <[email-masked]> wrote:

> On Tue, Jun 20, 2017 at 9:35 AM, Alvaro Retana (aretana) <
> [email-masked]> wrote:
>
>> I don’t have a problem with the words themselves – the point of my
>> DISCUSS is the fact that each word (“MUST”, for example) has two different

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Thu, 22 Jun 2017 06:48:47 +0000

On 6/22/17, 6:58 AM, "iesg on behalf of Lucien" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

Lucien:

Hi!

> Please confirm it's good for you?

Yes, the change is fine with me.  I’ll clear the DISCUSS.

Just one nit:  The phrase “Additional interpretation of RFC2119 terms:” seems out of place because there is no additional clarification about the keywords in the paragraph after it.

Thanks!

Alvaro.

---

From: Lucien <[email-masked]>
Date: Wed, 21 Jun 2017 23:56:03 -0700

Thanks Alvaro! Fixed the Nit also now...

On Wed, Jun 21, 2017 at 11:48 PM, Alvaro Retana (aretana) <[email-masked]

> On 6/22/17, 6:58 AM, "iesg on behalf of Lucien" <[email-masked] on
> behalf of [email-masked]> wrote:
>
>
>
> Lucien:
>
>
>
> Hi!
>
>
>
> Just one nit:  The phrase “Additional interpretation of RFC2119 terms:”
> seems out of place because there is no additional clarification about the
> keywords in the paragraph after it.
>
>
>
> Thanks!
>
>
>
> Alvaro.
>