Subject: [bmwg] Suresh Krishnan's No Objection on draft-ietf-bmwg-sdn-controller-benchmark-meth-08: (with COMMENT)

From: Suresh Krishnan <[email-masked]>
Date: Thu, 19 Apr 2018 06:59:00 -0700

Suresh Krishnan has entered the following ballot position for
draft-ietf-bmwg-sdn-controller-benchmark-meth-08: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-bmwg-sdn-controller-benchmark-meth/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I share Ignas's concern about this being too tightly associated with the OpenFlow model.

* Section 4.1
   The test cases SHOULD use Leaf-Spine topology with at least 1
   Network Device in the topology for benchmarking.

How is it even possible to have a leaf-spine topology with one Network Device?

---

From: Sarah B <[email-masked]>
Date: Thu, 19 Apr 2018 09:35:29 -0700

Hi Suresh,
	Thanks for your feedback. A few comments below inline with SB//

Thanks
Sarah

SB// I understand the point here, but I also feel strongly that it's not a problem. I've not had a customer yet ask for an SDN controller that wasn't leveraging OpenFlow. We can update the text to reflect this choice (the loose alignment to OpenFlow) and I'm open to feedback on specific test cases that you see as too OpenFlow specific, and we'll review to see if we can make them more generic.

> How is it even possible to have a leaf-spine topology with one Network Device?

SB// Agreed. We're reviewing now. Thanks again for the feedback