Subject: [bmwg] Updates on draft: Methodology for VNF Benchmarking Automation

From: Raphael Vicente Rosa <[email-masked]>
Date: Wed, 20 Feb 2019 09:51:13 -0300

Hi folks,

By the end of the last year we submitted the -03 version of the draft
"Methodology for VNF Benchmarking Automation" (see the info below).

Among the main achievements in the draft we highlight so far:
- We redefined the structure of the draft
- We produced an information model (github link
<https://github.com/raphaelvrosa/vnf-bench-model>) for the VNF Benchmark
Report (VNF-BR) that we now intend to translate into an YANG model (we
believe it could be more useful/important for the IETF community).
- We are running parallel experiments with our reference implementations,
and evolving the configurability and comparability factors in the VNF-BR
info model. We are going to bring the results to BMWG.
- We defined a set of common procedures in the methodology proposed by the
draft that we are following in the reference implementations.

Thus, we believe the draft stands in a version in need of comments from the
BMWG community. We are aware of the loose ends in the draft, and we have
plans to consolidate the knowledge there through experimental results.
Accordingly, for the next IETF meeting we intend to release a -04 version.

Finally, we would like to hear from you, if you believe the draft is ready
for adoption (or what is still needed to have it ready).

Best regards,
Raphael Rosa, on behalf of the authors

A new version of I-D, draft-rosa-bmwg-vnfbench-03.txt
has been successfully submitted by Raphael Vicente Rosa and posted to the
IETF repository.

Name:           draft-rosa-bmwg-vnfbench
Revision:       03
Title:          Methodology for VNF Benchmarking Automation
Document date:  2018-12-29
Group:          Individual Submission
Pages:          25
URL:
https://www.ietf.org/internet-drafts/draft-rosa-bmwg-vnfbench-03.txt
Status:         https://datatracker.ietf.org/doc/draft-rosa-bmwg-vnfbench/
Htmlized:       https://tools.ietf.org/html/draft-rosa-bmwg-vnfbench-03
Htmlized:
https://datatracker.ietf.org/doc/html/draft-rosa-bmwg-vnfbench
Diff:
https://www.ietf.org/rfcdiff?url2=draft-rosa-bmwg-vnfbench-03

Abstract:
   This document describes a common methodology for the automated
   benchmarking of Virtualized Network Functions (VNFs) executed on
   general-purpose hardware.  Specific cases of benchmarking
   methodologies for particular VNFs can be derived from this document.
   Two open source reference implementations are reported as running
   code embodiments of the proposed, automated benchmarking methodology.

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 20 Feb 2019 12:58:35 +0000

Thanks for your message and updated draft, Raphael.
Submissions long-before before the deadline are
always welcome!

BMWG,
please consider reviewing this draft before we
meet in Prague.

regards,
Al
bmwg co-chair

From: bmwg [mailto:[email-masked]] On Behalf Of Raphael Vicente Rosa
Sent: Wednesday, February 20, 2019 7:51 AM
To: [email-masked]
Subject: [bmwg] Updates on draft: Methodology for VNF Benchmarking Automation

Hi folks,

By the end of the last year we submitted the -03 version of the draft  "Methodology for VNF Benchmarking Automation" (see the info below).

Among the main achievements in the draft we highlight so far:
- We redefined the structure of the draft
- We produced an information model (github link<https://urldefense.proofpoint.com/v2/url?u=https-3A__github.com_raphaelvrosa_vnf-2Dbench-2Dmodel&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=Ay6x-AqG1lVipT-g7VaebXNVOGEUhy7dm1UpB7ooGoU&s=eV0bJM8rWK53Xc8yS0DWkxgNK_AVFFFFDeRYm8V0ETc&e=>) for the VNF Benchmark Report (VNF-BR) that we now intend to translate into an YANG model (we believe it could be more useful/important for the IETF community).
- We are running parallel experiments with our reference implementations, and evolving the configurability and comparability factors in the VNF-BR info model. We are going to bring the results to BMWG.
- We defined a set of common procedures in the methodology proposed by the draft that we are following in the reference implementations.

Thus, we believe the draft stands in a version in need of comments from the BMWG community. We are aware of the loose ends in the draft, and we have plans to consolidate the knowledge there through experimental results.
Accordingly, for the next IETF meeting we intend to release a -04 version.

Finally, we would like to hear from you, if you believe the draft is ready for adoption (or what is still needed to have it ready).

Best regards,

Name:           draft-rosa-bmwg-vnfbench
Revision:       03
Title:          Methodology for VNF Benchmarking Automation
Document date:  2018-12-29
Group:          Individual Submission
Pages:          25
URL:            https://www.ietf.org/internet-drafts/draft-rosa-bmwg-vnfbench-03.txt<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_internet-2Ddrafts_draft-2Drosa-2Dbmwg-2Dvnfbench-2D03.txt&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=Ay6x-AqG1lVipT-g7VaebXNVOGEUhy7dm1UpB7ooGoU&s=wnXOzYTCsJjqqIxv3EOjxQytyft4RD-2r8X0S_UnqGI&e=>
Status:         https://datatracker.ietf.org/doc/draft-rosa-bmwg-vnfbench/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Drosa-2Dbmwg-2Dvnfbench_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=Ay6x-AqG1lVipT-g7VaebXNVOGEUhy7dm1UpB7ooGoU&s=BKXVbiEFd1EnXLJZ9G8ek33XWnBctMzHgUNZ4cfwmnQ&e=>
Htmlized:       https://tools.ietf.org/html/draft-rosa-bmwg-vnfbench-03<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Drosa-2Dbmwg-2Dvnfbench-2D03&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=Ay6x-AqG1lVipT-g7VaebXNVOGEUhy7dm1UpB7ooGoU&s=cQ8r0o6VR9rYw8X56hUSUzx-iC4VQ-iki7gAy5uYUyg&e=>
Htmlized:       https://datatracker.ietf.org/doc/html/draft-rosa-bmwg-vnfbench<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_html_draft-2Drosa-2Dbmwg-2Dvnfbench&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=Ay6x-AqG1lVipT-g7VaebXNVOGEUhy7dm1UpB7ooGoU&s=-kTMwqqrgUDxG0QuWNmtjhe5vSBrPKOYblWJZI7GAqc&e=>
Diff:           https://www.ietf.org/rfcdiff?url2=draft-rosa-bmwg-vnfbench-03<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Drosa-2Dbmwg-2Dvnfbench-2D03&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=Ay6x-AqG1lVipT-g7VaebXNVOGEUhy7dm1UpB7ooGoU&s=DuwvvLujjTqylo9yH8pPDMbtZmHyxqo7IKDNhKwcCWY&e=>

Abstract: