Subject: [bmwg] Draft Agenda for BMWG at IETF-104

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Mon, 11 Mar 2019 13:39:52 +0000

BMWG,

The draft agenda is available here:
https://datatracker.ietf.org/meeting/104/materials/agenda-104-bmwg-00

Any early Agenda Bashes?
Are there more drafts coming today?
More requests for agenda slots to discuss drafts?

Reply to the list and let us know,
Al and Sarah
bmwg co-chairs

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 12 Mar 2019 12:24:24 +0000

I received many new inputs for the agenda
after posting the first draft, yesterday.

Thanks to everyone who helped!

the revised agenda is now posted:
https://datatracker.ietf.org/meeting/104/materials/agenda-104-bmwg-01

Al
bmwg co-chair

> -----Original Message-----
> From: bmwg [mailto:[email-masked]] On Behalf Of MORTON, ALFRED C
> (AL)
> Sent: Monday, March 11, 2019 9:40 AM
> To: [email-masked]
> Subject: [bmwg] Draft Agenda for BMWG at IETF-104
> 
> 
> BMWG,
> 
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_bmwg&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=Og8hOg_64kFu5yY21eZNl9822ORRh
> tsTfOGRDpWyF5A&s=kJ5FOt6agLT5txZCGVTC-h-Oiz8JlR9_QRkG-r42HSc&e=

---

From: "Maciek Konstantynowicz (mkonstan)" <[email-masked]>
Date: Tue, 12 Mar 2019 13:03:32 +0000

Hi Al,

We would like ask for the following to be added to BMWG IETF-104 agenda:

Continuing Proposals:

  Probabilistic Loss Ratio Search for Packet Throughput (PLRsearch)
    (includes test results from FD.io<http://FD.io> CSIT)
    Presenters: Vratko Polak, Maciek Konstantynowicz
    Related Draft:
    https://tools.ietf.org/html/draft-vpolak-bmwg-plrsearch-01

  Multiple Loss Ratio Search for Packet Throughput (MLRsearch)
    (includes test results from FD.io<http://FD.io> CSIT)
    Presenters: Vratko Polak, Maciek Konstantynowicz
    Related Draft:
    https://tools.ietf.org/html/draft-vpolak-mkonstan-bmwg-mlrsearch-00

NEW Proposals:

  NFV Service Density Benchmarking
    (includes test results from FD.io<http://FD.io> CSIT and CNCF CNF Testbed)
    Presenter: Maciek Konstantynowicz
    Related Draft:
    https://tools.ietf.org/html/draft-mkonstan-nf-service-density-00

Cheers,
-Maciek

On 12 Mar 2019, at 12:24, MORTON, ALFRED C (AL) <[email-masked]<mailto:[email-masked]>> wrote:

Al
bmwg co-chair

-----Original Message-----
From: bmwg [mailto:[email-masked]] On Behalf Of MORTON, ALFRED C
(AL)
Sent: Monday, March 11, 2019 9:40 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [bmwg] Draft Agenda for BMWG at IETF-104

BMWG,

Any early Agenda Bashes?

_______________________________________________
bmwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bmwg

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 12 Mar 2019 13:24:11 +0000

Thanks for the updates, Maciek.

I saw the new draft on PLResearch, because it uses
draft-***-bmwg- in the file name, and added that one to
the agenda.

Unfortunately, the other drafts don't use the
draft-lastname-bmwg- format, and I didn't see them
when I checked this morning.

So, we need another agenda update, and that will be
tomorrow.

Thanks for including the proposed topics in the format
of our agenda - makes my work a little easier!

regards, and see you in Prague,
Al

From: Maciek Konstantynowicz (mkonstan) [mailto:[email-masked]]
Sent: Tuesday, March 12, 2019 9:04 AM
To: MORTON, ALFRED C (AL) <[email-masked]>
Cc: [email-masked]; Vratko Polak -X (vrpolak - PANTHEON TECHNOLOGIES at Cisco) <[email-masked]>
Subject: Re: [bmwg] Draft Agenda for BMWG at IETF-104

Hi Al,

Continuing Proposals:

  Probabilistic Loss Ratio Search for Packet Throughput (PLRsearch)
    (includes test results from FD.io<https://urldefense.proofpoint.com/v2/url?u=http-3A__FD.io&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-6zYMI&m=LKmffvfqDFajtowmghK51wnd9vxX0cBy75ecm7zogpY&s=ks4BbI5uHBA-X1uXXS41ypy6lOjJ9b9TdPMgPFzmWS4&e=> CSIT)
    Presenters: Vratko Polak, Maciek Konstantynowicz
    Related Draft:
    https://tools.ietf.org/html/draft-vpolak-bmwg-plrsearch-01<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dvpolak-2Dbmwg-2Dplrsearch-2D01&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-6zYMI&m=LKmffvfqDFajtowmghK51wnd9vxX0cBy75ecm7zogpY&s=B6Y4LCJS1xcLRB8XJfF_n7LM-TjxPbZgJ96toLM3FFQ&e=>

  Multiple Loss Ratio Search for Packet Throughput (MLRsearch)
    (includes test results from FD.io<https://urldefense.proofpoint.com/v2/url?u=http-3A__FD.io&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-6zYMI&m=LKmffvfqDFajtowmghK51wnd9vxX0cBy75ecm7zogpY&s=ks4BbI5uHBA-X1uXXS41ypy6lOjJ9b9TdPMgPFzmWS4&e=> CSIT)
    Presenters: Vratko Polak, Maciek Konstantynowicz
    Related Draft:
    https://tools.ietf.org/html/draft-vpolak-mkonstan-bmwg-mlrsearch-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dvpolak-2Dmkonstan-2Dbmwg-2Dmlrsearch-2D00&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-6zYMI&m=LKmffvfqDFajtowmghK51wnd9vxX0cBy75ecm7zogpY&s=H3ymb1HSWXWOsRLUIW3o1usCMolTRGRppa3JbpABCh0&e=>

NEW Proposals:

  NFV Service Density Benchmarking
    (includes test results from FD.io<https://urldefense.proofpoint.com/v2/url?u=http-3A__FD.io&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-6zYMI&m=LKmffvfqDFajtowmghK51wnd9vxX0cBy75ecm7zogpY&s=ks4BbI5uHBA-X1uXXS41ypy6lOjJ9b9TdPMgPFzmWS4&e=> CSIT and CNCF CNF Testbed)
    Presenter: Maciek Konstantynowicz
    Related Draft:
    https://tools.ietf.org/html/draft-mkonstan-nf-service-density-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dmkonstan-2Dnf-2Dservice-2Ddensity-2D00&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-6zYMI&m=LKmffvfqDFajtowmghK51wnd9vxX0cBy75ecm7zogpY&s=YxHP64mdtuG692qrT6KU4Mprus33uk_dZFCvFqVzUvA&e=>

Cheers,
-Maciek

the revised agenda is now posted:
https://datatracker.ietf.org/meeting/104/materials/agenda-104-bmwg-01<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_meeting_104_materials_agenda-2D104-2Dbmwg-2D01&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-6zYMI&m=LKmffvfqDFajtowmghK51wnd9vxX0cBy75ecm7zogpY&s=wiQfpj40ATofBjHU8Kcg6pi9bdfS9H7t6tVymS3KEUI&e=>

Al
bmwg co-chair

-----Original Message-----

BMWG,

The draft agenda is available here:
https://datatracker.ietf.org/meeting/104/materials/agenda-104-bmwg-00<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_meeting_104_materials_agenda-2D104-2Dbmwg-2D00&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-6zYMI&m=LKmffvfqDFajtowmghK51wnd9vxX0cBy75ecm7zogpY&s=5LN2koSLdxmILD9EqdpQ1osfmFsBDl80h5V89nRSC2c&e=>

Any early Agenda Bashes?

_______________________________________________
bmwg mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/bmwg<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_bmwg&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-6zYMI&m=LKmffvfqDFajtowmghK51wnd9vxX0cBy75ecm7zogpY&s=geCWJuVyfEn6-aCDvHCTZO0JnQnIfLwTQiA8PXKrwGE&e=>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 13 Mar 2019 12:57:22 +0000

BMWG,

The Draft Agenda as of this morning US EDT, is posted:

https://datatracker.ietf.org/doc/agenda-104-bmwg/02/

We have a *very full* agenda, with several authors
intending to *share test data*.  This is a great opportunity
to advance our understanding of many proposals,
and it will probably take more than our 2 hour session
to fully appreciate and discuss the contributions.

So... we are lucky that scheduling provides a possible
and slightly innovative solution.  I will post a proposal
in another message to follow. Meanwhile, like the Agenda says:

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
     P L E A S E    R E A D   T H E   D R A F T S  ! ! ! !
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

regards,
Al
bmwg co-chair

From: bmwg [mailto:[email-masked]] On Behalf Of MORTON, ALFRED C (AL)
Sent: Tuesday, March 12, 2019 9:24 AM
To: Maciek Konstantynowicz (mkonstan) <[email-masked]>
Cc: [email-masked]
Subject: Re: [bmwg] Draft Agenda for BMWG at IETF-104

***Security Advisory: This Message Originated Outside of AT&T ***
Reference http://cso.att.com/EmailSecurity/IDSP.html for more information.
Thanks for the updates, Maciek.

From: Maciek Konstantynowicz (mkonstan) [mailto:[email-masked]]
Sent: Tuesday, March 12, 2019 9:04 AM
To: MORTON, ALFRED C (AL) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; Vratko Polak -X (vrpolak - PANTHEON TECHNOLOGIES at Cisco) <[email-masked]<mailto:[email-masked]>>
Subject: Re: [bmwg] Draft Agenda for BMWG at IETF-104

Hi Al,

Continuing Proposals:

NEW Proposals:

Cheers,
-Maciek

Al
bmwg co-chair

-----Original Message-----

BMWG,

Any early Agenda Bashes?

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Thu, 14 Mar 2019 12:20:07 +0000

Agenda now indicates the informal discussion to follow:
https://datatracker.ietf.org/doc/agenda-104-bmwg/03/

From: bmwg [mailto:[email-masked]] On Behalf Of MORTON, ALFRED C (AL)
Sent: Wednesday, March 13, 2019 8:57 AM
To: [email-masked]
Subject: Re: [bmwg] Draft Agenda for BMWG at IETF-104

https://datatracker.ietf.org/doc/agenda-104-bmwg/02/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_agenda-2D104-2Dbmwg_02_&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=WSqcvpTlQ3HJyf-jugVOI6Spn7wav2dmc9bUuRhdGWA&s=tLaovXNEIP0khqXhVMXmgMrRF1MGQBWjBwGvnfipoT0&e=>

regards,
Al
bmwg co-chair

From: bmwg [mailto:bmwg-bounces@ietf..org] On Behalf Of MORTON, ALFRED C (AL)
Sent: Tuesday, March 12, 2019 9:24 AM
To: Maciek Konstantynowicz (mkonstan) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [bmwg] Draft Agenda for BMWG at IETF-104

***Security Advisory: This Message Originated Outside of AT&T ***
Reference http://cso..att.com/EmailSecurity/IDSP.html<http://cso.att.com/EmailSecurity/IDSP.html> for more information.
Thanks for the updates, Maciek.

Hi Al,

Continuing Proposals:

NEW Proposals:

Cheers,
-Maciek

Al
bmwg co-chair
-----Original Message-----

BMWG,

Any early Agenda Bashes?

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 20 Mar 2019 18:36:03 +0000

BMWG,

Agenda development has slowed,
https://datatracker.ietf.org/doc/agenda-104-bmwg/
and now we have the next steps:

@Presenters:
Send your slides to mailto:[email-masked]
by Tuesday, March 26, 18:00 CET.
You should send PDF versions, as this is the format we upload
and display during the meeting. You may also send .pptx, if
you want suggestions/feedback.

@All Authors:
Everyone wants their draft reviewed, so they receive useful comments!
You can all help each-other out in this area:

*        READ another author-team's draft and provide comments on the list

*        You may make some friends who will review your drafts

*        You may learn something that you can apply to your work

I do this and I find it useful, so I pass it along.
It's one way that the world goes 'round...

@Everyone:
There are lots of ways to participate and make our session time more
productive. Some of the most useful exchanges start with a question or
comment shared by e-mail. I've had some fun/useful exchanges with
"friends I've never met". Most of us are drawn to BMWG because we
have expertise, and we like to share it.

Thanks for productive session preparation, and see you in Prague!
Al
bmwg co-chair

From: bmwg [mailto:[email-masked]] On Behalf Of MORTON, ALFRED C (AL)
Sent: Thursday, March 14, 2019 8:20 AM
To: [email-masked]
Subject: Re: [bmwg] Draft Agenda for BMWG at IETF-104

Agenda now indicates the informal discussion to follow:
https://datatracker.ietf.org/doc/agenda-104-bmwg/03/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_agenda-2D104-2Dbmwg_03_&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=Yr3XZ5SQ8ZGwYcrjhkO3iyUcwi34PQZ3uRfq60cuN5k&s=6b3wOYpF_lYz1q_DLcKxYv3bVWUACbbolcqsv6G8Cf0&e=>

BMWG,

https://datatracker.ietf.org/doc/agenda-104-bmwg/02/<https://urldefense.proofpoint.com/v2/url?u=https-3A__urldefense.proofpoint..com_v2_url-3Fu-3Dhttps-2D3A-5F-5Fdatatracker.ietf.org-5Fdoc-5Fagenda-2D2D104-2D2Dbmwg-5F02-5F-26d-3DDwMFAg-26c-3DLFYZ-2Do9-5FHUMeMTSQicvjIg-26r-3DOfsSu8kTIltVyD1oL72cBw-26m-3DWSqcvpTlQ3HJyf-2DjugVOI6Spn7wav2dmc9bUuRhdGWA-26s-3DtLaovXNEIP0khqXhVMXmgMrRF1MGQBWjBwGvnfipoT0-26e-3D&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=Yr3XZ5SQ8ZGwYcrjhkO3iyUcwi34PQZ3uRfq60cuN5k&s=lPAMVahrGUUMWDuDLcPrSe-mL9IZQrLm62trVj57zxE&e=>

regards,
Al
bmwg co-chair

Hi Al,

Continuing Proposals:

NEW Proposals:

Cheers,
-Maciek

Al
bmwg co-chair
-----Original Message-----

BMWG,

Any early Agenda Bashes?

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 26 Mar 2019 20:38:44 +0000

I have posted all the slides received,
see you tomorrow!
Al

From: MORTON, ALFRED C (AL)
Sent: Wednesday, March 20, 2019 2:36 PM
To: [email-masked]
Subject: RE: [bmwg] Draft Agenda for BMWG at IETF-104

BMWG,

@Presenters:

@All Authors:

@Everyone:

BMWG,

regards,
Al
bmwg co-chair

Hi Al,

Continuing Proposals:

NEW Proposals:

Cheers,
-Maciek

Al
bmwg co-chair
-----Original Message-----

BMWG,

Any early Agenda Bashes?

---

From: "Maciek Konstantynowicz (mkonstan)" <[email-masked]>
Date: Wed, 27 Mar 2019 09:30:26 +0000

Hello BMWG!

We would like to gather feedback for PLRsearch draft, specifically
related to its applicability to throughput soak test:

1. PLRsearch can be used for a soak test with specified total test
duration. What are the common soak test criteria that need to be met?

2. How does one validate the critical load (maximum throughput) found by
a discovery test (e.g. with PLRsearch)? For example single trial with
long duration and measuring total loss, or multiple shorter trials
looking at maximum loss per trial.

3. Assuming a single test methodology combines critical load discovery
and validation, what would be the quantitive criteria to communicate
reliable vs. not reliable results?

Looking forward to the discussion in the meetings later today...

Cheers,
Vratko&Maciek

On 12 Mar 2019, at 14:03, Maciek Konstantynowicz (mkonstan) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Al,

Continuing Proposals:

  Probabilistic Loss Ratio Search for Packet Throughput (PLRsearch)
    (includes test results from FD.io<http://fd.io/> CSIT)
    Presenters: Vratko Polak, Maciek Konstantynowicz
    Related Draft:
    https://tools.ietf.org/html/draft-vpolak-bmwg-plrsearch-01

  Multiple Loss Ratio Search for Packet Throughput (MLRsearch)
    (includes test results from FD.io<http://fd.io/> CSIT)
    Presenters: Vratko Polak, Maciek Konstantynowicz
    Related Draft:
    https://tools.ietf.org/html/draft-vpolak-mkonstan-bmwg-mlrsearch-00

NEW Proposals:

  NFV Service Density Benchmarking
    (includes test results from FD.io<http://fd.io/> CSIT and CNCF CNF Testbed)
    Presenter: Maciek Konstantynowicz
    Related Draft:
    https://tools.ietf.org/html/draft-mkonstan-nf-service-density-00

Cheers,
-Maciek

Al
bmwg co-chair

-----Original Message-----

BMWG,

Any early Agenda Bashes?

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 27 Mar 2019 15:12:26 +0000

Hi everyone,

We have completed a successful session with ~33 local
participants today: see the BMWG Etherpad for preliminary
meeting notes:
https://etherpad.ietf.org/p/notes-ietf-104-bmwg?useMonospaceFont=true

Also, based on attendance (~12 people),
and the details we covered during interactive discussion
of the detailed test results and test configurations,
I'm going to declare the Overtime session an unqualified
success.

Thanks for your participation, and looking forward to
additional productive review and commentary on the list.

Al
bmwg co-chair

From: MORTON, ALFRED C (AL)
Sent: Tuesday, March 26, 2019 4:38 PM
To: [email-masked]' <[email-masked]>
Subject: RE: [bmwg] Draft Agenda for BMWG at IETF-104

BMWG,

@Presenters:

@All Authors:

@Everyone:

BMWG,

regards,
Al
bmwg co-chair

Hi Al,

Continuing Proposals:

NEW Proposals:

Cheers,
-Maciek

Al
bmwg co-chair
-----Original Message-----

BMWG,

Any early Agenda Bashes?