Subject: [bmwg] A new draft aimed at bmwg

From: WB Lee <[email-masked]>
Date: Fri, 8 Mar 2019 13:12:17 +0900

Hi All,

We have been researched the POD testing in Containerized Infrastructures.
We submitted the new draft, "Considerations for Benchmarking Network
Performance in Containerized Infrastructures".

https://www.ietf.org/id/draft-dcn-bmwg-containerized-infra-00.txt

Abstract

   This draft describes benchmarking considerations for a containerized
   infrastructure.  In a containerized infrastructure, Virtualized
   Network Functions(VNFs) are deployed on operating-system-level
   virtualization platform by abstracting the user namespace as opposed
   to virtualization using a hypervisor.  Leveraging this, the system
   configurations and networking scenarios for VNF benchmarking will be
   partially changed by way of resource allocation and network port
   binding between a physical host and VNFs.  In this draft we compare
   the state of the art in container networking architecture with
   networking on VM-based virtualized systems, and provide several test
   scenarios for network performance in containerized infrastructure.

We welcome any comments.

Regards,
Wangbong Lee

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Fri, 8 Mar 2019 09:51:52 +0000

Thanks for your timely contribution, 
Mr. Lee and co-authors.  
I will certainly take time to review.

Al
bmwg co-chair 

> -----Original Message-----
> From: bmwg [mailto:[email-masked]] On Behalf Of WB Lee
> Sent: Thursday, March 7, 2019 11:12 PM
> To: [email-masked]
> Subject: [bmwg] A new draft aimed at bmwg
> 
> 
> Hi All,
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_id_draft-2Ddcn-2Dbmwg-2Dcontainerized-2Dinfra-
> 2D00.txt&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=GqCJ6KxJEotosmsZYGIRkgzSnPHw6
> 9gsd-qljl5VsKM&s=8TVO-ODX_CHjQHvGlCffATtz0hQeX6HUeog7Q8mGajc&e=
> 
> Abstract
> 
> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_bmwg&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=GqCJ6KxJEotosmsZYGIRkgzSnPHw6
> 9gsd-qljl5VsKM&s=Bw0LUXS-NxJHsEwXDVqXkyG-vuE7YWyeQMbEHEWsGfA&e=

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Fri, 22 Mar 2019 08:27:43 +0000

Mr. Lee and co-authors,

I read your draft: it is a good start for this topic,
and have a few comments to share.

General:
Instantiation of containers, pods, and internetworking
with K8s is somewhat non-deterministic and apparently
NUMA-Node agnostic, which is one way of saying that 
performance will likely vary from one instantiation to
the next, and the next, etc.  It would be good to 
specifically mention repeated instantiation and testing 
to quantify the performance variation under these 
conditions.

Related to the Memory Management Unit POV, section 3.1:
Life-cycle operations usually require considerable memory transfers.
Does this also imply that memory access times in Container VNFs
will be be affected when host resources are committed to Life-cycle
operations on other VNFs (such as instantiation/migrqation/deletion)?
IOW, will the effects of Life-cycle management be greater in the 
containerized infrastructure than for hypervisor with VM-based VNFs?

thanks,
Al
(as a participant)

> From: bmwg [mailto:[email-masked]] On Behalf Of MORTON, ALFRED C
> (AL)
> Sent: Friday, March 8, 2019 4:52 AM
> To: WB Lee <[email-masked]>; [email-masked]
> Subject: Re: [bmwg] A new draft aimed at bmwg
> 
> *** Security Advisory: This Message Originated Outside of AT&T ***.
> Reference http://cso.att.com/EmailSecurity/IDSP.html for more information.
> 
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=qXXXuSDIome9R0009wamlXyeacskd
> HvEajvNIkJnZi0&s=5A7xn7LyNn_hq7KAWSW9fFJj4i1SrXVeH8uoZ4DlPZU&e=