Subject: [bmwg] Review of draft-dcn-bmwg-containerized-infra-00

From: "Luis M. Contreras" <[email-masked]>
Date: Thu, 18 Apr 2019 12:38:38 +0200

Dear all,

As committed during IETF#104 Prague meeting, I have performed a review of
draft-dcn-bmwg-containerized-infra-00. These are my comments.

/* General comments */

.- I think the draft is a very good starting point for highlighting the
differences and implications due to distinct options of virtualization
methods. However, as it is written now, the draft only visualizes a number
of differences with the VM based approach or alternatives to consider for
containers in several aspects (networking, memory, hardware, etc), but it
does not provide specific guidance or recommendations about what and how to
test and benchmark the containerized case. So, in my opinion, a good path
to follow would be to include some guidelines in next versions of the draft.

.- When talking about container solutions (e.g., Docker, Kubernettes) no
references/links are included in the draft. Having some references would
help readers by pointing out where to look at.

.- As every technological option, containers have some pros and cons. Some
pros are provided in the draft (e.g., lightweight virtualization scheme),
but no cons are mentioned. Being this a document of the BMWG, I think it
would be convenient to highlight also potential cons due to
containerization in such a way that it can help the reader to take the
proper decision on what is the more appropriate virtualization technology
to follow from his/her point of view and needs.

.- Reference [ETSI-TST-009] is mentioned several times in the draft. I
think it would be good to make explicit what are the additions that this
draft provides with respect to [ETSI-TST-009].

/* Editorial comments */

.- It would be convenient to shift to the right the different bullets along
the draft. This would make the draft more readable.

.- In the Abstract: “… will be partially changed by way of resource
allocation and network port binding between a physical host and VNFs.” –
maybe re-write in this way: “… will be partially changed by the way in
which the resource allocation and network port binding between a physical
host and VNFs is performed.”

.- the VM based option is sometimes referred as “VM based” and others as
“VM-based”. A uniform reference is advised.

.- In section 3.2: “Other deployment models are classified bases on whether
…” à “Other deployment models are classified based on whether …”

.- Figure 2 reflects 4 different options. I think it would be good to
describe in the title of the figure each of these options (reference to
case (a), (b), etc).

Best regards,
Luis

___________________________________________
Luis M. Contreras
[email-masked]
[email-masked]
Global CTIO unit / Telefonica

---

From: "KJ SUN" <[email-masked]>
Date: Thu, 18 Apr 2019 19:56:41 +0900

Hi Luis,

Thank you very much for your comments. I agree with your conmments

In the next version, I will try to add contents including especially test scenarios and guidelines.

And also I think that analysis should be contained not only advantages of containerized infrastructure but also constraints. I will try to add that part also.

All editorial comments are also helpful for next version of this draft. I will reflect your comments.

Kind regards,

KJ
Kyoungjae Sun / K. J. SUN (Ph. D. Student)
Distributed Computing Network laboratory (DCN Lab)
School of Electronic Engineering, Soongsil Univ.
369 Sangdo-ro, Dongjak-gu, Seoul.
Tel. +82-2-814-0151
Mobile +82-10-3643-5627
Email [email-masked]
On 2019-04-18 오후 7:39:31, Luis M. Contreras <[email-masked]> wrote:
Dear all,
As committed during IETF#104 Prague meeting, I have performed a review of draft-dcn-bmwg-containerized-infra-00. These are my comments.
/* General comments */
.- I think the draft is a very good starting point for highlighting the differences and implications due to distinct options of virtualization methods. However, as it is written now, the draft only visualizes a number of differences with the VM based approach or alternatives to consider for containers in several aspects (networking, memory, hardware, etc), but it does not provide specific guidance or recommendations about what and how to test and benchmark the containerized case. So, in my opinion, a good path to follow would be to include some guidelines in next versions of the draft.
.- When talking about container solutions (e.g., Docker, Kubernettes) no references/links are included in the draft. Having some references would help readers by pointing out where to look at.
.- As every technological option, containers have some pros and cons. Some pros are provided in the draft (e.g., lightweight virtualization scheme), but no cons are mentioned. Being this a document of the BMWG, I think it would be convenient to highlight also potential cons due to containerization in such a way that it can help the reader to take the proper decision on what is the more appropriate virtualization technology to follow from his/her point of view and needs.
.- Reference [ETSI-TST-009] is mentioned several times in the draft. I think it would be good to make explicit what are the additions that this draft provides with respect to [ETSI-TST-009].
/* Editorial comments */
.- It would be convenient to shift to the right the different bullets along the draft. This would make the draft more readable.
.- In the Abstract: “… will be partially changed by way of resource allocation and network port binding between a physical host and VNFs.” – maybe re-write in this way: “… will be partially changed by the way in which the resource allocation and network port binding between a physical host and VNFs is performed.”
.- the VM based option is sometimes referred as “VM based” and others as “VM-based”. A uniform reference is advised.
.- In section 3.2: “Other deployment models are classified bases on whether …” à “Other deployment models are classified based on whether …”
.- Figure 2 reflects 4 different options. I think it would be good to describe in the title of the figure each of these options (reference to case (a), (b), etc).
Best regards,
Luis    

[email-masked] [mailto:[email-masked]] 
[email-masked] [mailto:[email-masked]]
Global CTIO unit / Telefonica
_______________________________________________ bmwg mailing list [email-masked] https://www.ietf.org/mailman/listinfo/bmwg

---
이 이메일은 Avast 안티바이러스 소프트웨어로 바이러스 검사를 완료했습니다.
https://www.avast.com/antivirus