Subject: [bmwg] YANG/NETCONF network interconnect tester implementation

From: Vladimir Vassilev <[email-masked]>
Date: Mon, 22 Jul 2019 15:26:54 +0200

Hi,

One of the projects in the hackathon targeted implementation of the 
draft-vassilev-bmwg-network-interconnect-tester (more details can be 
found on the hackathon wiki).

The draft is listed in the bmwg agenda for the session today with a 
question mark. Here is the hackathon implementation:

https://github.com/vlvassilev/yuma123/tree/master/example-modules/ietf-traffic-generator

There will be no formal presentation today but I will attend the 
session. The draft will be ready for formal presentation at IETF 106.

Vladimir

---

From: <[email-masked]>
Date: Mon, 22 Jul 2019 09:42:26 -0400

Scapy already exists as a  traffic generator.  What does Scapy not generate
that this traffic generator is needed?

Thanks,

Hemant

-----Original Message-----
From: hackathon <[email-masked]> On Behalf Of Vladimir Vassilev
Sent: Monday, July 22, 2019 9:27 AM
To: [email-masked]
Cc: [email-masked]
Subject: [hackathon] YANG/NETCONF network interconnect tester implementation

Hi,

One of the projects in the hackathon targeted implementation of the
draft-vassilev-bmwg-network-interconnect-tester (more details can be found
on the hackathon wiki).

The draft is listed in the bmwg agenda for the session today with a question
mark. Here is the hackathon implementation:

https://github.com/vlvassilev/yuma123/tree/master/example-modules/ietf-traff
ic-generator

There will be no formal presentation today but I will attend the session.
The draft will be ready for formal presentation at IETF 106.

Vladimir

_______________________________________________
hackathon mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/hackathon

---

From: <[email-masked]>
Date: Mon, 22 Jul 2019 13:46:54 +0000

I was using scapy yesterday. It worked for me. You may need some small hacks to adapt to what you need.

./Sorin

-----Original Message-----
From: hackathon <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, July 22, 2019 9:42 AM
To: 'Vladimir Vassilev'; [email-masked]
Cc: [email-masked]
Subject: Re: [hackathon] YANG/NETCONF network interconnect tester implementation

[EXTERNAL EMAIL] 

Scapy already exists as a  traffic generator.  What does Scapy not generate that this traffic generator is needed?

Thanks,

Hemant

-----Original Message-----
From: hackathon <[email-masked]> On Behalf Of Vladimir Vassilev
Sent: Monday, July 22, 2019 9:27 AM
To: [email-masked]
Cc: [email-masked]
Subject: [hackathon] YANG/NETCONF network interconnect tester implementation

Hi,

One of the projects in the hackathon targeted implementation of the draft-vassilev-bmwg-network-interconnect-tester (more details can be found on the hackathon wiki).

The draft is listed in the bmwg agenda for the session today with a question mark. Here is the hackathon implementation:

Vladimir

---

From: <[email-masked]>
Date: Mon, 22 Jul 2019 09:52:54 -0400

Any reason why Scapy could not be modified for what you needed?

Hemant

-----Original Message-----
From: hackathon <[email-masked]> On Behalf Of
[email-masked]
Sent: Monday, July 22, 2019 9:47 AM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [hackathon] YANG/NETCONF network interconnect tester
implementation

I was using scapy yesterday. It worked for me. You may need some small hacks
to adapt to what you need.

../Sorin

-----Original Message-----
From: hackathon <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, July 22, 2019 9:42 AM
To: 'Vladimir Vassilev'; [email-masked]
Cc: [email-masked]
Subject: Re: [hackathon] YANG/NETCONF network interconnect tester
implementation

[EXTERNAL EMAIL] 

Thanks,

Hemant

-----Original Message-----
From: hackathon <[email-masked]> On Behalf Of Vladimir Vassilev
Sent: Monday, July 22, 2019 9:27 AM
To: [email-masked]
Cc: [email-masked]
Subject: [hackathon] YANG/NETCONF network interconnect tester implementation

Hi,

Vladimir

---

From: <[email-masked]>
Date: Mon, 22 Jul 2019 13:59:53 +0000

My hack had to do with packer format. Not sure same issue.

./Sorin

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: Monday, July 22, 2019 9:53 AM
To: faibish, sorin; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [hackathon] YANG/NETCONF network interconnect tester implementation

[EXTERNAL EMAIL] 

Hemant

-----Original Message-----
From: hackathon <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, July 22, 2019 9:47 AM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [hackathon] YANG/NETCONF network interconnect tester implementation

../Sorin

-----Original Message-----
From: hackathon <[email-masked]> On Behalf Of [email-masked]
Sent: Monday, July 22, 2019 9:42 AM
To: 'Vladimir Vassilev'; [email-masked]
Cc: [email-masked]
Subject: Re: [hackathon] YANG/NETCONF network interconnect tester implementation

[EXTERNAL EMAIL] 

Thanks,

Hemant

-----Original Message-----
From: hackathon <[email-masked]> On Behalf Of Vladimir Vassilev
Sent: Monday, July 22, 2019 9:27 AM
To: [email-masked]
Cc: [email-masked]
Subject: [hackathon] YANG/NETCONF network interconnect tester implementation

Hi,

Vladimir

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Mon, 22 Jul 2019 17:03:58 +0000

Thanks Vladimir! 

I hope interested folks will contact you during the week 
for some discussions.

Al
bmwg co-chair

> From: bmwg [mailto:[email-masked]] On Behalf Of Vladimir Vassilev
> Subject: [bmwg] YANG/NETCONF network interconnect tester implementation
> 
> Hi,
> 
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__github.com_vlvassilev_yuma123_tree_master_example-2Dmodules_ietf-
> 2Dtraffic-2Dgenerator&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=Qmzhagr3a3Wmelkm01ine7DFndwpc
> jFVybkXnnGnYmM&s=0ssM3NBa4eboWJytuU4mYcXyX-BjnVDddQ4zB2LHork&e=
> 
> bmwg mailing list
> [email-masked]
> https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_mailman_listinfo_bmwg&d=DwICAg&c=LFYZ-
> o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=Qmzhagr3a3Wmelkm01ine7DFndwpc
> jFVybkXnnGnYmM&s=7d-rbHVfWSBJW7qQMDT3RU72ur8qt_DAHsOES7hwH6o&e=