Subject: Re: [bmwg] REG: draft-morton-bmwg-multihome-evpn/

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 2 Jul 2019 19:05:59 +0000

Hi Sudhin,

Thanks very much for your review of our draft,
and your willingness to meet on the phone to
sort-out some high-level questions first.
I think we saved a lot of time here.

Please see our replies below, and the draft
with updates will follow shortly.

regards,
Jim and Al(as a participant)

From: bmwg [mailto:[email-masked]] On Behalf Of Sudhin Jacob
Sent: Thursday, June 20, 2019 10:27 AM
To: [email-masked]
Subject: [bmwg] REG: draft-morton-bmwg-multihome-evpn/

Hi Al/Jim,

I had gone through the draft. Could you please clarify on measuring the throughput of multi home evpn services(How to do the test this requires some expansion in the current draft)..
[acm]
Yes, of course. Keep in mind that we are heavily
re-using the procedures of RFC 2889 for fully-meshed traffic.

The current draft is not clear in connecting the RT ports in order to measure the flow. Could you please provide some information regarding that. For effective measurement of throughput of multihome evpn services we must take in to account of reducing the network elements in the topology.
[acm]
Figure 1 is very minimal, one CE and 2 PE, sufficient for testing
a multi-homed CE scenario.

Figure 2 needs more network equipment to test address withdrawal. We showed the connection to CE_2 more clearly now (PE_3 if that's what you want below).

Suggestions:-

1.     If the remote PE is Single home and there must be a router tester connected to it.
[acm]
Are you suggesting that we remove the single-homed CE_2 in Figure 2? We can do that, but then we lose a simple and symmetrical test case.

2.     Another method is if we place a single home interface and multihome interface in the same routing instance which reduces the other routers/elements.
[acm]
So, a new setup like Figure 2 should include a CE which is single-homed to PE1 with ESI=0 ??  This new scenario could be used to reduce the test equipment needed, and it is supported by the EVPN technology. (We could do this in a new Figure 3)

Or, the CE would have two links to the same Router or PE?

We're not sure how that affects the performance we are trying to measure...

Then send unicast traffic from the single home to multiihome . Take the measurements in router ports.
[acm]
It is good to clarify that we are testing with Unicast flows, and
we have made that point now, and many other key references to
RFCs and other specs that will help.

Regards,
Sudhin

Juniper Internal

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 2 Jul 2019 20:24:38 +0000

Adding Jim's address to the thread,
Al

From: bmwg [mailto:[email-masked]] On Behalf Of MORTON, ALFRED C (AL)
Sent: Tuesday, July 2, 2019 3:06 PM
To: Sudhin Jacob <sjacob=[email-masked]>; [email-masked]
Subject: Re: [bmwg] REG: draft-morton-bmwg-multihome-evpn/

Hi Sudhin,

regards,

From: bmwg [mailto:bmwg-bounces@ietf..org] On Behalf Of Sudhin Jacob
Sent: Thursday, June 20, 2019 10:27 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [bmwg] REG: draft-morton-bmwg-multihome-evpn/

Hi Al/Jim,

Suggestions:-

Regards,
Sudhin

Juniper Internal