Subject: Re: [bmwg] draft-mkonstan-nf-service-density - call for comments

From: "Maciek Konstantynowicz (mkonstan)" <[email-masked]>
Date: Wed, 3 Jul 2019 12:42:22 +0000

Dear BMWG,

Following presentation and discussion at IETF104, we are looking for
more comments regarding this draft:

  https://tools.ietf.org/html/draft-mkonstan-nf-service-density-00

A working pre -01 version is available in Linux Foundation FD.io CSIT
repo, see reference at the bottom.

Appreciate all feedback.

Cheers,
-Maciek

P.S.

Links to pre -01 draft version in LF CSIT repo, file in markdown format
compatible with kramdown-rfc2629:

  https://gerrit.fd.io/r/c/18650/
  https://gerrit.fd.io/r/c/18650/2/docs/ietf/draft-mkonstan-nf-service-density-01.md

One needs to be signed into LF in order to interact with LF gerrit, LF
accounts are free.

---

From: "Maciek Konstantynowicz (mkonstan)" <[email-masked]>
Date: Mon, 8 Jul 2019 22:20:44 +0000

Dear BMWG,
We have just posted updated version of nf-service-density draft.
We are looking for comments and adoption of the draft as BMWG document.

Dear BMWG Chairs,
We would like to ask for a slot during the upcoming IETF105 meeting,
to present this work and ask for BMWG adoption. We will be presenting
remotely. Thanks in advance for accommodating.

Regards,
-Maciek (on behalf of draft authors)

Begin forwarded message:

From: <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-mkonstan-nf-service-density-01.txt
Date: 8 July 2019 at 22:13:51 BST
To: Peter Mikus <[email-masked]<mailto:[email-masked]>>, Maciek Konstantynowicz <[email-masked]<mailto:[email-masked]>>

A new version of I-D, draft-mkonstan-nf-service-density-01.txt
has been successfully submitted by Maciek Konstantynowicz and posted to the
IETF repository.

Name: draft-mkonstan-nf-service-density
Revision: 01
Title: NFV Service Density Benchmarking
Document date: 2019-07-08
Group: Individual Submission
Pages: 29
URL:            https://www.ietf.org/internet-drafts/draft-mkonstan-nf-service-density-01.txt
Status:         https://datatracker.ietf.org/doc/draft-mkonstan-nf-service-density/
Htmlized:       https://tools.ietf.org/html/draft-mkonstan-nf-service-density-01
Htmlized:       https://datatracker.ietf.org/doc/html/draft-mkonstan-nf-service-density
Diff:           https://www.ietf.org/rfcdiff?url2=draft-mkonstan-nf-service-density-01

Abstract:
  Network Function Virtualization (NFV) system designers and operators
  continuously grapple with the problem of qualifying performance of
  network services realised with software Network Functions (NF)
  running on Commercial-Off-The-Shelf (COTS) servers.  One of the main
  challenges is getting repeatable and portable benchmarking results
  and using them to derive deterministic operating range that is
  production deployment worthy.

  This document specifies benchmarking methodology for NFV services
  that aims to address this problem space.  It defines a way for
  measuring performance of multiple NFV service instances, each
  composed of multiple software NFs, and running them at a varied
  service "packing" density on a single server.

  The aim is to discover deterministic usage range of NFV system.  In
  addition specified methodology can be used to compare and contrast
  different NFV virtualization technologies.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

On 3 Jul 2019, at 13:42, Maciek Konstantynowicz (mkonstan) <[email-masked]<mailto:[email-masked]>> wrote:

Dear BMWG,

A working pre -01 version is available in Linux Foundation FD.io<http://FD.io> CSIT
repo, see reference at the bottom.

Appreciate all feedback.

Cheers,
-Maciek

P.S.