Subject: [bmwg] Secdir early review of draft-ietf-bmwg-ngfw-performance-00

From: Kathleen Moriarty via Datatracker <[email-masked]>
Date: Mon, 08 Jul 2019 13:38:08 -0700

Reviewer: Kathleen Moriarty
Review result: Has Nits

Thank you for your work on draft-ietf-bmwg-ngfw-performance.  This is a
straightforward review establishing metrics for comparison of SUT/DUT for
firewalls establishing measurement requirements as well as acceptance criteria.
 When crypto is recommended for use in testing, it's current, although it
should be noted that this is just for test environments.  In terms of security,
I think this document is ready with nits.

Please add a security considerations section.  Feel free to include something
like what's above.

Section 4.1: Nit

Spell out Device under test/system under test on first use.  I don't think it
comes up that often in the IESG review cycle.  I had to look it up and my
memory was jogged.

Sorry for my late 'early' review!

---

From: "Brian Monkman" <[email-masked]>
Date: Mon, 8 Jul 2019 16:40:22 -0400

Thanks for your feedback Kathleen. I will review it with the team and may get back to you with questions.

Brian Monkman

-----Original Message-----
From: Kathleen Moriarty via Datatracker <[email-masked]> 
Sent: July 8, 2019 4:38 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Secdir early review of draft-ietf-bmwg-ngfw-performance-00

Thank you for your work on draft-ietf-bmwg-ngfw-performance.  This is a straightforward review establishing metrics for comparison of SUT/DUT for firewalls establishing measurement requirements as well as acceptance criteria.
 When crypto is recommended for use in testing, it's current, although it should be noted that this is just for test environments.  In terms of security, I think this document is ready with nits.

Please add a security considerations section.  Feel free to include something like what's above.

Section 4.1: Nit

Spell out Device under test/system under test on first use.  I don't think it comes up that often in the IESG review cycle.  I had to look it up and my memory was jogged.

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 9 Jul 2019 07:06:16 +0000

Let me add my thanks for your review Kathleen!

@Brian and team, there is a "standard" security section
in wg chair's slides and other drafts. Please feel 
free to improve and customize the text for this 
case of next-gen firewall benchmarking 
(in isolated test environments, consistent with our charter).

regards,
Al
bmwg co-chair

> From: Brian Monkman [mailto:[email-masked]]
> Sent: Monday, July 8, 2019 4:40 PM
> To: 'Kathleen Moriarty' <[email-masked]>;
> [email-masked]
> Subject: RE: Secdir early review of draft-ietf-bmwg-ngfw-performance-00
> 
> should be noted that this is just for test environments.  In terms of
> security, I think this document is ready with nits.
> 
> Spell out Device under test/system under test on first use.  I don't think
> it comes up that often in the IESG review cycle.  I had to look it up and
> my memory was jogged.
>