Subject: Re: [bmwg] draft-vpolak-mkonstan-bmwg-mlrsearch - call for comments

From: "Maciek Konstantynowicz (mkonstan)" <[email-masked]>
Date: Wed, 3 Jul 2019 12:39:06 +0000

Dear BMWG,

Following presentation and discussion at IETF104, we are looking for
more comments regarding this draft:

  https://tools.ietf.org/html/draft-vpolak-mkonstan-bmwg-mlrsearch-01

A working pre -02 version is available in Linux Foundation FD.io CSIT
repo, see reference at the bottom.

Appreciate all feedback.

Cheers,
-Maciek

P.S.

Links to pre -02 draft version in LF CSIT repo, file in markdown format
compatible with kramdown-rfc2629:

  https://gerrit.fd.io/r/c/18648/
  https://gerrit.fd.io/r/c/18648/2/docs/ietf/draft-vpolak-mkonstan-bmwg-mlrsearch-02.md

One needs to be signed into LF in order to interact with LF gerrit, LF
accounts are free.

---

From: "Maciek Konstantynowicz (mkonstan)" <[email-masked]>
Date: Mon, 8 Jul 2019 22:20:46 +0000

Dear BMWG,
We have just posted updated version of mlrsearch draft.
We are looking for comments and adoption of the draft as BMWG document.

Dear BMWG Chairs,
We would like to ask for a slot during the upcoming IETF105 meeting,
to present this work and ask for BMWG adoption. We will be presenting
remotely. Thanks in advance for accommodating.

Regards,
-Maciek (on behalf of draft authors)

Begin forwarded message:

From: <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-vpolak-mkonstan-bmwg-mlrsearch-02.txt
Date: 8 July 2019 at 22:32:01 BST
To: Vratko Polak <[email-masked]<mailto:[email-masked]>>, Maciek Konstantynowicz <[email-masked]<mailto:[email-masked]>>

A new version of I-D, draft-vpolak-mkonstan-bmwg-mlrsearch-02.txt
has been successfully submitted by Maciek Konstantynowicz and posted to the
IETF repository.

Name: draft-vpolak-mkonstan-bmwg-mlrsearch
Revision: 02
Title: Multiple Loss Ratio Search for Packet Throughput (MLRsearch)
Document date: 2019-07-08
Group: Individual Submission
Pages: 15
URL:            https://www.ietf.org/internet-drafts/draft-vpolak-mkonstan-bmwg-mlrsearch-02.txt
Status:         https://datatracker.ietf.org/doc/draft-vpolak-mkonstan-bmwg-mlrsearch/
Htmlized:       https://tools.ietf.org/html/draft-vpolak-mkonstan-bmwg-mlrsearch-02
Htmlized:       https://datatracker.ietf.org/doc/html/draft-vpolak-mkonstan-bmwg-mlrsearch
Diff:           https://www.ietf.org/rfcdiff?url2=draft-vpolak-mkonstan-bmwg-mlrsearch-02

Abstract:
  This document proposes changes to [RFC2544], specifically to packet
  throughput search methodology, by defining a new search algorithm
  referred to as Multiple Loss Ratio search (MLRsearch for short).
  Instead of relying on binary search with pre-set starting offered
  load, it proposes a novel approach discovering the starting point in
  the initial phase, and then searching for packet throughput based on
  defined packet loss ratio (PLR) input criteria and defined final
  trial duration time.  One of the key design principles behind
  MLRsearch is minimizing the total test duration and searching for
  multiple packet throughput rates (each with a corresponding PLR)
  concurrently, instead of doing it sequentially.

  The main motivation behind MLRsearch is the new set of challenges and
  requirements posed by NFV (Network Function Virtualization),
  specifically software based implementations of NFV data planes.
  Using [RFC2544] in the experience of the authors yields often not
  repetitive and not replicable end results due to a large number of
  factors that are out of scope for this draft.  MLRsearch aims to
  address this challenge and define a common (standard?) way to
  evaluate NFV packet throughput performance that takes into account
  varying characteristics of NFV systems under test.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

On 3 Jul 2019, at 13:39, Maciek Konstantynowicz (mkonstan) <[email-masked]<mailto:[email-masked]>> wrote:

Dear BMWG,

A working pre -02 version is available in Linux Foundation FD.io<http://FD.io> CSIT
repo, see reference at the bottom.

Appreciate all feedback.

Cheers,
-Maciek

P.S.