Subject: [bmwg] [hackathon] BMWG - Containerized Infrastructure Benchmarking

From: 선경재 <[email-masked]>
Date: Mon, 14 Oct 2019 15:48:17 +0900

Hi Folks,

We have uploaded the wiki for " Benchmarking Methodology Working Group
(BMWG)" project in IETF 106 hackathon. In this hackathon, we are trying to
perform tests for the network performance of containerized infrastructure
based on Kubernetes, focusing on to figure out performance impacts by
various resource options. Our draft is also available in BMWG (
https://tools.ietf.org/html/draft-dcn-bmwg-containerized-infra).

Benchmarking Methodology Working Group (BMWG)

•   Champion(s)

o   KJ Sun ([email-masked]), Wangbong Lee ([email-masked])

•   Project(s)

o   The main goal is to figure out container networking performance impacts
by various resource options.

o   https://tools.ietf.org/html/draft-dcn-bmwg-containerized-infra

Details may be updated later.

we expect you to feel free to join and discuss together.

Best Regards,

KJ Sun

====================================================================

*선경재 / Kyoungjae Sun*

Ph.D Student in Distributed Computing and Networking Laboratory / Soongsil
University

Office : +82-2-820-0841    Phone : +82-10-3643-5627

Email : [email-masked]

====================================================================

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Mon, 14 Oct 2019 14:43:40 +0000

Thanks for starting this topic at the Hackathon, KJ!
(removing hackathon list, though).

I’ve been the Champion of the Measurement Systems, Tools, and
Projects topic at the last three Hackathons, and have just
now added the topic again for IETF-106.  There is some
clear cross-over between Benchmarking measurement of
Throughput and IPPM measurement of IP-Layer Capacity.
We can discuss further if you are interested.
Check-out the slides from Hackathon at IETF 105
https://github.com/IETF-Hackathon/ietf105-project-presentations/blob/master/105-acm-Hackathon-Measurements.pdf

BMWG, consider registering for the Hackathon:
https://www.ietf.org/how/runningcode/hackathons/
and participating in KJ’s project or
your own project/other projects that might interest you.

Al
bmwg co-chair

From: hackathon [mailto:[email-masked]] On Behalf Of ???
Sent: Monday, October 14, 2019 2:48 AM
To: [email-masked]; [email-masked]
Cc: 이왕봉 <[email-masked]>; 양현식 <[email-masked]>; 원호준 <[email-masked]>; 박영기 <[email-masked]>
Subject: [hackathon] BMWG - Containerized Infrastructure Benchmarking

Hi Folks,
We have uploaded the wiki for " Benchmarking Methodology Working Group (BMWG)" project in IETF 106 hackathon. In this hackathon, we are trying to perform tests for the network performance of containerized infrastructure based on Kubernetes, focusing on to figure out performance impacts by various resource options. Our draft is also available in BMWG (https://tools.ietf.org/html/draft-dcn-bmwg-containerized-infra<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Ddcn-2Dbmwg-2Dcontainerized-2Dinfra&d=DwQFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-6zYMI&m=7SyeHvlGlaARnacixf8p6SuuDjZfSX17lGrTWxB-Jic&s=UC_Wo22pHayZHdcezBeZNY6nTPhf3SRhKWawbBAlVBQ&e=>).

Benchmarking Methodology Working Group (BMWG)
•   Champion(s)
o   KJ Sun ([email-masked]..kr<mailto:[email-masked]>), Wangbong Lee ([email-masked]<mailto:[email-masked]>)
•   Project(s)
o   The main goal is to figure out container networking performance impacts by various resource options.
o   https://tools.ietf.org/html/draft-dcn-bmwg-containerized-infra<https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Ddcn-2Dbmwg-2Dcontainerized-2Dinfra&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=_6cen3Hn-e_hOm0BhY7aIpA58dd19Z9qGQsr8-6zYMI&m=7SyeHvlGlaARnacixf8p6SuuDjZfSX17lGrTWxB-Jic&s=UC_Wo22pHayZHdcezBeZNY6nTPhf3SRhKWawbBAlVBQ&e=>

Best Regards,

KJ Sun

선경재 / Kyoungjae Sun

Ph..D Student in Distributed Computing and Networking Laboratory / Soongsil University

Email : [email-masked]<mailto:[email-masked]>

---

From: "Charles Eckel (eckelcu)" <[email-masked]>
Date: Tue, 15 Oct 2019 21:17:37 +0000

KJ,

Thank you for bringing this project to the hackathon and for adding it to the wiki.

As a reminder to others who are planning to lead a project at the hackathon, please add it to the wiki. We currently have only 14 projects listed for IETF 106, and I know we will have any more.
https://trac.ietf.org/trac/ietf/meeting/wiki/106hackathon

The sooner you add your project to the wiki, the better the odds of others joining you and your team.

Cheers,
Charles

From: hackathon <[email-masked]> on behalf of 선경재 <[email-masked]>
Date: Monday, October 14, 2019 at 1:49 AM
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: 이왕봉 <[email-masked]>, 양현식 <[email-masked]>, 원호준 <[email-masked]>, 박영기 <[email-masked]>
Subject: [hackathon] BMWG - Containerized Infrastructure Benchmarking

Hi Folks,
We have uploaded the wiki for " Benchmarking Methodology Working Group (BMWG)" project in IETF 106 hackathon. In this hackathon, we are trying to perform tests for the network performance of containerized infrastructure based on Kubernetes, focusing on to figure out performance impacts by various resource options. Our draft is also available in BMWG (https://tools.ietf.org/html/draft-dcn-bmwg-containerized-infra).

Best Regards,

KJ Sun

선경재 / Kyoungjae Sun