Subject: [bmwg] Proposal - Benchmarking Methodology for Network Security Device Performance draft

From: <[email-masked]>
Date: Wed, 12 Aug 2020 14:09:47 -0400

Folks,

During the IETF 108 BMWG virtual meeting Tim Carlin presented on behalf of
NetSecOPEN information on the work we have been doing. The discussion
focussed mainly on the Network IPS test requirements we are planning on
adding.

A comment was made that the draft was getting rather large. After some
discussion we came up with an idea. I was asked to bring it up for
discussion on this mailing list.

In order to move the draft forward and also to allow for continued movement
on developing security testing requirements we are proposing splitting the
draft into different parts.

The first part would be focussed on performance testing elements. We would
expect this to be a stable for the most part and would be ready for IESG
review soon, hopefully this month.

The subsequent parts would be drafts that would capture security
requirements that would be added on to the first part. For example, a draft
that would cover NGFW security requirements and a draft that would cover
Network IPS requirements. These security requirement drafts would frequently
reference the first draft and might, at times, require documentation of
where deviations of the requirements contained in the first draft would be
allowed.

I believe if these changes are acceptable to everyone we will have change
the title of the first draft.

Please let me know if anyone has an issue with this proposal.

Brian

---------

Brian Monkman

Executive Director, NetSecOPEN

Office: +1-717-610-0808 

Fax: +1-717-506-0460

Mobile: +1-717-462-5422

 <https://www.netsecopen.org> https://www.netsecopen.org

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 12 Aug 2020 20:17:19 +0000

Hi Brian,

Thanks for following through on this topic.

you wrote:
The subsequent parts would be drafts that would capture security requirements that would be added on to the first part. For example, a draft that would cover NGFW security requirements and a draft that would cover Network IPS requirements. These security requirement drafts would frequently reference the first draft and might, at times, require documentation of where deviations of the requirements contained in the first draft would be allowed.

I don't mean to be simplistic, but I don't see the term "benchmarking" in the paragraph above.
It seems to me that the draft had more detail or an answer to the question "is this benchmarking?" but I want to be sure the work is included in our charter as a first step.

thanks!
Al
bmwg co-chair

From: bmwg [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, August 12, 2020 2:10 PM
To: [email-masked]
Cc: 'Bala Balarajah' <[email-masked]>
Subject: [bmwg] Proposal - Benchmarking Methodology for Network Security Device Performance draft

Folks,

During the IETF 108 BMWG virtual meeting Tim Carlin presented on behalf of NetSecOPEN information on the work we have been doing. The discussion focussed mainly on the Network IPS test requirements we are planning on adding.

A comment was made that the draft was getting rather large. After some discussion we came up with an idea. I was asked to bring it up for discussion on this mailing list.

In order to move the draft forward and also to allow for continued movement on developing security testing requirements we are proposing splitting the draft into different parts.

The first part would be focussed on performance testing elements. We would expect this to be a stable for the most part and would be ready for IESG review soon, hopefully this month.

The subsequent parts would be drafts that would capture security requirements that would be added on to the first part. For example, a draft that would cover NGFW security requirements and a draft that would cover Network IPS requirements. These security requirement drafts would frequently reference the first draft and might, at times, require documentation of where deviations of the requirements contained in the first draft would be allowed.

I believe if these changes are acceptable to everyone we will have change the title of the first draft.

Brian

---------
Brian Monkman

https://www.netsecopen.org<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.netsecopen.org&d=DwMFAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=UjnH8qu3pYPOFQJQR8K3n22Cf97aRrvN-W2ALQaFkZQ&s=uN-1N6ZoPq8H5iflqtW_5rt5Crd4CpdBYj9DlkCCYS0&e=>