Subject: [bmwg] New Version for draft Methodology for VNF Benchmarking Automation

From: Raphael Vicente Rosa <[email-masked]>
Date: Tue, 20 Oct 2020 14:25:00 -0300

Hi BMWG members,

We submitted a new version of the draft "Methodology for VNF Benchmarking
Automation", see below.

@BMWG Chairs: we would like a slot to present the draft updates (e.g.,
addressing the comments of the mailing-list) in the next IETF/BMWG meeting
and propose it to be adopted by the working group.

Best regards,
Raphael

A new version of I-D, draft-rosa-bmwg-vnfbench-06.txt
has been successfully submitted by Raphael Vicente Rosa and posted to the
IETF repository.

Name:           draft-rosa-bmwg-vnfbench
Revision:       06
Title:          Methodology for VNF Benchmarking Automation
Document date:  2020-10-20
Group:          Individual Submission
Pages:          49
URL:
https://www.ietf.org/archive/id/draft-rosa-bmwg-vnfbench-06.txt
Status:         https://datatracker.ietf.org/doc/draft-rosa-bmwg-vnfbench/
Htmlized:
https://datatracker.ietf.org/doc/html/draft-rosa-bmwg-vnfbench
Htmlized:       https://tools.ietf.org/html/draft-rosa-bmwg-vnfbench-06
Diff:
https://www.ietf.org/rfcdiff?url2=draft-rosa-bmwg-vnfbench-06

Abstract:
   This document describes a common methodology for the automated
   benchmarking of Virtualized Network Functions (VNFs) executed on
   general-purpose hardware.  Specific cases of automated benchmarking
   methodologies for particular VNFs can be derived from this document.
   An open source reference implementation is reported as running code
   embodiment of the proposed, automated benchmarking methodology.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Tue, 20 Oct 2020 17:37:28 +0000

Hi Raphael, welcome back!

What are the updates we can expect to read in the latest draft?

Al
bmwg co-chair

From: bmwg [mailto:[email-masked]] On Behalf Of Raphael Vicente Rosa
Sent: Tuesday, October 20, 2020 1:25 PM
To: [email-masked]
Subject: [bmwg] New Version for draft Methodology for VNF Benchmarking Automation

Hi BMWG members,

We submitted a new version of the draft "Methodology for VNF Benchmarking Automation", see below.

@BMWG Chairs: we would like a slot to present the draft updates (e.g., addressing the comments of the mailing-list) in the next IETF/BMWG meeting and propose it to be adopted by the working group.

Best regards,
Raphael

Name:           draft-rosa-bmwg-vnfbench
Revision:       06
Title:          Methodology for VNF Benchmarking Automation
Document date:  2020-10-20
Group:          Individual Submission
Pages:          49
URL:            https://www.ietf.org/archive/id/draft-rosa-bmwg-vnfbench-06.txt<https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-rosa-bmwg-vnfbench-06.txt__;!!BhdT!3cH5bVyOTbrnUEYtPCIt78eTqjM3FF6OfBUQyGYogIG5TgzhZFgVJNEur1Ar$>
Status:         https://datatracker.ietf.org/doc/draft-rosa-bmwg-vnfbench/<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-rosa-bmwg-vnfbench/__;!!BhdT!3cH5bVyOTbrnUEYtPCIt78eTqjM3FF6OfBUQyGYogIG5TgzhZFgVJKrUDB7P$>
Htmlized:       https://datatracker.ietf.org/doc/html/draft-rosa-bmwg-vnfbench<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-rosa-bmwg-vnfbench__;!!BhdT!3cH5bVyOTbrnUEYtPCIt78eTqjM3FF6OfBUQyGYogIG5TgzhZFgVJP8XAMxk$>
Htmlized:       https://tools.ietf.org/html/draft-rosa-bmwg-vnfbench-06<https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-rosa-bmwg-vnfbench-06__;!!BhdT!3cH5bVyOTbrnUEYtPCIt78eTqjM3FF6OfBUQyGYogIG5TgzhZFgVJKw8XcyD$>
Diff:           https://www.ietf.org/rfcdiff?url2=draft-rosa-bmwg-vnfbench-06<https://urldefense.com/v3/__https:/www.ietf.org/rfcdiff?url2=draft-rosa-bmwg-vnfbench-06__;!!BhdT!3cH5bVyOTbrnUEYtPCIt78eTqjM3FF6OfBUQyGYogIG5TgzhZFgVJLo_GgVw$>

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<https://urldefense.com/v3/__http:/tools.ietf.org/__;!!BhdT!3cH5bVyOTbrnUEYtPCIt78eTqjM3FF6OfBUQyGYogIG5TgzhZFgVJJe1MOBJ$>.

The IETF Secretariat

---

From: Raphael Vicente Rosa <[email-masked]>
Date: Tue, 20 Oct 2020 16:16:26 -0300

Hi Al,

Good to be back!
Sorry for being inactive for a while, tough times we are living in, but the
interest in the draft keeps alive.

Thanks for asking, the main draft updates are:

1. The introduction states a clear/better motivation for the draft;
2. In considerations, we clearly state what are the "Phases of a
Benchmarking Test" subject to automation;
3. The methodology depicts the need of YANG modules, explains them, and
presents the procedures that define the flow of information involved in
utilizing the YANG models to realize the methodology for VNF benchmarking
automation;
4. The methodology explains the composition of a VNF benchmarking report,
its inputs and outputs, by the means of automation and utilizing the draft
considerations (e.g., components of the proposed architectural framework);
5. YANG modules were added to the draft (not sure if it is correct, help
needed there);
6. Some of the sections/subsections titles were changed for clarity;
7. The reference implementation realizes all the methodology (getting some
results to present).

It was a major refactor in the draft content, giving more maturity to it
while clarifying its core concepts and proposal.

Raphael

On Tue, Oct 20, 2020 at 2:37 PM MORTON, ALFRED C (AL) <[email-masked]>
wrote:

> *From:* bmwg [mailto:[email-masked]] *On Behalf Of *Raphael
> Vicente Rosa
> *Sent:* Tuesday, October 20, 2020 1:25 PM
> *To:* [email-masked]
> *Subject:* [bmwg] New Version for draft Methodology for VNF Benchmarking
> Automation
>
>
>
> Hi BMWG members,
>
>
>
> <https://urldefense.com/v3/__https:/www.ietf.org/archive/id/draft-rosa-bmwg-vnfbench-06.txt__;!!BhdT!3cH5bVyOTbrnUEYtPCIt78eTqjM3FF6OfBUQyGYogIG5TgzhZFgVJNEur1Ar$>
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/draft-rosa-bmwg-vnfbench/__;!!BhdT!3cH5bVyOTbrnUEYtPCIt78eTqjM3FF6OfBUQyGYogIG5TgzhZFgVJKrUDB7P$>
> Htmlized:
> <https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/draft-rosa-bmwg-vnfbench__;!!BhdT!3cH5bVyOTbrnUEYtPCIt78eTqjM3FF6OfBUQyGYogIG5TgzhZFgVJP8XAMxk$>
> <https://urldefense.com/v3/__https:/tools.ietf.org/html/draft-rosa-bmwg-vnfbench-06__;!!BhdT!3cH5bVyOTbrnUEYtPCIt78eTqjM3FF6OfBUQyGYogIG5TgzhZFgVJKw8XcyD$>
> Diff:
> <https://urldefense.com/v3/__https:/www.ietf.org/rfcdiff?url2=draft-rosa-bmwg-vnfbench-06__;!!BhdT!3cH5bVyOTbrnUEYtPCIt78eTqjM3FF6OfBUQyGYogIG5TgzhZFgVJLo_GgVw$>
>
> Abstract:
> until the htmlized version and diff are available at tools.ietf.org
> <https://urldefense.com/v3/__http:/tools.ietf.org/__;!!BhdT!3cH5bVyOTbrnUEYtPCIt78eTqjM3FF6OfBUQyGYogIG5TgzhZFgVJJe1MOBJ$>
> .
>
> The IETF Secretariat
>