Subject: [bmwg] Several inconsistencies in current draft-ietf-bmwg-ngfw-performance

From: Redkin Petr <[email-masked]>
Date: Wed, 7 Apr 2021 11:00:30 +0000

Hello,

Please, pay attention at several inconsistencies in current netsecopen draft (saw in 6-7 versions).

1.       TLS SNI

a.       in part of the document SNI is mandatory
The client endpoint SHOULD send TLS Extension Server Name Indication (SNI) information when opening a security tunnel

b.       in part of the document SNI is optional
For TLS the client MAY use Server Name Indication (SNI).
If using SNI, the server will then perform an SNI name check with the proposed FQDN compared to the domain embedded in the certificate.

2.       New connections in sustain phase

a.       From this sentence engineer may assume, that no new connections are established in sustain phase because all clients & connections (it is different concepts) must be established at a ramp up

Sustain phase starts when all required clients (connections) are active and operating at their desired load condition.

b.       But it is not, otherwise we cannot measure CPS metric in sustain phase, for example in traffic mix test
Optional KPIs: TCP Connections Per Second and TLS Handshake Rate

3.       Client source port

a.       In part of the document source port is variable in range and varies per client connection
The source port range SHOULD be in the range of 1024 - 65535.
The behavior of the client is to sweep through the given server IP space, sequentially generating a recognizable service by the DUT.  Thus, a balanced, mesh between client endpoints and server endpoints will be generated in a client port server port combination.

b.       But it is not clear from this sentence
Each client endpoint performs the same actions as other endpoints, with the difference being the source IP of the client endpoint and the target server IP pool.

Best Regards,
Petr Redkin

Performance research expert,
JSC "InfoTeCS"

---

From: <[email-masked]>
Date: Wed, 7 Apr 2021 11:21:34 -0400

Thanks for your feedback Petr. It is appreciated. We will look at these and
let you know if we have any questions.

Brian

From: bmwg <[email-masked]> On Behalf Of Redkin Petr
Sent: Wednesday, April 7, 2021 7:01 AM
To: [email-masked]
Subject: [bmwg] Several inconsistencies in current
draft-ietf-bmwg-ngfw-performance

Hello,

Please, pay attention at several inconsistencies in current netsecopen draft
(saw in 6-7 versions).

1.	TLS SNI

The client endpoint SHOULD send TLS Extension Server Name Indication (SNI)
information when opening a security tunnel

If using SNI, the server will then perform an SNI name check with the
proposed FQDN compared to the domain embedded in the certificate.

a.	From this sentence engineer may assume, that no new connections are
established in sustain phase because all clients & connections (it is
different concepts) must be established at a ramp up

Sustain phase starts when all required clients (connections) are active and
operating at their desired load condition.

b.	But it is not, otherwise we cannot measure CPS metric in sustain
phase, for example in traffic mix test

3.	Client source port

a.	In part of the document source port is variable in range and varies
per client connection

The behavior of the client is to sweep through the given server IP space,
sequentially generating a recognizable service by the DUT.  Thus, a
balanced, mesh between client endpoints and server endpoints will be
generated in a client port server port combination.

Each client endpoint performs the same actions as other endpoints, with the
difference being the source IP of the client endpoint and the target server
IP pool.

Best Regards, 

Petr Redkin

JSC "InfoTeCS"

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 7 Apr 2021 15:31:23 +0000

Hi Petr,

Thanks for your comments on the NGFW draft.  Please subscribe to bmwg-list to ensure that you see all replies.

A few replies below, [acm]
Al
(as document shepherd)

From: bmwg <[email-masked]> On Behalf Of Redkin Petr
Sent: Wednesday, April 7, 2021 7:01 AM
To: [email-masked]
Subject: [bmwg] Several inconsistencies in current draft-ietf-bmwg-ngfw-performance

Hello,

  1.  TLS SNI

     *   in part of the document SNI is mandatory
The client endpoint SHOULD send TLS Extension Server Name Indication (SNI) information when opening a security tunnel

     *   in part of the document SNI is optional
For TLS the client MAY use Server Name Indication (SNI).
If using SNI, the server will then perform an SNI name check with the proposed FQDN compared to the domain embedded in the certificate.
[acm]
I want to note our Requirements language, which says that only terms like MUST and SHALL indicate mandatory requirements.  SHOULD is a strong recommendation, and MAY is optional of course, so there are two different requirement levels being used as you point out. I'll let the authors explain their rationale for different requirements levels for SNI (in different tests, perhaps?).

  1.  New connections in sustain phase

     *   From this sentence engineer may assume, that no new connections are established in sustain phase because all clients & connections (it is different concepts) must be established at a ramp up

     *   But it is not, otherwise we cannot measure CPS metric in sustain phase, for example in traffic mix test
Optional KPIs: TCP Connections Per Second and TLS Handshake Rate

  1.  Client source port

     *   In part of the document source port is variable in range and varies per client connection
The source port range SHOULD be in the range of 1024 - 65535.
The behavior of the client is to sweep through the given server IP space, sequentially generating a recognizable service by the DUT.  Thus, a balanced, mesh between client endpoints and server endpoints will be generated in a client port server port combination.

     *   But it is not clear from this sentence
Each client endpoint performs the same actions as other endpoints, with the difference being the source IP of the client endpoint and the target server IP pool.

Best Regards,
Petr Redkin

---

From: <[email-masked]>
Date: Thu, 8 Apr 2021 06:50:59 -0400

Petr,

Here's our response to each item..

Response for Comment 1: 

The confusion or inconsistency has occurred since we use SNI as mandatory
for a test scenario (traffic mix test) and as optional for other test
scenarios.

We will revise the text and provide more clarity in the next version.

  Response for Comment 2:   

The sentence doesn't describe that the client must keep the connections open
during the sustain phase. However, we can change the sentence as follows 

"Sustain phase starts when all required clients (connections) are active and
operating at their desired load condition."

This means that the clients/client endpoints are established their required
target connection (based on configured load). It is obvious that the clients
will close the connections once they received all contents from the server.
Also, the clients will establish new connections during the sustain phase.
Otherwise, there is no traffic in the sustain phase and the test equipment
can't keep the desired load.

  Response for Comment 3:  

The endpoints perform the same action. However, the IPs (SRC and DST) and
also ports (random source port from the range) are different. we can change
the text if more clarity required.

"Thus, a balanced mesh between client endpoints and server endpoints will be
generated in a client IP/port server IP/port combination.

Brian and Bala

From: bmwg <[email-masked]> On Behalf Of MORTON, ALFRED C (AL)
Sent: Wednesday, April 7, 2021 11:31 AM
To: Redkin Petr <Petr.Redkin=[email-masked]>; [email-masked]
Subject: Re: [bmwg] Several inconsistencies in current
draft-ietf-bmwg-ngfw-performance

Hi Petr,

Thanks for your comments on the NGFW draft.  Please subscribe to bmwg-list
to ensure that you see all replies.

(as document shepherd)

From: bmwg <[email-masked] <mailto:[email-masked]> > On Behalf
Of Redkin Petr
Sent: Wednesday, April 7, 2021 7:01 AM
To: [email-masked] <mailto:[email-masked]> 
Subject: [bmwg] Several inconsistencies in current
draft-ietf-bmwg-ngfw-performance

Hello,

1.	TLS SNI

[acm] 

I want to note our Requirements language, which says that only terms like
MUST and SHALL indicate mandatory requirements.  SHOULD is a strong
recommendation, and MAY is optional of course, so there are two different
requirement levels being used as you point out. I'll let the authors explain
their rationale for different requirements levels for SNI (in different
tests, perhaps?).

3.	Client source port

 

Best Regards, 

Petr Redkin

JSC "InfoTeCS"

---

From: Redkin Petr <[email-masked]>
Date: Thu, 8 Apr 2021 11:30:44 +0000

I think that the proposed changes (for all comments) will make the text of the document more understandable and eliminate potential differences in interpretations. Thanks.

I also suggest revise the document in the context of supporting non-inline products (NGFW or NGIDS/NGIPS device in monitor-only mode) in performance tests or restrict it to only inline mode as in security effectiveness test. The estimation approach based on traffic degradation is not applicable in this case.

Best Regards,
Petr Redkin

From: [email-masked] <[email-masked]>
Sent: Thursday, April 8, 2021 1:51 PM
To: Redkin Petr <[email-masked]>
Cc: 'MORTON, ALFRED C (AL)' <[email-masked]>; [email-masked]; 'Bala Balarajah' <[email-masked]>
Subject: RE: [bmwg] Several inconsistencies in current draft-ietf-bmwg-ngfw-performance

Petr,

Here’s our response to each item….

Response for Comment 1:
The confusion or inconsistency has occurred since we use SNI as mandatory for a test scenario (traffic mix test) and as optional for other test scenarios.
We will revise the text and provide more clarity in the next version.

  Response for Comment 2:
The sentence doesn't describe that the client must keep the connections open during the sustain phase. However, we can change the sentence as follows
"Sustain phase starts when all required clients (connections) are active and operating at their desired load condition."
This means that the clients/client endpoints are established their required target connection (based on configured load). It is obvious that the clients will close the connections once they received all contents from the server. Also, the clients will establish new connections during the sustain phase. Otherwise, there is no traffic in the sustain phase and the test equipment can't keep the desired load.

  Response for Comment 3:
The endpoints perform the same action. However, the IPs (SRC and DST) and also ports (random source port from the range) are different. we can change the text if more clarity required.
"Thus, a balanced mesh between client endpoints and server endpoints will be generated in a client IP/port server IP/port combination.

Brian and Bala

From: bmwg <[email-masked]<mailto:[email-masked]>> On Behalf Of MORTON, ALFRED C (AL)
Sent: Wednesday, April 7, 2021 11:31 AM
To: Redkin Petr <Petr.Redkin=[email-masked]<mailto:Petr.Redkin=[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [bmwg] Several inconsistencies in current draft-ietf-bmwg-ngfw-performance

Hi Petr,

From: bmwg <[email-masked]<mailto:[email-masked]>> On Behalf Of Redkin Petr
Sent: Wednesday, April 7, 2021 7:01 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [bmwg] Several inconsistencies in current draft-ietf-bmwg-ngfw-performance

Hello,

  1.  TLS SNI

     *   in part of the document SNI is optional
For TLS the client MAY use Server Name Indication (SNI).
If using SNI, the server will then perform an SNI name check with the proposed FQDN compared to the domain embedded in the certificate.
[acm]
I want to note our Requirements language, which says that only terms like MUST and SHALL indicate mandatory requirements.  SHOULD is a strong recommendation, and MAY is optional of course, so there are two different requirement levels being used as you point out. I’ll let the authors explain their rationale for different requirements levels for SNI (in different tests, perhaps?).

  1.  Client source port

Best Regards,
Petr Redkin

---

From: Brian Monkman <[email-masked]>
Date: Thu, 8 Apr 2021 11:31:50 +0000

Thanks for you suggestion.

Brian

Get Outlook for iOS<https://aka.ms/o0ukef>
________________________________
From: Redkin Petr <[email-masked]>
Sent: Thursday, April 8, 2021 7:30:44 AM
To: [email-masked] <[email-masked]>
Cc: 'MORTON, ALFRED C (AL)' <[email-masked]>; [email-masked] <[email-masked]>; 'Bala Balarajah' <[email-masked]>
Subject: RE: [bmwg] Several inconsistencies in current draft-ietf-bmwg-ngfw-performance

Best Regards,

Petr Redkin

JSC "InfoTeCS"

Petr,

Response for Comment 1:

  Response for Comment 2:

  Response for Comment 3:

Brian and Bala

Hi Petr,

(as document shepherd)

Hello,

  1.  TLS SNI

[acm]

  1.  Client source port

Best Regards,

Petr Redkin

JSC "InfoTeCS"