Subject: Re: [bmwg] Martin Duke's Discuss on draft-ietf-bmwg-evpntest-09: (with DISCUSS and COMMENT)

From: "Sudhin" <[email-masked]>
Date: 1 Jul 2021 07:32:30 -0000

Hi All,

Thanks for the comments. Please see the reply inline.

Regards,
Sudhin

From: Sarah Banks &lt;[email-masked]&gt;
Sent: Tue, 29 Jun 2021 23:04:43
To: Martin Duke &lt;[email-masked]&gt;
Cc: The IESG &lt;[email-masked]&gt;, [email-masked], [email-masked], [email-masked]
Subject: Re: [bmwg] Martin Duke&#39;s Discuss on draft-ietf-bmwg-evpntest-09: (with DISCUSS and COMMENT)

Hi Martin,
&nbsp; &nbsp;Thanks for your review and comments. The authors are cc&#39;ed here, and will review the feedback and provide the appropriate next steps.

Thanks,
Sarah

&gt; On Jun 28, 2021, at 4:49 PM, Martin Duke via Datatracker &lt;[email-masked]&gt; wrote:
&gt;
&gt; Martin Duke has entered the following ballot position for
&gt; draft-ietf-bmwg-evpntest-09: Discuss
&gt;
&gt; When responding, please keep the subject line intact and reply to all
&gt; email addresses included in the To and CC lines. (Feel free to cut this
&gt; introductory paragraph, however.)
&gt;
&gt;
&gt; Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
&gt; for more information about DISCUSS and COMMENT positions.
&gt;
&gt;
&gt; The document, along with other ballot positions, can be found here:
&gt; https://datatracker.ietf.org/doc/draft-ietf-bmwg-evpntest/
&gt;
&gt;
&gt;
&gt; ----------------------------------------------------------------------
&gt; DISCUSS:
&gt; ----------------------------------------------------------------------
&gt;
&gt; (3.8) (4.8) Why is packet loss measured in time? How is learning 2X MAC
&gt; addresses relevant to the packet loss measurement at the traffic generator? How
&gt; long does the traffic generator have to wait to conclude that the packet is
&gt; lost?

Sudhin&gt;&gt;&gt;&gt;&gt; HA &nbsp;test must be measured in seconds. Because the learning of Mac is needed to ensure frames are not flooded. Traffic generator calculations are beyond the scope of the draft. These devices are calibrated by the respective vendors.&nbsp;
&gt;
&gt; (3.9) Is a single failure to learn an address sufficient to determine that the
&gt; device has reached capacity? Or could packet loss or some other phenomenon lose
&gt; some addresses? In other words, be more precise on how polling reveals the
&gt; capacity.
Sudhin&gt;&gt;&gt; This is explained in the procedure section, which means the DUT can&#39;t learn any incremental values of MAC+IP/MAC+ipv6.

&gt; Is there some lower bound on the time between sending ARP/ND packets and
&gt; querying the DUT?

Sudhin&gt;&gt;&gt; As explained above each 5% increase the data is validated.

&gt; (3.11, 3.12, 4.10, 4.11) Does the traffic generator send F frames in total or F
&gt; ffs? The spec says both. Are there any constraints on F, perhaps an integer
&gt; multiple of X?

Sudhin&gt; F as variable is selected due to the fact it must be different from Mac values which is denoted by &#39;X&#39;. Yes F is an integer value to denote frames per sec.
&gt;
&gt; ----------------------------------------------------------------------
&gt; COMMENT:
&gt; ----------------------------------------------------------------------
&gt;
&gt; (3.10, 4.9) Again, is there a minimum time between sending the traffic and
&gt; querying the result?

Sudhin&gt;&gt;&gt;&gt; &nbsp;The traffic is continuous and query interval to poll script must have minimum delay of 1s.
&gt;
&gt; (3.12, 4.11) I don&rsquo;t believe you&rsquo;ve adequately addressed Al&rsquo;s TSVART review.
&gt; What does &ldquo;100% compared to the average usage&rdquo; mean? Is that double? Shouldn&rsquo;t
&gt; there be a formula to compute average usage?

Sudhin&gt;&gt; CPU usages goes from 0% to 100%. Average usage is the usage of DUT during the start of the test. For example it can be 20% or 25% it must not spike to 100%.
&gt;
&gt; As Al asks, what is the threshold over which an increase in memory usage will
&gt; fail the test?

Sudhin&gt;&gt; As the test says the memory should not increase with respect to time. If it is then it is a failure.
&gt;
&gt;
&gt;
&gt; _______________________________________________
&gt; bmwg mailing list
&gt; [email-masked]
&gt; https://www.ietf.org/mailman/listinfo/bmwg
&nbsp;

---

From: Martin Duke <[email-masked]>
Date: Thu, 1 Jul 2021 10:13:22 -0700

Thanks for your responses

I am trying to be quite literal and precise here, and my overall sense is
that the text has many assumptions built into it that I would like to make
explicit.

On Thu, Jul 1, 2021 at 12:32 AM Sudhin <[email-masked]> wrote:

> > ----------------------------------------------------------------------
> > DISCUSS:
> > ----------------------------------------------------------------------
> >
> > (3.8) (4.8) Why is packet loss measured in time? How is learning 2X MAC
> > addresses relevant to the packet loss measurement at the traffic
> generator? How
> > long does the traffic generator have to wait to conclude that the packet
> is
> > lost?
>
> Sudhin>>>>> HA  test must be measured in seconds. Because the learning of
> Mac is needed to ensure frames are not flooded. Traffic generator
> calculations are beyond the scope of the draft. These devices are
> calibrated by the respective vendors.
>

I cannot reconcile this reply with the text in the draft: "Objective:
Measure traffic loss during routing engine fail over."

Maybe the objective is to measure the time till the standby device acquires
all the state, AND the packet loss, if any?

It would appear also that there is a hidden requirement that the topology
must not have a delay or jitter than exceeds the loss detection algorithm
of the generator.

> >
> > (3.9) Is a single failure to learn an address sufficient to determine
> that the
> > device has reached capacity? Or could packet loss or some other
> phenomenon lose
> > some addresses? In other words, be more precise on how polling reveals
> the
> > capacity.
> Sudhin>>> This is explained in the procedure section, which means the DUT
> can't learn any incremental values of MAC+IP/MAC+ipv6.
>

I read the procedure section, and I still have these questions. If I send X
ARP/ND messages and there are X-1 entries in the table, does that
conclusively prove that the limit is X-1, or might a packet have been lost?

>
> > Is there some lower bound on the time between sending ARP/ND packets and
> > querying the DUT?
>
> Sudhin>>> As explained above each 5% increase the data is validated.
>

That is not my question. If I send an ARP or ND message, and then query 1
us later, should I expect to see that entry in the result? (I see in [3.10]
below, IIUC, that you answer that the expectation is 1 sec.)

>
> > (3.11, 3.12, 4.10, 4.11) Does the traffic generator send F frames in
> total or F
> > ffs? The spec says both. Are there any constraints on F, perhaps an
> integer
> > multiple of X?
>
> Sudhin> F as variable is selected due to the fact it must be different
> from Mac values which is denoted by 'X'. Yes F is an integer value to
> denote frames per sec.
>

Alright please apply s/Send F frames/Send F frames per second in these
sections. Please also add text defining limits ando/or considerations for
choosing F.

>
> > ----------------------------------------------------------------------
> > COMMENT:
> > ----------------------------------------------------------------------
> >
> > (3.10, 4.9) Again, is there a minimum time between sending the traffic
> and
> > querying the result?
>
> Sudhin>>>>  The traffic is continuous and query interval to poll script
> must have minimum delay of 1s.
>

Wonderful -- please add this limit to these sections and (3.9)

> >
> > (3.12, 4.11) I don’t believe you’ve adequately addressed Al’s TSVART
> review.
> > What does “100% compared to the average usage” mean? Is that double?
> Shouldn’t
> > there be a formula to compute average usage?
>
> Sudhin>> CPU usages goes from 0% to 100%. Average usage is the usage of
> DUT during the start of the test. For example it can be 20% or 25% it must
> not spike to 100%.
>

As an example, at the start of the test, the CPU usage is 10%. If at any
point CPU usage is 100%, it fails, but if it never exceeds 99.9%, it
passes? If so, deleting the phrase "compared to the average usage" would
make this clearer.

> >
> > As Al asks, what is the threshold over which an increase in memory usage
> will
> > fail the test?
>
> Sudhin>> As the test says the memory should not increase with respect to
> time. If it is then it is a failure.
> >
>

Say the memory usage at the start of the test is 25%.

If it momentarily increases to 25.1% and then goes back down again, is that
a failure?

If it ends the test at 25.1%, is that failure?

> >
> >
> > _______________________________________________
> > bmwg mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/bmwg
> <https://www.ietf.org/mailman/listinfo/bmwg==>
>
>