Subject: [bmwg] Version 10, draft-ietf-bmwg-ngfw-performance

From: <[email-masked]>
Date: Sun, 26 Sep 2021 10:30:54 -0400

Folks,

An update to draft-ietf-bmwg-ngfw-performance has been posted. I believe the
next step is WG Chair review.

Version 10 has gone through multiple reviews . As a result, we have
corrected a number of typos and grammatical errors. Additionally, we
clarified wording in a few spots. The following has also been changed as a
result of comments/discussions from/with Sarah Banks. (Sarah, thank you.)

*	Removed NGIDS from the draft
*	Added the following text in section 3 for "Inline" mode and
"Fail-open" clarification: " This document provides testing terminology and
testing methodology for modern and next-generation network security devices
that are configured in Active ("Inline") mode."
*	Also, we added the following text in section 4.2:  "DUT/SUT MUST be
configured in "Inline" mode so that the traffic is actively inspected by the
DUT/SUT.  Also "Fail-Open" behavior MUST be disabled on the DUT/SUT."
*	Added more clarification for the parameters and values defined in
section "4.3.1.  Client Configuration": This section specifies which
parameters SHOULD be considered while configuring clients using test
equipment.  Also, this section specifies the RECOMMENDED values for certain
parameters.  The values are the defaults used in most of the client
operating systems currently.
*	Rephrased section 5 " Testbed Consideration". Added recommended
steps for reference test.
*	Explained the usage of the parameter "Initial throughput": "Initial
throughput is not a KPI to report.  This value is configured on the traffic
generator and used to perform Step 1: "Test Initialization and
Qualification" described under the Section 7.1.4."

Brian

---------

Brian Monkman

Executive Director, NetSecOPEN

Office: +1-717-610-0808 

Fax: +1-717-506-0460

Mobile: +1-717-462-5422

 <https://www.netsecopen.org> https://www.netsecopen.org

---

From: "MORTON JR., AL" <[email-masked]>
Date: Sun, 26 Sep 2021 16:54:15 +0000

BMWG,

Those who have submitted comments on recent versions (8,9) should check the diffs now.
Please confirm that your comments have been addressed in version 10, by e-mail, ASAP.

thanks,
Al
bmwg co-chair

From: bmwg <[email-masked]> On Behalf Of [email-masked]
Sent: Sunday, September 26, 2021 10:31 AM
To: [email-masked]
Cc: [email-masked]
Subject: [bmwg] Version 10, draft-ietf-bmwg-ngfw-performance

Folks,

An update to draft-ietf-bmwg-ngfw-performance has been posted. I believe the next step is WG Chair review.

Version 10 has gone through multiple reviews . As a result, we have corrected a number of typos and grammatical errors. Additionally, we clarified wording in a few spots. The following has also been changed as a result of comments/discussions from/with Sarah Banks. (Sarah, thank you.)

  *   Removed NGIDS from the draft
  *   Added the following text in section 3 for "Inline" mode and "Fail-open" clarification: " This document provides testing terminology and testing methodology for modern and next-generation network security devices that are configured in Active ("Inline") mode."
  *   Also, we added the following text in section 4.2:  "DUT/SUT MUST be configured in "Inline" mode so that the traffic is actively inspected by the DUT/SUT.  Also "Fail-Open" behavior MUST be disabled on the DUT/SUT."
  *   Added more clarification for the parameters and values defined in section "4.3.1.  Client Configuration": This section specifies which parameters SHOULD be considered while configuring clients using test equipment.  Also, this section specifies the RECOMMENDED values for certain parameters.  The values are the defaults used in most of the client operating systems currently.
  *   Rephrased section 5 " Testbed Consideration". Added recommended steps for reference test.
  *   Explained the usage of the parameter "Initial throughput": "Initial throughput is not a KPI to report.  This value is configured on the traffic generator and used to perform Step 1: "Test Initialization and Qualification" described under the Section 7.1.4."
Brian

---------
Brian Monkman

https://www.netsecopen.org<https://urldefense.com/v3/__https:/www.netsecopen.org__;!!BhdT!wpaM8GOInxvNJdztL0uqXkYCL1UWmjmmAASp8hiMJEKN0JgjzEyGqz2m7207$>