Subject: Re: [bmwg] [Technical Errata Reported] RFC8239 (6763)

From: Leonard Yu <[email-masked]>
Date: Wed, 1 Dec 2021 08:37:47 +0000

I was assuming the texts describing Iteration 1 & 2 were incorrect. But from the drawing below, I can see it is the text describing iteration 1 and 2 are incorrect.

I will make a new errara report for to correct the texts for iteration 1 &2
[Text, letter  Description automatically generated]

From: Lucien <[email-masked]>
Date: Tuesday, 30 November 2021 at 20.56
To: MORTON JR., AL <[email-masked]>
Cc: Jacob Rapp <[email-masked]>, RFC Errata System <[email-masked]>, Sarah B <[email-masked]>, Warren Kumari <[email-masked]>, [email-masked] <[email-masked]>, Leonard Yu <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: [Technical Errata Reported] RFC8239 (6763)
Here is a picture illustrating it, sorry my ascii skills for drawing are not there yet.

On Tue, Nov 30, 2021 at 11:55 MORTON JR., AL <[email-masked]<mailto:[email-masked]>> wrote:
Thanks for your quick reply, Lucien!
Al

From: Lucien <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, November 30, 2021 2:29 PM
To: RFC Errata System <[email-masked]<mailto:[email-masked]>>
Cc: Jacob Rapp <[email-masked]<mailto:[email-masked]>>; Warren Kumari <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; MORTON JR., AL <[email-masked]<mailto:[email-masked]>>; Sarah B <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Technical Errata Reported] RFC8239 (6763)

Hello,

This errata is incorrect. The original text is correct.

Lucien

On Tue, Nov 30, 2021 at 6:47 AM RFC Errata System <[email-masked]<mailto:[email-masked]>> wrote:
The following errata report has been submitted for RFC8239,
"Data Center Benchmarking Methodology".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6763<https://urldefense.com/v3/__https:/www.rfc-editor.org/errata/eid6763__;!!BhdT!wScd1KMc51KUWqw0VGpG0Koz6W11ctc3VWC0cf5ClMcedcAYPseHP0RwShhp$>

--------------------------------------
Type: Technical
Reported by: Leonard Yu <[email-masked]<mailto:[email-masked]>>

Section: 3.2

Original Text
-------------
Last iteration: Ingress port 1 sending line rate to egress
port 2, ingress port 3 sending line rate to egress port 4, etc.
Ingress port N-1 and port N will oversubscribe, at 1% of line
rate, egress port N-3 and port N-2, respectively. Measure the
buffer size value by multiplying the number of extra frames
sent by the frame size for each egress port.

Corrected Text
--------------
Last iteration: Ingress port 1 sending line rate to egress
port 2, ingress port 3 sending line rate to egress port 4, etc.
Ingress port N-1 and port N will oversubscribe, at 1% of line
rate, egress port N-4 and port N-3, respectively. Measure the
buffer size value by multiplying the number of extra frames
sent by the frame size for each egress port.

Notes
-----
If
#1, 1->2, 3->4, 5->6, 7->8, ... and N-1->2, N->3
#2, 1->2, 3->4, 5->6, 7->8, ... and N-1->4, N->5

Then
#last, 1->2, 3->4, 5->6, 7->8, ... and N-1->N-4, N->N-3

Otherwise, the general equation won't satisfy #1 and #2

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party
can log in to change the status and edit the report, if necessary.

--------------------------------------
RFC8239 (draft-ietf-bmwg-dcbench-methodology-18)
--------------------------------------
Title               : Data Center Benchmarking Methodology
Publication Date    : August 2017
Author(s)           : L. Avramov, J. Rapp
Category            : INFORMATIONAL
Source              : Benchmarking Methodology
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Lucien <[email-masked]>
Date: Wed, 1 Dec 2021 05:54:41 -0800

Iteration 1 and 2 are correct in the original text as well.

On Wed, Dec 1, 2021 at 00:37 Leonard Yu <[email-masked]> wrote:

> I was assuming the texts describing Iteration 1 & 2 were incorrect. But
> from the drawing below, I can see it is the text describing iteration 1 and
> 2 are incorrect.
>
>
>
> *From: *Lucien <[email-masked]>
> *Date: *Tuesday, 30 November 2021 at 20.56
> *To: *MORTON JR., AL <[email-masked]>
> *Cc: *Jacob Rapp <[email-masked]>, RFC Errata System <
> [email-masked]>, Sarah B <[email-masked]>, Warren Kumari
> <[email-masked]>, [email-masked] <[email-masked]>, Leonard Yu <
> [email-masked]>, [email-masked] <[email-masked]>
> *Subject: *Re: [Technical Errata Reported] RFC8239 (6763)
>
> On Tue, Nov 30, 2021 at 11:55 MORTON JR., AL <[email-masked]> wrote:
>
> *From:* Lucien <[email-masked]>
> *Sent:* Tuesday, November 30, 2021 2:29 PM
> *To:* RFC Errata System <[email-masked]>
> *Cc:* Jacob Rapp <[email-masked]>; Warren Kumari <[email-masked]>;
> [email-masked]; MORTON JR., AL <[email-masked]>; Sarah B <
> [email-masked]>; [email-masked]; [email-masked]
> *Subject:* Re: [Technical Errata Reported] RFC8239 (6763)
>
>
>
> Hello,
>
>
>
> On Tue, Nov 30, 2021 at 6:47 AM RFC Errata System <
> [email-masked]> wrote:
>
> https://www.rfc-editor.org/errata/eid6763
> <https://urldefense.com/v3/__https:/www.rfc-editor.org/errata/eid6763__;!!BhdT!wScd1KMc51KUWqw0VGpG0Koz6W11ctc3VWC0cf5ClMcedcAYPseHP0RwShhp$>
>
> Reported by: Leonard Yu <[email-masked]>
>
> Section: 3.2
>
> Original Text
> -------------

---

From: Lucien <[email-masked]>
Date: Wed, 1 Dec 2021 13:51:59 -0800

Hi Leonard,

This method depicts iteration to test a port pair. The example in the text
uses for example port pair 2 and 3. I did a drawing showing you a different
port-pair starting point (1 and 2) instead of (2 and 3). What is important
is to know what port-pair is selected and follow the methodology for that
test as described in the text.

I suggest engaging in an email conversation if there is further confusion.
I am happy to help explain any misunderstandings.

Thank you,

Lucien

On Wed, Dec 1, 2021 at 05:54 Lucien <[email-masked]> wrote:

>> [email-masked]>, Sarah B <[email-masked]>, Warren
>> Kumari <[email-masked]>, [email-masked] <[email-masked]>, Leonard Yu <

---

From: Leonard Yu <[email-masked]>
Date: Thu, 9 Dec 2021 13:08:17 +0000

Hi Lucien,

Sorry, I accidentally deleted the entire conversation.

I am still confused about the text. Please let me explain my confusion wrt 3) Measure maximum port pair buffer sizes.:

>From “Ingress port 1 sending line rate to egress port 2”, I know that port 1 and port 2 are a pair.
>From “ingress port 3 sending line rate to egress port 4”, I know that port 3 and port 4 are a pair.
(are my understanding above correct?) At least they are the same as your drawing below.

[Diagram  Description automatically generated]

Then, the text says ” Ingress port N-1 and port N will oversubscribe, at 1% of line
         rate, egress port 2 and port 3, respectively.”. Here, this is where my confusion is. In your drawing, the oversubscribed ports are port 1 and port 2, because they are a pair. But the text says, port 2 and port 3 to be oversubscribed. Port 2 and port 3 are from two different pairs, correct?

They cannot be both correct. Either the text, or the equation is correct.

Best,
Leonard

From: Lucien <[email-masked]>
Date: Wednesday, 1 December 2021 at 22.52
To: Leonard Yu <[email-masked]>
Cc: Jacob Rapp <[email-masked]>, MORTON JR., AL <[email-masked]>, RFC Errata System <[email-masked]>, Sarah B <[email-masked]>, Warren Kumari <[email-masked]>, [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
Subject: Re: [Technical Errata Reported] RFC8239 (6763)
Hi Leonard,

This method depicts iteration to test a port pair. The example in the text uses for example port pair 2 and 3. I did a drawing showing you a different port-pair starting point (1 and 2) instead of (2 and 3). What is important is to know what port-pair is selected and follow the methodology for that test as described in the text.

I suggest engaging in an email conversation if there is further confusion. I am happy to help explain any misunderstandings.

Thank you,

Lucien

On Wed, Dec 1, 2021 at 05:54 Lucien <[email-masked]<mailto:[email-masked]>> wrote:
Iteration 1 and 2 are correct in the original text as well.

On Wed, Dec 1, 2021 at 00:37 Leonard Yu <[email-masked]<mailto:[email-masked]>> wrote:
I was assuming the texts describing Iteration 1 & 2 were incorrect. But from the drawing below, I can see it is the text describing iteration 1 and 2 are incorrect.

From: Lucien <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, 30 November 2021 at 20.56
To: MORTON JR., AL <[email-masked]<mailto:[email-masked]>>
Cc: Jacob Rapp <[email-masked]<mailto:[email-masked]>>, RFC Errata System <[email-masked]<mailto:[email-masked]>>, Sarah B <[email-masked]<mailto:[email-masked]>>, Warren Kumari <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>, Leonard Yu <[email-masked]<mailto:[email-masked]>>, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Technical Errata Reported] RFC8239 (6763)
Here is a picture illustrating it, sorry my ascii skills for drawing are not there yet.

Hello,

Lucien

Section: 3.2

Original Text
-------------

Corrected Text
--------------

Notes
-----
If

Then

Instructions:
-------------