Subject: [bmwg] resending: Re: [iotdir] telechat Review for draft-ietf-bmwg-ngfw-performance-13

From: Toerless Eckert <[email-masked]>
Date: Sun, 30 Jan 2022 13:21:59 +0100

[resending, because [email-masked] is set up to not accept emails longer than 60kb,
 a first for me (have not seen this in other IETF WGs. So this time around i will
 try to add the review as an attachment.]

Reviewer: toerless eckert
Review result: On the right track

Summary:
Thanks a lot for this work. Its an immensibley complex and important problem to
tackle. I have in my time only measured router traffic performance and that already was an
infinite matrix. This looks to me like some order of infinite bigger a problem.

Meaning: however questioning my reviews feedback may be wrt. nitpicking about the document,
i think that the document in its existing form is already a great advancement to measure
performance for these security devices, and in doubt should be progressed rather faster than
slower especially because in my (limited) market understanding, many security device vendors will
only provide actual feedback once it is an RFC (community i think overall more conservative in
adopting IETF work, most not proactively engaging during draft stage).

But of course: feel free to improve the document with any of the feedback/suggestions
in my review that you feel are useful.

Maybe high level, i would suggest most importantly to add more explanations, especially in
an appropriate section about those aspects known NOT to be considered (but potentially
important) so that the applicability of the tests that are described are better put into
perspective by adopters of the draft to their real-world situations.

Favorite pet topic: Add req. to measure the DUT through a power meter and report consumption
so we can start making sure products with lower power consumptions will see sales benefits
when reporting numbers from this document (see details inline).

Formal:
I choose to keep the whole document inline to make it easier for readers to vet
my comments without having to open in parallel a copy of the whole document.

Rest see attachment 

Thanks!
    Toerless

---

From: "MORTON JR., AL" <[email-masked]>
Date: Sun, 30 Jan 2022 19:31:00 +0000

> -----Original Message-----
> From: Toerless Eckert <[email-masked]>
> Sent: Sunday, January 30, 2022 7:22 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked];
> [email-masked]; [email-masked]
> Subject: resending: Re: [iotdir] telechat Review for draft-ietf-bmwg-ngfw-
> performance-13
> 
[acm] 
I have raised the limit several times.
The limit continues to be exceeded, even with plain text messages...

Al

---

From: t petch <[email-masked]>
Date: Sun, 30 Jan 2022 21:09:41 +0000

>   try to add the review as an attachment.]

I have and think that it is an excellent idea, especially when it stops 
me getting .pdf of close to 1Mbyte and html which includes the MSO 
styleshift!

Tom Petch

> _______________________________________________
> bmwg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bmwg
>