Subject: [bmwg] A question about combining models in draft-dcn-bmwg-containerized-infra-08

From: Bill Fenner <[email-masked]>
Date: Wed, 23 Mar 2022 11:33:44 +0100

Hi,

In section 4.5.  Model Combination, we see a picture that uses a veth
connected to a vswitch for east/west traffic:

     +-------------------------------------------------------+
     | User Space                                            |
     | +--------------------+         +--------------------+ |
     | |        C-VNF       |         |        C-VNF       | |
     | | +------+  +------+ |         | +------+  +------+ | |
     | +-| veth |--| veth |-+         +-| veth |--| veth |-+ |
     |   +---^--+  +---^--+             +--^---+  +---^--+   |
     |       |         |                   |          |      |
     |       |         |                   |          |      |
     |       |     +---v--------+  +-------v----+     |      |
     |       |     | vhost-user |  | vhost-user |     |      |
     |       |  +--|  / memif   |--|  / memif   |--+  |      |
     |       |  |  +------------+  +------------+  |  |      |
     |       |  |             vSwitch              |  |      |
     |       |  +----------------------------------+  |      |
     |       |                                        |      |
     --------|----------------------------------------|-------

Have you considered orchestrating the containers to eliminate the vswitch,
by creating a single veth pair with one end in each container:

     +-------------------------------------------------------+
     | User Space                                            |
     | +--------------------+         +--------------------+ |
     | |        C-VNF       |         |        C-VNF       | |
     | | +------+  +------+ |         | +------+  +------+ | |
     | +-| veth |--| veth |-+         +-| veth |--| veth |-+ |
     |   +---^--+  +---^--+             +--^---+  +---^--+   |
     |       |         |                   |          |      |
     |       |         |                   |          |      |
     |       |          -------------------           |      |
     |       |                                        |      |
     --------|----------------------------------------|-------

Is it useful to eliminate (and/or measure) the overhead of the vswitch in
this case?

Thanks,
  Bill

---

From: Minh-Ngoc Tran <[email-masked]>
Date: Wed, 23 Mar 2022 19:40:47 +0900

Hi Bill,

Because we are currently considering different packet acceleration techniques (SRIOV,vPP,Ovs-DPDK or ebpf), the direct veth connection as you mentioned is not yet considered for now.

Considering the Model Combination scope, I think we should test  the scenario you mentioned test in our upcoming hackathon works

Thank for your suggestion

__________________________________

Minh-Ngoc Tran

Distributed Cloud and Network lab

Soongsil University

511 Sangdo-dong Dongjak-gu

Seoul, 156-743 Korea

TEL : (+82)-2-820-0841

From: Bill Fenner
Sent: Wednesday, March 23, 2022 7:34 PM
To: [email-masked]
Subject: [bmwg] A question about combining models in draft-dcn-bmwg-containerized-infra-08

Hi,

In section 4.5.  Model Combination, we see a picture that uses a veth connected to a vswitch for east/west traffic:

| User Space                                            |

| |        C-VNF       |         |        C-VNF       | |

|       |         |                   |          |      |

|       |         |                   |          |      |

|       |  |             vSwitch              |  |      |

|       |                                        |      |

Have you considered orchestrating the containers to eliminate the vswitch, by creating a single veth pair with one end in each container:

| User Space                                            |

| |        C-VNF       |         |        C-VNF       | |

|       |         |                   |          |      |

|       |         |                   |          |      |

|       |                                        |      |

Is it useful to eliminate (and/or measure) the overhead of the vswitch in this case?

Thanks,

Bill

---

From: Minh-Ngoc Tran <[email-masked]>
Date: Wed, 23 Mar 2022 19:52:45 +0900

Hi Bill,

Do you mean direct veth connection between 2 C-VNFs in the user-space? I think an user-space vswitch (VPP or OvS-DPDK) is need to establish that. We are currently not aware of any other techniques that can provide user-space connection between 2 C-VNFs other that using user-space vswitch

If we don’t use the user-space vswitch, then the traffic should go through kernel which is definitely worse than bypass-kernel techniques.

Maybe ebpf can act differently, we are going to test it in our future works

Thanks,

Minh-Ngoc Tran

Soongsil University

Seoul, 156-743 Korea

TEL : (+82)-2-820-0841

From: Minh-Ngoc Tran
Sent: Wednesday, March 23, 2022 7:40 PM
To: Bill Fenner; [email-masked]
Subject: RE: [bmwg] A question about combining models in draft-dcn-bmwg-containerized-infra-08

Hi Bill,

Minh-Ngoc Tran

Soongsil University

Seoul, 156-743 Korea

TEL : (+82)-2-820-0841

From: Bill Fenner

Hi,

| User Space                                            |

| |        C-VNF       |         |        C-VNF       | |

|       |         |                   |          |      |

|       |         |                   |          |      |

|       |  |             vSwitch              |  |      |

|       |                                        |      |

| User Space                                            |

| |        C-VNF       |         |        C-VNF       | |

|       |         |                   |          |      |

|       |         |                   |          |      |

|       |                                        |      |

Thanks,

Bill