Subject: RE: Latency and load

From: Jim McQuaid <[email-masked]>
Date: Tue, 24 Aug 1999 08:53:40 -0400

I love "trombone test."  New to my jargon file!

I think that the ideal is clearly a METHODOLOGY which can be scaled to any
number of input and output ports, starting with the simple case of one input
and one output.

I think that the RESULTS of such a methodology are highly likely to having
different meanings / interpretations depending on the number of ports and
some known or unknown characteristics of device architectures.

This is true for simple forwarding rate metrics and is certainly going to be
true for latency.  BTW what I liked about the trombone test - in this
context - is the idea of total latency of the path snaking in and out of the
device: possibly a multiplier effect which makes it easier to detect and
measure?  But I understand that the trombone configuration was not mentioned
directly in reference to latency testing.  Nevertheless, it has
possibilities!

Jim McQuaid
Ganymede Software

-----Original Message-----
From: Jeffrey Dunn [mailto:[email-masked]]
Sent: Monday, August 23, 1999 10:06 PM
To: David Newman
Cc: bmwg
Subject: Re: Latency and load

David,

I absolutely disagree.  In the case of devices such as ATM and FR
switches or routers, the number of cells/frames/packets per second per
port/interface and, more importantly, the number of forwarding
discussions per port/interface per second will significantly effect both
the latency and loss statistics.  In any device which bases forwarding
decisions on information in multi-level caches, the number of ports and
destinations per port involved in a test will drastically impact
performance both in latency and loss.

Jeff Dunn
Advanced Network Consultants

>David Newman wrote:
> 
> What Jim said.
> 
> The particular instances I mentioned always involved more than two
> ports, but I don't think that should be a requirement in determining a
> "correct" method of measurement. The methodology should work independent
> of the number of ports. Of course, the number of ports, offered load,
> and traffic orientation should be declared by the tester.
> 
> dn
> 
> > I think the current discussion is about what might be the ingredients of
> > "correct way" since there is no specific definition in 1944/2544 about
> > multiport devices.  Multiport devices probably have different latency
> > characteristics for different paths but that is a real rathole!!
> >
> > Jim McQuaid
> > Ganymede Software
> >
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]
> > Sent: Monday, August 23, 1999 1:31 PM
> > To: [email-masked]
> > Subject: Latency and load
> >
> >
> > I have another question regarding the Latency and Load issue.
> >
> > How many port pairs are you utilizing when running the latency test  ??

---

From: "mike winslow" <[email-masked]>
Date: Tue, 24 Aug 1999 09:26:48 -0400

We used to call it "looped PVC test" back when we did it in the '70ies on
X.25..

Trombone test: hmm.. back then, that would have had to have been an ACRONYM
ya know..

(A Concise Reduction Obliquely Naming Your Meaning)

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Jim McQuaid
Sent: Tuesday, August 24, 1999 8:54 AM
To: bmwg
Subject: RE: Latency and load

Jim McQuaid
Ganymede Software

-----Original Message-----
From: Jeffrey Dunn [mailto:[email-masked]]
Sent: Monday, August 23, 1999 10:06 PM
To: David Newman
Cc: bmwg
Subject: Re: Latency and load

David,

Jeff Dunn

---

From: "Robert Mandeville" <[email-masked]>
Date: Tue, 24 Aug 1999 11:41:19 +0200

We used tromboning in the first ATM test Data Comm published.I got the term
from a Swiss lab working on a Eureka research grant at the time. Tromboning
is pretty much useless when i comes to measuring latency. It is just a cheap
way of loading all the ports of a DUT using just a single port traffic
generator/receiver. It is very sensitive to clock drift. The only
requirement is that the DUT interfaces are full duplex. ATM made an ideal
candidate at the time.
Bob

[email-masked]
usa +1-949-400-44-44
europe +33 (0)6 07 47 67 10

----- Original Message -----
From: mike winslow <[email-masked]>
To: 'Jim McQuaid' <[email-masked]>; 'bmwg'
<[email-masked]>
Sent: Tuesday, August 24, 1999 3:26 PM
Subject: RE: Latency and load

---

From: Steve Bell <[email-masked]>
Date: Tue, 24 Aug 1999 15:25:01 -0700

Bob,
Exactly, typically we see it being used as a cheap/dirty production test
technique
around firms in Silicon Valley.  A lot of times they will program their own
product to
generate/receive the traffic, then "trombone" it through the DUT.  Haven't
found too many
useful applications for it in our test lab, although you could probably show
us some :)
Regards,  -Steve Bell/SVNL

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Robert Mandeville
Sent: Tuesday, August 24, 1999 2:41 AM
To: 'Jim McQuaid'; 'bmwg'
Cc: [email-masked]
Subject: Re: Latency and load

[email-masked]
usa +1-949-400-44-44