Subject: [Bnbsg] Participate in IETF 90 Bits-N-Bites: Internet of Things (IoT)

From: Alexa Morris <[email-masked]>
Date: Mon, 19 May 2014 22:03:52 -0700

Hi Everyone,

Finally getting this out to all of you. I would like to send an email to the relevant working group lists tomorrow (Tuesday). The below is essentially the language we have on the website, which was taken from the text prepared by Alex and Pascal. Please send me any comments at your earliest convenience. Question: I’m not sure what the sentence at the end means when it says, “Things deployed on a table, relying on local connections and alternatively exhibiting remote access across the Internet”  — does that mean that it will use the local IETF network but also potentially access devices or things that are external to the IETF network? If so, could we rephrase it to say, "Things deployed on a table, connecting via the local IETF network in Toronto and/or demonstrating remote access across the Internet.”  Or is the sentence clear enough as is and perhaps it’s just my own lack of understanding that is the issue :-)

Also, is this the complete list of WG lists that we should send the email to: 

- 6lo WG
- 6tisch WG
- RoLL WG
- lwig WG
- ACE BoF
- Core WG

+++++++

Bits-N-Bites at IETF 90 in Toronto will focus on the Internet of Things, and the IETF invites you and your organization to participate!

The arrival of Things connected to the Internet in recent years has given life to new applications in both the consumer and industrial market segments. We are surrounded by products that utilize connectivity and a growing enthusiasm suggests imminent and impressive deployments: billions of new connected devices are expected by year 2020.  In the industrial world, wide spread wireless sensoring devices that collect data and measurements will move us into the next phase of process optimization. This will require the combination of the best of Information Technology (IT) and Operational Technology (OT), forming the IT/OT convergence.

When deploying multi-stage Thing topologies, two trends compete: IP protocols are enhanced and transformed into less end-to-end protocols (address translation, header compression, 'mesh under' routing and more) and, alternatively, existing IP protocols are reduced to their bare minimum such as to fit in reduced Things (reduced CPU frequency and number of transistors, dimensions and energy consumption).

IETF 90 demonstrations should exhibit recent developments of IP protocols for IoT networks (6lowpan adaptation layers, MANET and RPL routing protocols, 6tsch time-constrained communications, CoAP app-layer protocols) as well as demonstrations of the tendency of bringing the known IPv6 as close as possible to the Thing - minimum set of unmodified IPv6, Neighbor Discovery, DHCP, HTTP, IKEv2.

Does your organization want to reach 1,200 Internet engineers and demonstrate your IoT technologies and usage of IETF protocols? This is your opportunity to show leading industry professionals the latest and greatest of what you do in a social and interactive setting.

Examples of demos include, but are not limited, to:

• home automation controller using SNMP for HVAC and ambient temperature, electricity counter;
• industrial-grade Wireless Sensor Network products;
• scalable wireless designs and existing deployments;
• IPv6 end-to-end and backbone interconnection;
• tablet summarizing status of widespread devices through heterogeneous link connections;
• smart belt collecting body information with low-energy communication protocols;
• vehicle interior connected designs, vehicle-to-road sensor-based communications;
• sensor-assisted autonomous mobile Things (mono-, bi-, quad- wheeled or propelled devices).

There many ways to configure your demo, such as: 

• Things deployed on a table, relying on local connections and alternatively exhibiting remote access across the Internet;
• a poster describing a demo;
• video sequence showing a lab demonstration.

For information about IETF 90 Bits-N-Bites, please see http://www.ietf.org/meeting/90/90-bits-n-bites.html or send email to [email-masked].

Regards,
Alexa

----------
Alexa Morris / Executive Director / IETF
48377 Fremont Blvd., Suite 117, Fremont, CA  94538
Phone: +1.510.492.4089 / Fax: +1.510.492.4001
Email: [email-masked]

Managed by Association Management Solutions (AMS)
Forum Management, Meeting and Event Planning
www.amsl.com <http://www.amsl.com/>

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 20 May 2014 11:31:08 +0200

Hi Alexa,

Makes sense to me.  Please see below some comments.

Le 20/05/2014 07:03, Alexa Morris a écrit :
> Hi Everyone,
>
> Finally getting this out to all of you. I would like to send an
> email to the relevant working group lists tomorrow (Tuesday). The
> below is essentially the language we have on the website, which was
> taken from the text prepared by Alex and Pascal. Please send me any
> comments at your earliest convenience.

Below.

> Question: I’m not sure what the sentence at the end means when it
> says, “Things deployed on a table, relying on local connections and
> alternatively exhibiting remote access across the Internet”  — does
> that mean that it will use the local IETF network but also
> potentially access devices or things that are external to the IETF
> network?

Yes, that could be the case.  A demo on-table in Toronto may access
sensor devices across the Internet located in other country.

> If so, could we rephrase it to say, "Things deployed on a table,
> connecting via the local IETF network in Toronto and/or
> demonstrating remote access across the Internet.”

Yes, that reads better.

> Or is the sentence clear enough as is and perhaps it’s just my own
> lack of understanding that is the issue :-)
>
> - 6lo WG - 6tisch WG - RoLL WG - lwig WG - ACE BoF - Core WG

In the illustration at
http://www.ietf.org/meeting/90/90-bits-n-bites.html
I noticed a position marker up in the picture.  I think that is very 
relevant.

Maybe the call for demos could be enhanced with a geographical 
networking aspect.  Maybe just a few words here and there.

I would suggest adding [email-masked] (the GeoNet BoF) since it focuses on 
geonet and has a side use-case for vehicular communications.  And also 
[email-masked] (the GeoPriv WG).

This covers people with geo-location experience who may be interested in 
demoing IoT geo-localization aspects.  Because typically geo-enabled 
devices are small and thus Things (e.g. GPS receiver), important in 
vehicular communications (geonet/its topic: dead-reckoning enhancements 
for enhanced GPS localization, geo-dissemination), service applications 
on smartphones (geopriv WG topics: google "geofeeds", 
IP-to-LatLong-to-CivicAddress resolution mechanisms).

Alex

>
> +++++++
>
> Bits-N-Bites at IETF 90 in Toronto will focus on the Internet of
> Things, and the IETF invites you and your organization to
> participate!
>
> The arrival of Things connected to the Internet in recent years has
> given life to new applications in both the consumer and industrial
> market segments. We are surrounded by products that utilize
> connectivity and a growing enthusiasm suggests imminent and
> impressive deployments: billions of new connected devices are
> expected by year 2020.  In the industrial world, wide spread
> wireless sensoring devices that collect data and measurements will
> move us into the next phase of process optimization. This will
> require the combination of the best of Information Technology (IT)
> and Operational Technology (OT), forming the IT/OT convergence.
>
> When deploying multi-stage Thing topologies, two trends compete: IP
> protocols are enhanced and transformed into less end-to-end
> protocols (address translation, header compression, 'mesh under'
> routing and more) and, alternatively, existing IP protocols are
> reduced to their bare minimum such as to fit in reduced Things
> (reduced CPU frequency and number of transistors, dimensions and
> energy consumption).
>
> IETF 90 demonstrations should exhibit recent developments of IP
> protocols for IoT networks (6lowpan adaptation layers, MANET and RPL
> routing protocols, 6tsch time-constrained communications, CoAP
> app-layer protocols) as well as demonstrations of the tendency of
> bringing the known IPv6 as close as possible to the Thing - minimum
> set of unmodified IPv6, Neighbor Discovery, DHCP, HTTP, IKEv2.
>
> Does your organization want to reach 1,200 Internet engineers and
> demonstrate your IoT technologies and usage of IETF protocols? This
> is your opportunity to show leading industry professionals the
> latest and greatest of what you do in a social and interactive
> setting.
>
> • home automation controller using SNMP for HVAC and ambient
> temperature, electricity counter; • industrial-grade Wireless Sensor
> Network products; • scalable wireless designs and existing
> deployments; • IPv6 end-to-end and backbone interconnection; •
> tablet summarizing status of widespread devices through heterogeneous
> link connections; • smart belt collecting body information with
> low-energy communication protocols; • vehicle interior connected
> designs, vehicle-to-road sensor-based communications; •
> sensor-assisted autonomous mobile Things (mono-, bi-, quad- wheeled
> or propelled devices).
>
> • Things deployed on a table, relying on local connections and
> alternatively exhibiting remote access across the Internet; • a
> poster describing a demo; • video sequence showing a lab
> demonstration.
>
> For information about IETF 90 Bits-N-Bites, please see
> http://www.ietf.org/meeting/90/90-bits-n-bites.html or send email to
> [email-masked].
>
> Regards, Alexa
>
>
> ---------- Alexa Morris / Executive Director / IETF 48377 Fremont
> Blvd., Suite 117, Fremont, CA  94538 Phone: +1.510.492.4089 / Fax:
> +1.510.492.4001 Email: [email-masked]
>
> Managed by Association Management Solutions (AMS) Forum Management,
> Meeting and Event Planning www.amsl.com <http://www.amsl.com/>
>
> _______________________________________________ Bnbsg mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/bnbsg
>

---

From: Alexa Morris <[email-masked]>
Date: Tue, 20 May 2014 06:47:54 -0700

Alex,

Thanks so much for your feedback! I modified the email below to include some small geo-networking reference. Basically in the paragraph about IETF 90 demonstrations I added, "Demonstrations on geo-networking and the surrounding privacy issues are also welcome.” and then I included your suggested demo topics in the list of demo examples that are bulleted. See below for proposed email:

+++++++

IETF 90 demonstrations should exhibit recent developments of IP protocols for IoT networks (6lowpan adaptation layers, MANET and RPL routing protocols, 6tsch time-constrained communications, CoAP app-layer protocols) as well as demonstrations of the tendency of bringing the known IPv6 as close as possible to the Thing - minimum set of unmodified IPv6, Neighbor Discovery, DHCP, HTTP, IKEv2. Demonstrations on geo-networking and the surrounding privacy issues are also welcome.  

• home automation controller using SNMP for HVAC and ambient temperature, electricity counter;
• industrial-grade Wireless Sensor Network products;
• scalable wireless designs and existing deployments;
• IPv6 end-to-end and backbone interconnection;
• tablet summarizing status of widespread devices through heterogeneous link connections;
• smart belt collecting body information with low-energy communication protocols;
• vehicle interior connected designs, vehicle-to-road sensor-based communications;
• sensor-assisted autonomous mobile Things (mono-, bi-, quad- wheeled or propelled devices);
• vehicular communications (e.g. dead-reckoning enhancements for enhanced GPS localization, geo-dissemination);
• service applications on smartphones (google "geofeeds", IP-to-LatLong-to-CivicAddress resolution mechanisms).

Regards,
Alexa

On May 20, 2014, at 2:31 AM, Alexandru Petrescu <[email-masked]> wrote:

> I noticed a position marker up in the picture.  I think that is very relevant.
> 
> Maybe the call for demos could be enhanced with a geographical networking aspect.  Maybe just a few words here and there.
> 
> I would suggest adding [email-masked] (the GeoNet BoF) since it focuses on geonet and has a side use-case for vehicular communications.  And also [email-masked] (the GeoPriv WG).
> 
> This covers people with geo-location experience who may be interested in demoing IoT geo-localization aspects.  Because typically geo-enabled devices are small and thus Things (e.g. GPS receiver), important in vehicular communications (geonet/its topic: dead-reckoning enhancements for enhanced GPS localization, geo-dissemination), service applications on smartphones (geopriv WG topics: google "geofeeds", IP-to-LatLong-to-CivicAddress resolution mechanisms).
> 
> Alex
> 
>> 
>> +++++++
>> 
> [email-masked]
> https://www.ietf.org/mailman/listinfo/bnbsg
> 

----------

---

From: Alexandru Petrescu <[email-masked]>
Date: Tue, 20 May 2014 16:03:41 +0200

Hi Alexa,

Thanks for the new version, makes sense.

While reading it I think it could be improved, as suggested below.

Le 20/05/2014 15:47, Alexa Morris a écrit :
[...]

> Demonstrations on geo-networking and the surrounding privacy issues
> are also welcome.

Demonstrations of geo-location uses in and for IP networking and the
surrounding privacy issues are also welcome.

> Examples of demos include, but are not limited, to:

[...]
> • service applications on smartphones (google "geofeeds",

Smartphone applications relying on geo-localization (...).

Alex

>>> below is essentially the language we have on the website, which
>>> was taken from the text prepared by Alex and Pascal. Please send
>>> me any comments at your earliest convenience.
>>
>> Below.
>>
>>
>>> says, “Things deployed on a table, relying on local connections
>>> and alternatively exhibiting remote access across the Internet”
>>> — does that mean that it will use the local IETF network but also
>>> potentially access devices or things that are external to the
>>> IETF network?
>>
>>> Or is the sentence clear enough as is and perhaps it’s just my
>>> own lack of understanding that is the issue :-)
>>>
>> http://www.ietf.org/meeting/90/90-bits-n-bites.html I noticed a
>> position marker up in the picture.  I think that is very relevant.
>>
>> I would suggest adding [email-masked] (the GeoNet BoF) since it
>> focuses on geonet and has a side use-case for vehicular
>> communications.  And also [email-masked] (the GeoPriv WG).
>>
>> This covers people with geo-location experience who may be
>> interested in demoing IoT geo-localization aspects.  Because
>> typically geo-enabled devices are small and thus Things (e.g. GPS
>> receiver), important in vehicular communications (geonet/its
>> topic: dead-reckoning enhancements for enhanced GPS localization,
>> geo-dissemination), service applications on smartphones (geopriv
>> WG topics: google "geofeeds", IP-to-LatLong-to-CivicAddress
>> resolution mechanisms).
>>
>> Alex
>>
>>>
>>> +++++++
>>>
>>> The arrival of Things connected to the Internet in recent years
>>> has given life to new applications in both the consumer and
>>> industrial market segments. We are surrounded by products that
>>> utilize connectivity and a growing enthusiasm suggests imminent
>>> and impressive deployments: billions of new connected devices are
>>> wireless sensoring devices that collect data and measurements
>>> will move us into the next phase of process optimization. This
>>> will require the combination of the best of Information
>>> Technology (IT) and Operational Technology (OT), forming the
>>> IT/OT convergence.
>>>
>>> When deploying multi-stage Thing topologies, two trends compete:
>>> IP protocols are enhanced and transformed into less end-to-end
>>> protocols for IoT networks (6lowpan adaptation layers, MANET and
>>> RPL routing protocols, 6tsch time-constrained communications,
>>> CoAP app-layer protocols) as well as demonstrations of the
>>> tendency of bringing the known IPv6 as close as possible to the
>>> Thing - minimum set of unmodified IPv6, Neighbor Discovery,
>>> DHCP, HTTP, IKEv2.
>>>
>>> demonstrate your IoT technologies and usage of IETF protocols?
>>> This is your opportunity to show leading industry professionals
>>> the latest and greatest of what you do in a social and
>>> interactive setting.
>>>
>>> temperature, electricity counter; • industrial-grade Wireless
>>> Sensor Network products; • scalable wireless designs and existing
>>> tablet summarizing status of widespread devices through
>>> heterogeneous link connections; • smart belt collecting body
>>> information with low-energy communication protocols; • vehicle
>>> interior connected designs, vehicle-to-road sensor-based
>>> communications; • sensor-assisted autonomous mobile Things
>>> (mono-, bi-, quad- wheeled or propelled devices).
>>>
>>> http://www.ietf.org/meeting/90/90-bits-n-bites.html or send
>>> email to [email-masked].
>>>
>>> Regards, Alexa
>>>
>>>
>>> Blvd., Suite 117, Fremont, CA  94538 Phone: +1.510.492.4089 /
>>> Fax: +1.510.492.4001 Email: [email-masked]
>>>
>>> Managed by Association Management Solutions (AMS) Forum
>>> Management, Meeting and Event Planning www.amsl.com
>>> <http://www.amsl.com/>
>>>
>>> _______________________________________________ Bnbsg mailing
>>> list [email-masked] https://www.ietf.org/mailman/listinfo/bnbsg
>>>
>>
>>

---

From: Alexa Morris <[email-masked]>
Date: Tue, 20 May 2014 07:38:12 -0700

Much better, thank you! I will incorporate those right away.

Alexa

----------

---

From: Alexa Morris <[email-masked]>
Date: Tue, 20 May 2014 16:36:26 -0700

Everyone,

Unless I hear differently, I will plan to send the revised text out to the relevant wg lists either very late tonight PT or very early tomorrow, Weds. So, if you have further comments, please send them by 8pm PT today.

Thanks!
Alexa

----------