Subject: FW: [Bridge-mib] Outstanding RSTP-MIB issues

From: Rohit Rohit <[email-masked]>
Date: Tue, 13 Nov 2001 14:46:18 -0800

Hi Less, 

  I didn't get the reply for this mail earlier.
  Trying it again.

  Thanks
  Rohit

-----Original Message-----
From: Rohit Rohit 
Sent: Tuesday, October 09, 2001 9:33 AM
To: 'Les Bell'; [email-masked]
Subject: RE: [Bridge-mib] Outstanding RSTP-MIB issues

Hi, 

  I am not sure whether the presentation discussed the dot1dStpHoldTime
  issue for RSTP or not.
  We have holdCount for the rstp and which is not same as dot1dStpHoldTime
  for stp.
  So are we going to have a new object for the rstpHoldCount ?
  If yes, then what should be the value of dot1dStpHoldTime for the
  rstp bridges.

  Thanks
  Rohit

-----Original Message-----
From: Les Bell [mailto:[email-masked]]
Sent: Tuesday, October 09, 2001 6:29 AM
To: [email-masked]
Subject: [Bridge-mib] Outstanding RSTP-MIB issues

Here is a summary of the outstanding issues on the RSTP-MIB,
U-BRIDGE-MIB and V-BRIDGE-MIB in draft-ietf-bridge-rstpmib-00.txt

I would like to solicit more input from people to try and close these
issues and get an updated draft out before the December IETF.

(1) Some missing items were identified (see the presentation).
    STATUS: Should add these to the new draft mib.
    COMMENTS: No comments from the mailing list.
    PROPOSED ACTION: Add the missing items.

(2) The U-BRIDGE-MIB and V-BRIDGE-MIB should probably be done as
    updates to RFC 2674.
    STATUS: No feedback received yet.
    COMMENTS: No comments from the mailing list.
    PROPOSED ACTION: Requires further input from the mailing list.

Les...

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

---

From: "Les Bell" <[email-masked]>
Date: Tue, 13 Nov 2001 23:31:00 +0000

Sorry, I forgot to respond to this email previously.

The TxHoldCount is not configurable according to 802.1w, so I did not think it
was necessary to include it in the MIB.  Table 8-3 and Table 17-5 of 802.1w do
not indicate a valid range for the TxHoldCount value, just defining the default
value of 3.  802.1w 14.8.1.2 Set Bridge Protocol parameters does not include
TxHoldCount in the list of input parameters.

I shall raise this issue on the IEEE 802.1 WG email list, to see if we can get
their views on whether this was the intention, or if TxHoldCount should really
be configurable.

Les...

Rohit Rohit <[email-masked]> on 13/11/2001 22:46:18

Sent by:  Rohit Rohit <[email-masked]>

To:   "'Les Bell'" <[email-masked]>, [email-masked]
cc:   [email-masked], [email-masked], [email-masked]
Subject:  FW: [Bridge-mib] Outstanding RSTP-MIB issues

Hi Less,

  Thanks
  Rohit

-----Original Message-----
From: Rohit Rohit
Sent: Tuesday, October 09, 2001 9:33 AM
To: 'Les Bell'; [email-masked]
Subject: RE: [Bridge-mib] Outstanding RSTP-MIB issues

Hi,

  Thanks
  Rohit

-----Original Message-----
From: Les Bell [mailto:[email-masked]]
Sent: Tuesday, October 09, 2001 6:29 AM
To: [email-masked]
Subject: [Bridge-mib] Outstanding RSTP-MIB issues

Les...

---

From: "Les Bell" <[email-masked]>
Date: Wed, 14 Nov 2001 23:45:47 +0000

This was discussed at the IEEE 802.1 WG meeting today.  It was agreed that the
TxHoldCount value should be configurable, with a range of 1 - 10.  This
correction will be added to IEEE 802.1y, the maintenance document for IEEE
802.1D/w issues.

Therefore, we should add this as a new item to the RSTP MIB.

Les...

__________________________________

Les...

Hi Less,

  Thanks
  Rohit

-----Original Message-----
From: Rohit Rohit
Sent: Tuesday, October 09, 2001 9:33 AM
To: 'Les Bell'; [email-masked]
Subject: RE: [Bridge-mib] Outstanding RSTP-MIB issues

Hi,

  Thanks
  Rohit

-----Original Message-----
From: Les Bell [mailto:[email-masked]]
Sent: Tuesday, October 09, 2001 6:29 AM
To: [email-masked]
Subject: [Bridge-mib] Outstanding RSTP-MIB issues

Les...

---

From: Rohit Rohit <[email-masked]>
Date: Thu, 15 Nov 2001 09:48:25 -0800

Hi Les, 

  Thanks for your reply.
  IMHO we have two options

  1) add the new object and say that dot1dStpHoldTime  doesn't make
     sense for the RSTP.

  2) For RSTP dot1dStpHoldTime should be treated as TxHoldCount with a 
     different range.

  I prefer to go with the second option.

  Thanks
  Rohit

-----Original Message-----
From: Les Bell [mailto:[email-masked]]
Sent: Wednesday, November 14, 2001 3:46 PM
To: Rohit Rohit
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: FW: [Bridge-mib] Outstanding RSTP-MIB issues

This was discussed at the IEEE 802.1 WG meeting today.  It was agreed that
the
TxHoldCount value should be configurable, with a range of 1 - 10.  This
correction will be added to IEEE 802.1y, the maintenance document for IEEE
802.1D/w issues.

Les...

The TxHoldCount is not configurable according to 802.1w, so I did not think
it
was necessary to include it in the MIB.  Table 8-3 and Table 17-5 of 802.1w
do
not indicate a valid range for the TxHoldCount value, just defining the
default
value of 3.  802.1w 14.8.1.2 Set Bridge Protocol parameters does not include
TxHoldCount in the list of input parameters.

I shall raise this issue on the IEEE 802.1 WG email list, to see if we can
get
their views on whether this was the intention, or if TxHoldCount should
really
be configurable.

Les...

Hi Less,

  Thanks
  Rohit

-----Original Message-----
From: Rohit Rohit
Sent: Tuesday, October 09, 2001 9:33 AM
To: 'Les Bell'; [email-masked]
Subject: RE: [Bridge-mib] Outstanding RSTP-MIB issues

Hi,

  Thanks
  Rohit

-----Original Message-----
From: Les Bell [mailto:[email-masked]]
Sent: Tuesday, October 09, 2001 6:29 AM
To: [email-masked]
Subject: [Bridge-mib] Outstanding RSTP-MIB issues

Les...

---

From: "Les Bell" <[email-masked]>
Date: Tue, 13 Nov 2001 23:31:00 +0000

Les...

Hi Less,

  Thanks
  Rohit

-----Original Message-----
From: Rohit Rohit
Sent: Tuesday, October 09, 2001 9:33 AM
To: 'Les Bell'; [email-masked]
Subject: RE: [Bridge-mib] Outstanding RSTP-MIB issues

Hi,

  Thanks
  Rohit

-----Original Message-----
From: Les Bell [mailto:[email-masked]]
Sent: Tuesday, October 09, 2001 6:29 AM
To: [email-masked]
Subject: [Bridge-mib] Outstanding RSTP-MIB issues

Les...