Subject: [Bridge-mib] dot1dStpTopChanges

From: "Buia, Christopher" <[email-masked]>
Date: Thu, 13 Dec 2001 13:11:28 -0500

Hello Bridge-MIB WG,

I have a relatively simple question.  If someone could answer it, it would be appreciated.

What exactly constitutes a "topology change" such that the dot1dStpTopChanges object would be updated?  A list of examples would be wonderful.  The reason I ask is this...

Given the following layer 2 topology:

Router
   |
   |
   |
   |
Bridge A ---------- Bridge B
   |
   |
   |
   |
   |
Bridge C ---------- Bridge D
                            |
                            |
                            |
                            |
                            |
                         Bridge E

The root bridge is Bridge B, and there are no other connections between the bridges.  When the link between Bridge A and Bridge C goes down, the dot1dStpTopChanges object is incremented on the root bridge B.  However, when the same link comes back up, the dot1dStpTopChanges on the root bridge is not incremented again.

Basically, I'm asking if the dot1dStpTopChanges object on the root bridge can be relied upon to accurately determine when a spanning tree topology change had occurred (i.e. a link between two bridges has gone up or down).

Many thanks in advance.

Chris

Christopher A. Buia
Senior Software Engineer
SPECTRUM Core Services
Aprisma Management Technologies
603-334-2928
www.aprisma.com

_______________________________________________
Bridge-mib mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/bridge-mib

---

From: Michael MacFaden <[email-masked]>
Date: Thu, 13 Dec 2001 15:18:38 -0800

On Thu, Dec 13, 2001 at 01:11:28PM -0500, Buia, Christopher wrote:
>What exactly constitutes a "topology change" such that the dot1dStpTopChanges 
>object would be updated?  

In general some bridge configuration changes or a link-state change for
a link that has not disabled Change Detection (8.5.5.10), per 802.1D 
spec page 63.

    dot1dStpTopChanges OBJECT-TYPE
        SYNTAX      Counter32
        MAX-ACCESS  read-only
        STATUS      current
        DESCRIPTION
            "The total number of topology changes detected by
            this bridge since the management entity was last
            reset or initialized."
        REFERENCE
            "IEEE 802.1D-1990: Section 6.8.1.1.3"
        ::= { dot1dStp 4 }

Unfortunately the REFERENCE clause has not been fixed in the
new draft to point to the spec at  www.ieee.org 
file name named 802.1D-1998.pdf.
I found section 8.3 a good starting place. Esp Sec 8.3.5:

  The Spanning Tree Algorithm and Protocol provide procedures for a Bridge that 
  detects a change in active topology to notify the Root of the change reliably, 
  and for the Root subsequently to communicate the change
  to all the Bridges. The Bridges then use a short value to age out dynamic 
  entries in the Fitering Database for period.

>[snip]can be relied upon to accurately determine when a spanning tree topology 
>change had occurred (i.e. a link between two bridges has gone up or down).

I don't think you can do that. Rapid Spanning Tree protocol 
won't send a TCN from a non-root bridge to the root bridge 
when a link is removed.

Regards,
Mike MacFaden