Subject: RE: [Bridge-mib] I-D ACTION:draft-ietf-bridge-rstpmib-02.txt

From: "Ngai, Vivian" <[email-masked]>
Date: Tue, 26 Mar 2002 10:50:16 -0500

Alex,

I see the the extra variable as redundant...or maybe I just don't understand
what you mean...

It seems to me that if both the "admin" and the "oper" version of the
variables will be set to the same value at the same time.  So why an extra
variable?  From what I understand, the other parameters have both versions
defined only because the actual operational value changes according to the
environment, i.e. according to the values received/determined from the
BPDUs.  The "admin" version, therefore, stores the desired local value and
the "oper" version stores the actual value used in the network.

I guess we can define the "admin" version just like you say, but I don't
understand how the operational value can be changed automatically.  I'm not
aware of any PDUs that would force you to use a 16-bit or a 32-bit port
cost.  So if you believe we need this, can you propose an algorithm/state
machine for choosing the right value?

Regards,
Vivian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Tuesday, March 26, 2002 6:31 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: [Bridge-mib] I-D ACTION:draft-ietf-bridge-rstpmib-02.txt
> 
> 
> Hi,
> I would like to remind my conversation with Les (see below).
> I don't see this problem solved in the draft.
> Do you want to comment this issue?
> Yours truly, Alex 
> 
> On Thu, 28 Feb 2002 10:28:41 +0200 I replied (asked):
> Alex>Les,
> Alex>We would like to define "auto selection" for 
> PortPathCost. I mean, 
> Alex>for example, if dot1dStpAdminPortPathCost32 is set to "0", the 
> Alex>agent could select dot1dStpOperPortPathCost32 automatically, 
> Alex>corresponding to table 17-7 in 17.28.2 of 802.1s. When 
> Alex>dot1dStpAdminPortPathCost32 is set to positive value, 
> agent could 
> Alex>use this value for dot1dStpOperPortPathCost32. I don't see any 
> Alex>other solution to force the agent to use table 17.7. May be I 
> Alex>missed something?
> Alex>
> Alex>Thank you for your interest in my remarks, Alex
> 
> On Thursday, February 28, 2002 9:56 AM Les Bell asked
> Les> Alex> I expected to see here the objects 
> Les> Alex> dot1dStpAdminPortPathCost32 and dot1dStpOperPortPathCost32 
> Les> Alex> instead of a single dot1dStpPortPathCost32. What about it ?
> Les> Alex,
> Les> Can you explain why we need an Admin and Operational version
> Les> of PathCost, please?
> Les> Under what circumstances could these values differ?
> Les> Les...
> 
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]On
> > Behalf Of [email-masked]
> > Sent: Tuesday, March 26, 2002 2:20 PM
> > To: IETF-Announce:
> > Cc: [email-masked]
> > Subject: [Bridge-mib] I-D ACTION:draft-ietf-bridge-rstpmib-02.txt
> > 
> > 
> > A New Internet-Draft is available from the on-line 
> > Internet-Drafts directories.
> > This draft is a work item of the Bridge MIB Working Group 
> of the IETF.
> > 
> > 	Title		: Definitions of Managed Objects for 
> > Bridges with Rapid 
> >                           Spanning Tree Protocol
> > 	Author(s)	: E. Bell, V. Ngai
> > 	Filename	: draft-ietf-bridge-rstpmib-02.txt
> > 	Pages		: 17
> > 	Date		: 25-Mar-02
> > 	
> > This memo defines a portion of the Management Information Base (MIB)
> > for use with network management protocols in TCP/IP based internets.
> > In particular, it defines a MIB module for managing the Rapid
> > Spanning Tree capability defined by the IEEE P802.1t [802.1t] and
> > P802.1w [802.1w] amendments to IEEE Std 802.1D-1998 for bridging
> > between Local Area Network (LAN) segments.
> > 
> > A URL for this Internet-Draft is:
> > http://www.ietf.org/internet-drafts/draft-ietf-bridge-rstpmib-02.txt
> > 
> > To remove yourself from the IETF Announcement list, send a 
> message to 
> > ietf-announce-request with the word unsubscribe in the body 
> > of the message.
> > 
> > Internet-Drafts are also available by anonymous FTP. Login 
> > with the username
> > "anonymous" and a password of your e-mail address. After logging in,
> > type "cd internet-drafts" and then
> > 	"get draft-ietf-bridge-rstpmib-02.txt".
> > 
> > A list of Internet-Drafts directories can be found in
> > http://www.ietf.org/shadow.html 
> > or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> > 
> > 
> > Internet-Drafts can also be obtained by e-mail.
> > 
> > Send a message to:
> > 	[email-masked].
> > In the body type:
> > 	"FILE /internet-drafts/draft-ietf-bridge-rstpmib-02.txt".
> > 	
> > NOTE:	The mail server at ietf.org can return the document in
> > 	MIME-encoded form by using the "mpack" utility.  To use this
> > 	feature, insert the command "ENCODING mime" before the "FILE"
> > 	command.  To decode the response(s), you will need "munpack" or
> > 	a MIME-compliant mail reader.  Different MIME-compliant 
> > mail readers
> > 	exhibit different behavior, especially when dealing with
> > 	"multipart" MIME messages (i.e. documents which have been split
> > 	up into multiple messages), so check your local documentation on
> > 	how to manipulate these messages.
> > 		
> > 		
> > Below is the data which will enable a MIME compliant mail reader
> > implementation to automatically retrieve the ASCII version of the
> > Internet-Draft.
> > 
> 
> _______________________________________________
> Bridge-mib mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/bridge-mib
>

---

From: [email-masked] (Alex Ruzin)
Date: Sun, 31 Mar 2002 08:42:46 +0200

RE: [Bridge-mib] I-D ACTION:draft-ietf-bridge-rstpmib-02.txtVivian,
The usage of the "admin" and the "oper" version of the variables in general
is not a purpose of my proposition.
What I meant was: in the current MIB there is no any possibility to say to
an agent, that it (agent) has to use the table 8-5 (.1t) or 17.7 (.1w)
instead of explicit value.
Proposing method allows in "admin" version of the variable or to set
explicit value or to
force an agent to use the table. In the second case we may read from
"oper" version the selected value.
Another solution I see: to allow the variable dot1dStpPortPathCost  to have
a value 0 as a flag for speed based selection. But this method does not
allow us
to know a selected value.
What do you think about this problem and these solutions?
Do you see an another solution?
Yours sincerely, Alex

  -----Original Message-----
  From: Ngai, Vivian [mailto:[email-masked]]
  Sent: Tuesday, March 26, 2002 5:50 PM
  To: [email-masked]'
  Cc: [email-masked]
  Subject: RE: [Bridge-mib] I-D ACTION:draft-ietf-bridge-rstpmib-02.txt

  Alex,

  I see the the extra variable as redundant...or maybe I just don't
understand what you mean...

  Regards,
  Vivian