Subject: [Cacao] Updated Charter Text

From: Bret Jordan <[email-masked]>
Date: Thu, 20 Jun 2019 17:36:37 +0200

All,

We believe we have addressed all comments on the charter.  Please see the attached new charter text.

Thanks,
Bret
PGP Fingerprint: 63B4 FC53 680A 6B7D 1447  F2C0 74F8 ACAE 7415 0050
"Without cryptography vihv vivc ce xhrnrw, however, the only thing that can not be unscrambled is an egg."

---

From: <[email-masked]>
Date: Fri, 21 Jun 2019 06:23:10 +0000

Bret,

Thank you for addressing some of my comments.

Nevertheless, the following ones are still pending from where I sit:

* The issue about data models vs. application encoding
- Application encoding is part of this item "CACAO Protocol Specification", not data modeling
- s/CACAO JSON Data Model/CACAO Data Model
* The text is still referring to "products"
* I don't understand what is meant by "Identify and standardize the configuration for at least one protocol".
- This is an issue raised since 2018: https://github.com/boucadair/IETF-Drafts-Reviews/blob/master/cacao-proposed%20charter-rev%2011122018a.pdf

I'm not insisting on the validation issue because this may be implicitly deduced from the new text. Nevertheless, I'm wondering whether we need to have some text about operations on the shared actions that may be aggregated/enriched/split because otherwise one may think that the shared actions, once generated, are frozen.

Cheers,
Med

De : Cacao [mailto:[email-masked]] De la part de Bret Jordan
Envoyé : jeudi 20 juin 2019 17:37
À : cacao
Objet : [Cacao] Updated Charter Text

All,

Thanks,
Bret

---

From: Bret Jordan <[email-masked]>
Date: Fri, 21 Jun 2019 09:27:35 +0000

Chairs,

Can we move forward with this working group?  Or is this a blocker?  Are the concerns raised representative of consensus of the group?  Note: I have not heard anyone else raise these issues and I have heard more people support the charter than not.

If this is a blocker and we can not move forward until we have unanimity, please say so.

Bret

________________________________
From: Cacao <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Friday, June 21, 2019 12:23:10 AM
To: Bret Jordan; cacao
Subject: [EXT] Re: [Cacao] Updated Charter Text

Bret,

- Application encoding is part of this item “CACAO Protocol Specification”, not data modeling

* The text is still referring to “products”

* I don’t understand what is meant by “Identify and standardize the configuration for at least one protocol”.

- This is an issue raised since 2018: https://github.com/boucadair/IETF-Drafts-Reviews/blob/master/cacao-proposed%20charter-rev%2011122018a.pdf<https://clicktime.symantec.com/3L1vJpSVtah3oJMXFyYB6RM7Vc?u=https%3A%2F%2Fgithub.com%2Fboucadair%2FIETF-Drafts-Reviews%2Fblob%2Fmaster%2Fcacao-proposed%2520charter-rev%252011122018a.pdf>

I’m not insisting on the validation issue because this may be implicitly deduced from the new text. Nevertheless, I’m wondering whether we need to have some text about operations on the shared actions that may be aggregated/enriched/split because otherwise one may think that the shared actions, once generated, are frozen.

Cheers,

Med

All,

Thanks,

Bret