Subject: Re: capreq questions - hierarchy and sub-calendars

From: "Mark D. Anderson" <[email-masked]>
Date: Sun, 22 Nov 1998 17:46:57 -0800

>Different calendars can not have the same CalID, as
>then the CalId would not be unique.
>
>Is that your question?

No, an ID i understand, assuming they are basically URI's.
Where I'm getting thrown off is the term "hierarchical name".
Is that a composition of "Name" property values?
Or is that a CalId, with no human readable parts?
Can I tell just by looking at a CalID that two calendars
have a hierarchical relationship?
What are the syntactic rules for creating a "hierarchical name"?
Are these supposed to be like IMAP mailboxes (rfc2060)?
If so, I might note that IMAP dictates that a delete does
*not* affect children (delete of foo does not delete foo.bar).

I would think that there would be a notion of an ID for
components or calendars, which is essentially an opaque
string or number, and impervious to naming changes or language
variants, and that the protocol would concern itself with
only those ID's.

(And btw, I would think that there could be fully-qualified
CalID's identifying the same calendar, under replication?)

-mda

---

From: "Doug Royer [N6AAW]" <[email-masked]>
Date: Sun, 22 Nov 1998 17:24:29 -0800 (PST)

> From: "Mark D. Anderson" <[email-masked]>

> >4. calendar hierarchy and sub-calendars.
> >
> >Sub calendars are a way to organize data elements in 
> >a hierarchy manner. That is, a calendar can contains
> >components (Events, todo, journals, etc) as well as 
> >calendars. A use for this would be to store your
> >kids baseball games in a sub calendar to yours.  This
> >is *Very* similar to files and directory.
> >
> >Inheritance is not defined as a requirement and is 
> >out of scope for the CAP definition.
> 
> So the containment hierarchy has no semantics, and is
> merely a lexical property of the identifiers?
> Or is it just a lexical property of the names, and
> not even the identifiers?
> Could different users choose to arrange their hierarchy
> differently, yet use the same ID's?

I am confused. What do you mean by 'identifiers' and 'ID'?
If you mean 'CalID', from section 2 "Terminology"

	A calendar is identified by its unique calendar identifier.

Is that your question?

-Doug
-------------------------------------------------------------------
[email-masked]		http://www.royer.com/dougr.html
801 W. El Camino #131		Work:   (650)786-7599
Mountain View, CA 94040		Ham Radio: N6AAW, Aviation: PP-ASEL