Subject: Recurrence UNTIL/RDATE/EXDATE properties with DATE values

From: Damon Chaplin <[email-masked]>
Date: Wed, 01 Nov 2000 21:16:43 +0000

I'm a bit unsure of the semantics of UNTIL/RDATE/EXDATE recurrence
properties that have DATE values (as opposed to DATE-TIME values).

If only a DATE is given, do you just assume that the time is 00:00:00,
or do you do something more. For example -

If an UNTIL property has a DATE value does it mean:

 a) until 12 am on that date (i.e. you just assume 00:00:00).
 b) until the last occurrence on that date (i.e. you take it as 23:59:59).

If an RDATE property has a DATE value does it mean:

 a) an occurrence on 12 am on that date.
 b) an occurrence at the same time as the initial occurrence, but on the given date.

If an EXDATE property has a DATE value does it mean:

 a) exclude any occurrence at 12 am on that date.
 b) exclude all occurrences on that date.

I think all the (a) answers are more intuitive but I don't think the iCalendar
spec is specific about these.

Damon

---

From: John Stracke <[email-masked]>
Date: Thu, 02 Nov 2000 09:03:00 -0500

> properties that have DATE values (as opposed to DATE-TIME values).

I would suggest that we might want to just ban DATE values, to reduce ambiguity; in all
the cases Damon gives, whether you pick (a) or (b), you can get the same effect with
DATE-TIME values.

Does anybody remember the motivation for permitting DATE values in the first place?

--
/==============================================================\
|John Stracke    | http://www.ecal.com |My opinions are my own.|
|Chief Scientist |=============================================|
|eCal Corp.      |How many roads must a man walk down before he|
[email-masked]|admits he is LOST?                           |
\==============================================================/

---

From: Damon Chaplin <[email-masked]>
Date: Thu, 02 Nov 2000 18:37:54 +0000

> spec is specific about these.

Oops. I meant (b) there.

Damon