Subject: Re: Recurrence-Rule-Question

From: Martin Neimeier <[email-masked]>
Date: Mon, 20 Nov 2000 17:10:45 +0000

[email-masked] wrote:
> 
> Sure, what I sent you was from my logging dump file which kinda spells it
> out... in english for debugging purposes...
> 
> I don't care about DTSTART so that time is zero for my purposes....
> 
> BEGIN:VTIMEZONE
> TZID:Chile, Santiago  (CHL)
> BEGIN:STANDARD
> DTSTART:
> RRULE:FREQ=YEARLY;BYDAY=1SU;BYMONTH=3;BYMONTHDAY=9;BYHOUR=0;BYMINUTE=0
> TZOFFSETFROM:-0300
> TZOFFSETTO:-0400
> TZNAME:Chile, Santiago
> END:STANDARD
> BEGIN:DAYLIGHT
> DTSTART:
> RRULE:FREQ=YEARLY;BYDAY=1SU;BYMONTH=10;BYMONTHDAY=9;BYHOUR=0;BYMINUTE=0
> TZOFFSETFROM:-0400
> TZOFFSETTO:-0300
> TZNAME:Chile, Santiago,DST
> END:DAYLIGHT
> END:VTIMEZONE

Some corrections:

1. DTSTART is a MUST for STANDARD and DAYLIGHT and cannot be empty (it MUST be a local DATE-TIME)
2. RRULE should be RRULE:FREQ=YEARLY;BYDAY=1SU;BYMONTH=3;BYMONTHDAY=9,10,11,12,13,14,15
3. The correct TZID should be "America/Santiago" 
4. The DAYLIGHT-TZNAME should be "CLST"
5. The STANDARD-TZNAME should be "CLT"

My version:

BEGIN:VTIMEZONE
TZID:America/Santiago
TZURL:ftp://elsie.nci.nih.gov/pub/
BEGIN:STANDARD
DTSTART:20000312T000000
RRULE:FREQ=YEARLY;BYDAY=SU;BYMONTH=3;BYMONTHDAY=9,10,11,12,13,14,15
TZOFFSETFROM:-0300
TZOFFSETTO:-0400
TZNAME:CLT
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:19991010T000000
RRULE:FREQ=YEARLY;BYDAY=SU;BYMONTH=10;BYMONTHDAY=9,10,11,12,13,14,15
TZOFFSETFROM:-0400
TZOFFSETTO:-0300
TZNAME:CLST
END:DAYLIGHT
END:VTIMEZONE

Is this now correct ?

cu
Martin
-- 
UNIX was never designed to keep people from doing stupid things, because
that policy would also keep them from doing clever things.   (Doug Gwyn)
--
Martin Neimeier / Ingenieur-Buero Neimeier / Schwarzach / Germany
mailto:[email-masked] / http://www.ibn.de (under heavy reconstruction) / Tel:+49(6262)912344 /
Fax:+49(6262)912347

---

From: "Graham Gilmore" <[email-masked]>
Date: Mon, 20 Nov 2000 11:47:53 -0500

> 3. The correct TZID should be "America/Santiago"

    According to 4.8.3.1 of rfc2445, the TZID property is pretty much an
arbitrary string :
"Note: this document does not define a naming convention for zone
identifiers."

    As long as your date-time TZID parameter values refer to your own
VTIMEZONE objects by the correct TZID, I think you're safe.  Has this
changed?

    Graham Gilmore

---

From: Martin Neimeier <[email-masked]>
Date: Mon, 20 Nov 2000 18:49:58 +0000

> RRULE:FREQ=YEARLY;BYDAY=SU;BYMONTH=10;BYMONTHDAY=9,10,11,12,13,14,15

Okay,

ignore the points 3 to 5. This is only my opinion and no specified RULE in RFC2445. 
But whats with the rest ?

cu
Martin