Subject: Re: second try: RSVP usage in ITIP messages

From: [email-masked]
Date: Mon, 14 May 2001 09:56:39 -0400

sman wrote on 05/12/2001 04:22:56 AM:
> RSVP=TRUE is interpreted as: the Attendee is permitted to send the 
> Organizer a REPLY message to change their PARTSTAT. The REPLY 
> message can also be used to modify parameters such as DELEGATED-FROM
> and DELEGATED-TO.

The intent is good but Id add/modify this a tiny bit.  I think you do not 
want to preclude a COUNTER (or to prevent a REFRESH request) do you??  You 
could expressly call out these cases too but then it would require us to 
revise the text if someone later addes a new METHOD.  Can you/we phrase 
your text in such a way that it is clear that any workflow related kinds 
of actions (ie: accepting, declining, COUNTER, REFRESH, delegation, etc) 
are permitted only if RSVP=TRUE?

> RSVP=FALSE is interpreted as: the Attendee is not permitted to sent 
> the Organizer a reply.

Good (as long as that 'reply' is not a 'REPLY').

> In the case where the Organizer fixes a spelling error in the 
> summary and resends the event to the attendees, the fact that 
> RSVP=TRUE does not require an Attendee to send a REPLY. The REPLY is
> only necessary if the Attendee needs to change a parameter value 
> (such as PARTSTAT). 

or if they want to COUNTER or REFRESH...

Bruce
===========================================================================
Bruce Kahn                                INet: [email-masked]
Iris Associates                          Phone: 978.392.5335
Westford, MA, USA 01886                    FAX: and nothing but the FAX...
Standard disclaimers apply, even where prohibited by law...

---

From: [email-masked] (Steve Mansour)
Date: Mon, 14 May 2001 08:00:38 -0700

[email-masked] wrote:

> The intent is good but Id add/modify this a tiny bit.  I think you do
> not want to preclude a COUNTER (or to prevent a REFRESH request) do
> you??  You could expressly call out these cases too but then it would
> require us to revise the text if someone later addes a new METHOD.
> Can you/we phrase your text in such a way that it is clear that any
> workflow related kinds of actions (ie: accepting, declining, COUNTER,
> REFRESH, delegation, etc) are permitted only if RSVP=TRUE?

I see your point.  Yes, I can reword it.  Are others OK with this?

> Good (as long as that 'reply' is not a 'REPLY').

right, I'll watch the capitalization.

> or if they want to COUNTER or REFRESH...

yep.  I'll send out a 3rd try.

-Steve

>
>
> Bruce
>
> ==========================================================================
>