Subject: CAP Database

From: "Karen Chu" <[email-masked]>
Date: Tue, 25 Sep 2001 16:18:00 -0700

I was reading CAP draft-ietf-calsch-cap-05 and have a couple questions for
you. The reason, I think, any CAP enable clients can be used to access any
CAP
enable servers is because they all recognize the CAP commands like below:

		   C: BEGIN:VCAP
               C: BEGIN:VCOMMAND
               C: METHOD:DELETE
               C: TARGET:cap://cal.foo.com/bill
               C: BEGIN:VQUERY
               C: QUERY:SELECT UID FROM VEVENT WHERE UID = 'abcd12345'
               C: END:VQUERY
               C: END:VCOMMAND
               C: END:VCAP
               C: .

Of course! But this will require any Calendar Server has to have the same
database schema definition. In this case, VEVENT must be the table which
stores event
calendar object information in the CAP enable calendar server database.

Am I understanding correctly?
If so, there must a document to describe the DB definitions.
Can someone point it out to me.

Thanks
Karen

---

From: George Babics <[email-masked]>
Date: Tue, 25 Sep 2001 20:14:28 -0400

Karen Chu wrote:
> database schema definition.

  No this is not needed.
 
  CAP does not specify the type of database nor database definition
to use. How calendar components, and their properties, are stored is
completely up to the implementation. Even though the query language
is modeled on SQL, a CAP server does not need to use an SQL database.
It can easily map the SQL query into its own internal query language.

George

> In this case, VEVENT must be the table which
> stores event