Subject: Re: TARGET in VQUERY (was: No comments on my proposals?)

From: Andrea Campi <[email-masked]>
Date: Wed, 4 Sep 2002 18:49:54 +0200

On Sat, Aug 24, 2002 at 10:50:49AM -0600, Doug Royer wrote:
> Patrice Lapierre wrote:
> > 
> > The addition of a TARGET property in VQUERY addresses this issue,
> > and may even allow a more efficient implementation since we don't
> > need to search all the VAGENDAs to find the VQUERY.
> 
> I agree. I have seen no objection, so I added to the CAP source.
> 

I don't see this added in the latest draft - I guess it should appear
in section 8.6, that is:

     queryc    =  "BEGIN" ":" "VQUERY" CRLF
                queryprop
                "END" ":" "VCAR" CRLF

     queryprop = 1*(

                 ; the following are OPTIONAL but MUST NOT occur
                 ; more than once
                 ;
                 queryid / target

                 ; the following are OPTIONAL, and MAY occur
                 ; more than once
                 ;
                 / name / x-prop / iana-prop

                 ; the following MUST occur at least once.
                 ;
                 / query

                )

Bye,
	Andrea

-- 
Andrea Campi                              mailto:[email-masked]
I.NET S.p.A.                              http://www.inet.it
Direzione Tecnica - R&D			  phone: +39 02 32863 ext 1
v. Darwin, 85 - I-20019			  fax: +39 02 32863 ext 7705
Settimo Milanese (MI), Italy

---

From: Doug Royer <[email-masked]>
Date: Wed, 04 Sep 2002 11:50:38 -0600

> > I agree. I have seen no objection, so I added to the CAP source.

True, I did not push it yet as I have often discoverd that
people tend to ignore an issue - until you have said 'done'.