Subject: DELETED objects

From: Andrea Campi <[email-masked]>
Date: Thu, 5 Sep 2002 15:52:36 +0200

Section 2.2 (at its very end) says:

>	Finally, the CUA could do a "DELETE" or change their state to "DELETED" for all of these now old scheduling requests in the CS. See [iTIP] for details on resolving multiple [iTIP] scheduling entries. 

There is no way to "change state to DELETED" other than using the
DELETE command, so this period should read:

>	Finally, the CUA could do a "DELETE" for all of these now old scheduling requests in the CS. See [iTIP] for details on resolving multiple [iTIP] scheduling entries. 

Also, in 1.3:

       3.  A marked for delete component has its state set to DELETE. To retrieve any deleted object, simply do a query asking for any objects that were stored with its state set to "DELETED". By default objects marked for delete are not returned. The CUA must specifically ask for marked for delete objects.

It might not be obvious but in addition to this, a query MUST NOT
return objects in the DELETED state and in other states, as there
would be no way to distinguish between them. I wonder if this warrants
a brief note here.

Bye,
	Andrea

-- 
Andrea Campi                              mailto:[email-masked]
I.NET S.p.A.                              http://www.inet.it
Direzione Tecnica - R&D			  phone: +39 02 32863 ext 1
v. Darwin, 85 - I-20019			  fax: +39 02 32863 ext 7705
Settimo Milanese (MI), Italy

---

From: Doug Royer <[email-masked]>
Date: Thu, 05 Sep 2002 08:51:24 -0600

Andrea Campi wrote:
> Finally, the CUA could do a "DELETE" or change their state to
> "DELETED" for all of these now old scheduling requests in the CS. See
> [iTIP] for details on resolving multiple [iTIP] scheduling entries.
> 

> Finally, the CUA could do a "DELETE" for all of these now old
> scheduling requests in the CS. See [iTIP] for details on resolving
> multiple [iTIP] scheduling entries.

Yes. 

> Also, in 1.3:
> 
> 3.  A marked for delete component has its state set to DELETE. To
> retrieve any deleted object, simply do a query asking for any objects
> that were stored with its state set to "DELETED". By default objects
> marked for delete are not returned. The CUA must specifically ask for
>  marked for delete objects.
> 

True. If I don't see any objections, I'll add a note.

Thanks again!
-Doug