Subject: Reply to MODIFY command

From: Andrea Campi <[email-masked]>
Date: Wed, 4 Sep 2002 19:17:08 +0200

Hi all,

section 9.5 states:

 If multiple components are selected, then what uniquely identified the component MUST BE returned (UID, QUERYID, ...) if the component contains a unique identifier. If not sufficient information to uniquely identify the modified components MUST BE returned in the reply. 

I find this hard to understand (uniquely identifying multiple things
sounds like an oxymoron to me), would it be possible to elaborate on
this and maybe add a couple of examples?

Bye,
	andrea

-- 
Andrea Campi                              mailto:[email-masked]
I.NET S.p.A.                              http://www.inet.it
Direzione Tecnica - R&D			  phone: +39 02 32863 ext 1
v. Darwin, 85 - I-20019			  fax: +39 02 32863 ext 7705
Settimo Milanese (MI), Italy

---

From: Doug Royer <[email-masked]>
Date: Wed, 04 Sep 2002 12:14:38 -0600

Andrea Campi wrote:
> 
> Hi all,
> 
> section 9.5 states:
> 
>  If multiple components are selected, then what uniquely identified the
> component MUST BE returned (UID, QUERYID, ...) if the component contains
> a unique identifier. If not sufficient information to uniquely identify
> the modified components MUST BE returned in the reply.
> 

Was that not covered in the ABNF for the reply? I think
it lists what has to be returned for each component type.
Or are you saying it is incomplete or inaccurate?

---

From: Andrea Campi <[email-masked]>
Date: Thu, 5 Sep 2002 12:02:46 +0200

> Or are you saying it is incomplete or inaccurate?

Yes, that's part of the problem - there's no modify-reply ABNF.

Bye,
	Andrea