Subject: Ordering of results

From: Andrea Campi <[email-masked]>
Date: Fri, 6 Sep 2002 15:43:55 +0200

Section 6.1.1.7 says:

 Sorting will take place in the order the columns are supplied in the QUERY command. The CS MUST sort at least the first column. The CS MAY sort additional columns. 

However, it does not say what sorting, if any, is performed on:

SELECT * FROM VEVENT

Note that according to the ABNF, it's not legal to do:

SELECT DTSTART,* FROM VEVENT

Is this, intended, or should:

cap-cols    = cap-col / ( cap-cols "," cap-col)
                        / "*"

be changed to:

cap-cols    = cap-col / ( cap-col "," cap-cols)
                        / "*"

Also, the ABNF is still not right:
 - cap-col should allow component.property, but doesn't
 - col-value can't appear on the left side of an operator (well, except
IN), so you can't write STATE()='BOOKED'

Sorry if you've simply not gotten around to do it yet, just want to
be sure they're not forgotten.

While here, I noted that in 6.1.1.3 OWNER() got renamed to CAL-OWNERS();
however, section 6.1.1.1 already discusses the same.

-- 
Andrea Campi                              mailto:[email-masked]
I.NET S.p.A.                              http://www.inet.it
Direzione Tecnica - R&D			  phone: +39 02 32863 ext 1
v. Darwin, 85 - I-20019			  fax: +39 02 32863 ext 7705
Settimo Milanese (MI), Italy

---

From: Doug Royer <[email-masked]>
Date: Fri, 06 Sep 2002 10:14:21 -0600

Andrea Campi wrote:
> 
> Section 6.1.1.7 says:
> 
>  Sorting will take place in the order the columns are supplied in
> the QUERY command. The CS MUST sort at least the first column. The CS
> MAY sort additional columns.
> 

Please re-read 6.1.1.7

---

From: Doug Royer <[email-masked]>
Date: Fri, 06 Sep 2002 10:19:27 -0600

> be sure they're not forgotten.

Was a proposal submitted? If no, then you are correct, I
have not looked at it yet.

> however, section 6.1.1.1 already discusses the same.

Thanks, I'll merge and delete the duplicate.
The name change was proposed (I think by) Mark Davidson
along with the new ABNF and there were no objections from this list.
Please search the archives in case I missed something.