Subject: [Captive-portals] The architecture requiring that the API be secure

From: Kyle Larose <[email-masked]>
Date: Wed, 28 Feb 2018 13:30:39 +0000

Hey everyone,

Issue #6 in the architecture draft (https://github.com/capport-wg/architecture/issues/6)
was raised to point out that we should really mandate that the API be secure.

Basically, we want to make TLS a requirement, not a suggestion, so I've changed the
wording around TLS to reflect this. I also added a section to the security section
discussing the motivation behind the requirement.

I haven't submitted a new draft with these changes yet; they're still on github in a pull
request.

Let me know if you have any comments or concerns.

Thanks,

Kyle

Disclaimer:
This communication (including any attachments) is intended for the use of the intended recipient(s) only and may contain information that is considered confidential, proprietary, sensitive and/or otherwise legally protected. Any unauthorized use or dissemination of this communication is strictly prohibited. If you have received this communication in error, please immediately notify the sender by return e-mail message and delete all copies of the original communication. Thank you for your cooperation.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 28 Feb 2018 17:26:06 -0500

Kyle Larose <[email-masked]> wrote:
    > Issue #6 in the architecture draft
    > (https://github.com/capport-wg/architecture/issues/6) was raised to
    > point out that we should really mandate that the API be secure.

I entered some comments on the github issue.

    > Basically, we want to make TLS a requirement, not a suggestion, so I've
    > changed the wording around TLS to reflect this. I also added a section
    > to the security section discussing the motivation behind the
    > requirement.

I think that we have to deal with Martin's points about all the ways that the
certificate behind HTTPS can be broken.  I don't want to see overrides for
that certificate.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [