Subject: [Captive-portals] (no subject)

From: Brian Shields <[email-masked]>
Date: Fri, 5 Jul 2019 15:54:02 -0700

My name is Brian Shields and I am a member of the WBA, where I am currently
working with a group of industry peers to address captive portal issues.
This group is finalizing a white paper to document the issues and to
provide some proposed fixes to ameliorate them. This will be circulated
amongst the WBA membership with additional plans to liaise with other
standard bodies, with IETF among the first group to do so, and advocate for
the advancement of improving practices and experience for the captive
network.
That said, the WBA would like to engage with the IETF to address the issues
as well as provide support to push some of the current IETF capport
activities to practical trials. The WBA next event will be in Frankfurt on
Oct 2-3, and we would be glad to invite a IETF delegation to discuss a way
forward on the joint collaboration and potentially trials kick-off.
A few of us are planning to join the capport IETF 105 session virtually and
look forward to engaging with everyone there. Thanks very much.
Brian Shields
VP, Engineering at Boingo
Project Lead, Captive Network Portal Standards for Wi-Fi Workgroup, WBA

---

From: Michael Richardson <[email-masked]>
Date: Sat, 06 Jul 2019 16:32:24 -0400

> as well as provide support to push some of the current IETF capport

That sounds exciting.

What we really need is more involvment from captive portal operators,
and more document review so that we can progress.  We have some involvement
From smartphone OS vendors already, but things work best when we can have
people writing code engage with the documents.

    > forward on the joint collaboration and potentially trials kick-off.

So, the IETF is not a single entity, so it's hard to invite "us"
You may find this useful --- https://www.ietf.org/about/participate/tao/

    > look forward to engaging with everyone there. Thanks very much.

Cool.

    > ----------------------------------------------------
    > Alternatives:

    > ----------------------------------------------------
    > _______________________________________________
    > Captive-portals mailing list
    > [email-masked]
    > https://www.ietf.org/mailman/listinfo/captive-portals

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Sat, 06 Jul 2019 16:33:23 -0400

> forward on the joint collaboration and potentially trials kick-off.

I will be in Belgrade Oct. 5-6, but I don't represent the WG.

---

From: Erik Kline <[email-masked]>
Date: Sun, 7 Jul 2019 12:32:56 -0700

Thanks Brian.  The capport agenda is currently unspecified.  Would you like
some time to present?  I think a quick overview, even presented remotely,
could be helpful for kicking off further discussion.

(If so, is ~10-15 minutes of our one allotted hour okay?)

On Fri, 5 Jul 2019 at 15:54, Brian Shields <[email-masked]> wrote:

> My name is Brian Shields and I am a member of the WBA, where I am
> currently working with a group of industry peers to address captive portal
> issues. This group is finalizing a white paper to document the issues and
> to provide some proposed fixes to ameliorate them. This will be circulated
> standard bodies, with IETF among the first group to do so, and advocate
> for the advancement of improving practices and experience for the captive
> network.
> That said, the WBA would like to engage with the IETF to address the
> issues as well as provide support to push some of the current IETF capport
> activities to practical trials. The WBA next event will be in Frankfurt
> on Oct 2-3, and we would be glad to invite a IETF delegation to discuss a
> way forward on the joint collaboration and potentially trials kick-off.
> A few of us are planning to join the capport IETF 105 session virtually
> and look forward to engaging with everyone there. Thanks very much.
> Brian Shields

---

From: Tommy Pauly <[email-masked]>
Date: Sun, 07 Jul 2019 19:06:19 -0700

+1 to getting a presentation from WBA; it would also be useful to get input and conversation during the meeting about the current working group documents!

Best,
Tommy

> On Jul 7, 2019, at 12:32 PM, Erik Kline <[email-masked]> wrote:
> 
> Thanks Brian.  The capport agenda is currently unspecified.  Would you like some time to present?  I think a quick overview, even presented remotely, could be helpful for kicking off further discussion.
> 
> On Fri, 5 Jul 2019 at 15:54, Brian Shields <[email-masked] <mailto:[email-masked]>> wrote:
> My name is Brian Shields and I am a member of the WBA, where I am currently working with a group of industry peers to address captive portal issues. This group is finalizing a white paper to document the issues and to provide some proposed fixes to ameliorate them. This will be circulated amongst the WBA membership with additional plans to liaise with other standard bodies, with IETF among the first group to do so, and advocate for the advancement of improving practices and experience for the captive network.
> That said, the WBA would like to engage with the IETF to address the issues as well as provide support to push some of the current IETF capport activities to practical trials. The WBA next event will be in Frankfurt on Oct 2-3, and we would be glad to invite a IETF delegation to discuss a way forward on the joint collaboration and potentially trials kick-off.
> A few of us are planning to join the capport IETF 105 session virtually and look forward to engaging with everyone there. Thanks very much.
> Brian Shields
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/captive-portals <https://www.ietf.org/mailman/listinfo/captive-portals>

---

From: Brian Shields <[email-masked]>
Date: Mon, 8 Jul 2019 08:01:55 -0700

Hi Erik and Tommy,

I would be happy to present. How long should I plan for? 15 minutes could
be enough to go over our work to date with time for discussion added.

Thanks,
Brian

On Sun, Jul 7, 2019 at 7:06 PM Tommy Pauly <[email-masked]> wrote:

> +1 to getting a presentation from WBA; it would also be useful to get
> input and conversation during the meeting about the current working group
> documents!
>
> Best,
> Tommy
>
> Thanks Brian.  The capport agenda is currently unspecified.  Would you
> like some time to present?  I think a quick overview, even presented
> remotely, could be helpful for kicking off further discussion.
>

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 09 Jul 2019 10:18:05 +1000

15 minutes plus some time for questions and discussions is what I would be happy to allocate.  If you want less time, that's easy.  Let me know if you think that 15 is insufficient and we can work something out.

On Tue, Jul 9, 2019, at 01:03, Brian Shields wrote:
> Hi Erik and Tommy,
> 
> I would be happy to present. How long should I plan for? 15 minutes 
> could be enough to go over our work to date with time for discussion 
> added. 
> 
> Thanks,
> Brian
>