Subject: [Captive-portals] Notes from todays informal meeting

From: "Martin Thomson" <[email-masked]>
Date: Wed, 20 Nov 2019 11:06:00 +0800

Mention PvD in the architecture as it is in AD review

7710bis link relation shall be removed
codepoint 160? we should deprecate 160, register it for polycom, pick a new one, and document the experience.  This requires IETF review.

gStation overview
 - everything works fine
 - v4 only
 - dynamic JSON includes MAC of device
 - happily uses HTTPS, the device already needs a certificate for other reasons
 - the API can't be accessed from outside the network
 - the venue info URL is cloud-hosted

Discussion about accessing resources.
portal URL might be better if it were accessible from outside the network.  Maybe recommend that URLs other than the API doc be public and be accessible from other networks.  Maybe recommend that they not require that applications use the DNS.  They should be unique for the venue, not with content that varies based on where the request comes from.  Issue filed on architecture doc.

Changes to API discussed and agreed, recorded in issues in the repository.

Experiment for Vancouver IETF.  Desire to get the RA working.  Desire to get a real portal on the network (on a different SSID maybe).

---

From: Erik Kline <[email-masked]>
Date: Wed, 20 Nov 2019 11:43:09 +0800

I copied these minutes into the github repo.  The slides we used are also
uploaded there as well:

    https://github.com/capport-wg/wg-materials/tree/master/ietf106