Subject: [Captive-portals] CAPPORT support in iOS 14 and macOS Big Sur betas

From: Tommy Pauly <[email-masked]>
Date: Mon, 22 Jun 2020 14:30:14 -0700

Hello CAPPORT,

I wanted to highlight an announcement we’ve made for the betas of iOS and macOS released today:

How to modernize your captive network <https://developer.apple.com/news/?id=q78sq5rv>

The betas for iOS and macOS support both draft-ietf-capport-rfc7710bis and draft-ietf-capport-api by default. This doesn’t change the user experience of logging onto captive networks, but the system will request the DHCP options and handle the RA option, and will prefer using the Captive Portal API Server interaction over having a probe that is intercepted.

If you have a portal system that is already implementing the CAPPORT features, please test out these betas and let us know if you see any issues! And if you have a captive portal solution, we’d encourage you to start supporting this soon.

Best,
Tommy

---

From: "Martin Thomson" <[email-masked]>
Date: Tue, 23 Jun 2020 10:00:20 +1000

Tommy, this is great!  Thanks for all your work here, it's good to see this turn into something concrete.

On Tue, Jun 23, 2020, at 07:30, Tommy Pauly wrote:
> How to modernize your captive network 
> <https://developer.apple.com/news/?id=q78sq5rv>
> 
> The betas for iOS and macOS support both draft-ietf-capport-rfc7710bis 
> and draft-ietf-capport-api by default. This doesn’t change the user 
> experience of logging onto captive networks, but the system will 
> request the DHCP options and handle the RA option, and will prefer 
> using the Captive Portal API Server interaction over having a probe 
> that is intercepted.
> 
> If you have a portal system that is already implementing the CAPPORT 
> features, please test out these betas and let us know if you see any 
> issues! And if you have a captive portal solution, we’d encourage you 
> to start supporting this soon.
> 
> Best,
> Tommy
> _______________________________________________
> Captive-portals mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/captive-portals
>