Subject: Re: [Captive-portals] [EXTERNAL] BoF proposal: Evaluate impact of MAC address randomization to IP applications

From: "Lee, Yiu" <[email-masked]>
Date: Wed, 30 Sep 2020 04:16:55 +0000

Hi Eric,

Sorry for the delay.  Comments inline:

Thanks,
Yiu

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tuesday, September 29, 2020 at 8:35 AM
To: "[email-masked]" <[email-masked]>, Jason Livingood <[email-masked]>, "Lee, Yiu" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: Magnus Westerlund <[email-masked]>, Erik Kline <[email-masked]>, Roman Danyliw <[email-masked]>, Benjamin Kaduk <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [EXTERNAL] BoF proposal: Evaluate impact of MAC address randomization to IP applications

Jason, Jason, Yiu,

Based on the previous email thread, may I suggest a couple of items to improve the BoF proposal (wiki/agenda) ?

- I guess that there will be more than 50 people based on the initial reactions

- adding capport as conflict to be avoided for the BoF

[YL] Can you elaborate?

- adding a link to draft-lee-randomized-macaddr-ps

[YL] Will do

- assuming that it is too early to form a WG, please state the status of ‘non WG forming’

[YL] Noted

- putting  the description & agenda on the wiki https://trac.tools.ietf.org/bof/trac/wiki<https://urldefense.com/v3/__https:/trac.tools.ietf.org/bof/trac/wiki__;!!CQl3mcHX2A!RSXmaxkBH6JCErvEmGGD7luqaqCDc3f9wIiM6WRHvkBmPZqaeFNHBe8PHAbsvGE$> before this Friday 2nd of October deadline

[YL] Will work on it tomorrow.

- starting to find a potential chair who is not a proponent

[YL] Ok

- Adding discussion about privacy impact on the agenda is important or even critical

[YL] OK

- adding IEEE coordination is also important (could be handled before the potential BoF)

[YL] JW will help here.

More specific to draft-lee-randomized-macaddr-ps-01, here are a couple of comments (mostly details):

  *   MAC addresses are not always 48 bits long
  *   MAC addresses are not always assigned by manufacturers (think VM)
  *   Suggest to distinguish between ‘stable’ and ‘static’ and ‘persistent’ MAC address
  *   Of course BCP 14 is no more RFC 2119 ;-)
  *   PS-04 is more a requirement than a problem statement

[Y] We will add these to 02.

Hope this helps and happy to continue the discussion of course ;-)

[YL] Thanks!

-éric

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 30 Sep 2020 06:13:52 +0000

Yiu,

Thank you for your reply.

My first two points are about the wiki https://trac.tools.ietf.org/bof/trac/wiki<https://urldefense.com/v3/__https:/trac.tools.ietf.org/bof/trac/wiki__;!!CQl3mcHX2A!RSXmaxkBH6JCErvEmGGD7luqaqCDc3f9wIiM6WRHvkBmPZqaeFNHBe8PHAbsvGE$> where the BoF proponents should indicate the expected number of people and the potential conflict with other WG meetings.

While the ‘expected number of people’ is not really relevant for an on-line meeting, my estimate is that there will be more than 50 participants.

Finally, in the list of other WG meetings that could create a conflict for the participants, I suggest to add ‘capport’ WG https://datatracker.ietf.org/wg/capport/charter/ (this email is posted on this WG meeting) as IMHO capport participants could be interested in MADINAS.

Regards

-éric

From: "Lee, Yiu" <[email-masked]>
Date: Wednesday, 30 September 2020 at 06:17
To: Eric Vyncke <[email-masked]>, "[email-masked]" <[email-masked]>, "Livingood, Jason" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: Magnus Westerlund <[email-masked]>, Erik Kline <[email-masked]>, Roman Danyliw <[email-masked]>, Benjamin Kaduk <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [EXTERNAL] BoF proposal: Evaluate impact of MAC address randomization to IP applications

Hi Eric,

Thanks,
Yiu

Jason, Jason, Yiu,

[YL] Can you elaborate?

[YL] Will do

[YL] Noted

[YL] Ok

[YL] OK

[YL] JW will help here.

-          MAC addresses are not always 48 bits long

-          MAC addresses are not always assigned by manufacturers (think VM)

-          Suggest to distinguish between ‘stable’ and ‘static’ and ‘persistent’ MAC address

-          Of course BCP 14 is no more RFC 2119 ;-)

-          PS-04 is more a requirement than a problem statement

[YL] Thanks!

-éric