Subject: RE: [Capwap] CAPWAP poll results and next steps

From: "Darren Loher" <[email-masked]>
Date: Tue, 17 May 2005 17:46:49 -0700

How about this for protocol authors documenting "objectives compliance"?

The protocol authors could include a section to their draft called
"CAPWAP Objectives".  This section would mirror the table of contents
for section 5 of the objectives draft and briefly document (1-2
sentences minimum) how the protocol meets each objective, including a
reference to the appropriate section in their protocol draft.

5.   Objectives 
     5.1  Mandatory and Accepted Objectives  
       5.1.1  Logical Groups  
		The xxx protocol supports logical groups via it's 
		implementation of x, y and z described in section 8.

       5.1.2  Support for Traffic Separation 
		xxx protocol supports the separation of control and data
traffic
		by specifying methods for use of tunnels in section 9.
The 
		solution includes support for a control tunnel, multiple

		data tunnels and split tunnels.

       5.1.3  Wireless Terminal Transparency 
		.... etc ...

I would invite the protocol authors to make more complete, stronger
statements than the above, but something like the above should be "good
enough".

The table format suggested is nice to have in addition to the above
descriptions for a quick reference.

The evaluation draft would include its own, more detailed write-up of
how each draft implements each objective and document how strong, weak,
loose, or specific the protocol defines the solution to each objective.
The evaluation draft would also document where the protocol goes beyond
the objectives.

-Darren

> -----Original Message-----
> From: Pat Calhoun [mailto:[email-masked]]
> Sent: Tuesday, May 17, 2005 12:00 AM
> To: Darren Loher; [email-masked]
> Cc: [email-masked]
> Subject: RE: [Capwap] CAPWAP poll results and next steps
> 
> Darren, I'm a little confused. While I would be OK with this being
done in
> a
> protocol evaluation draft, what would you expect to see from the
protocol
> authors?
> 
> Pat Calhoun
> CTO, Wireless Networking Business Unit
> Cisco Systems
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Pat Calhoun" <[email-masked]>
Date: Tue, 17 May 2005 17:58:46 -0700

That works for me, with the understanding that the LWAPP CAPWAP protocol
comformance specification will be significantly more complete than the
suggestion below. 

Pat Calhoun

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Darren Loher
> Sent: Tuesday, May 17, 2005 5:47 PM
> To: Pat Calhoun; [email-masked]
> The protocol authors could include a section to their draft 
> called "CAPWAP Objectives".  This section would mirror the 
> table of contents for section 5 of the objectives draft and 
> briefly document (1-2 sentences minimum) how the protocol 
> meets each objective, including a reference to the 
> appropriate section in their protocol draft.
> 
> 
> 5.   Objectives 
> 		xxx protocol supports the separation of control 
> and data traffic
> I would invite the protocol authors to make more complete, 
> stronger statements than the above, but something like the 
> above should be "good enough".
> 
> The table format suggested is nice to have in addition to the 
> above descriptions for a quick reference.
> 
> The evaluation draft would include its own, more detailed 
> write-up of how each draft implements each objective and 
> document how strong, weak, loose, or specific the protocol 
> defines the solution to each objective.
> The evaluation draft would also document where the protocol 
> goes beyond the objectives.
> 
> -Darren
> 
> 
> > CTO, Wireless Networking Business Unit Cisco Systems