Subject: RE: [Capwap] CAPWAP poll results and next steps

From: <[email-masked]>
Date: Mon, 16 May 2005 16:58:06 -0700

This suggestion seems reasonable to me.  Are there any comments from the WG and especially the individual protocol draft editors?

Regards,
Dorothy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of ext Pat Calhoun
Sent: Sunday, May 15, 2005 12:50 PM
To: [email-masked]
Cc: Gellert Dorothy (Nokia-ES/MtView)
Subject: RE: [Capwap] CAPWAP poll results and next steps

Dorothy,

I think it is important to make sure that we have a consistent approach at
documenting protocol conformance. The lack of such consistency will cause
the evaluation phase to be unnecessarily complex.

From the e-mail below, you state that a protocol needs to comply with the
problem statement, the taxonomy document and the objectives document. I can
easily understand how one can specify conformance (or not) against the
objectives document, but it is much less clear when it comes to the taxonomy
and problem statement draft (which the latter was included in the objectives
document).

What I would like to propose is that the authors of the documents use every
objectives in the document, and for every objective provide some text
describing the conformance, and finally a conformance rating in the form of
(satisfies objective, partially satisfies objective or does not satify
objective).

For example:

   3.0 Mandatory Objectives
   3.1 Interoperability Objective
	The CAPWAP protocol must include sufficient capabilities
negotiations
	to distinguish between major types of WTPs.
	
   3.1.1 Protocol Evaluation
	The xxx protocol defines a mechanism whereby the WTP...

   3.1.2 Compliance
	The xxx satisfies this CAPWAP objective

Lastly, it would be a good idea for the documents to include a compliance
summary table, in the following form:

                                                 Partially    Does not
                                    Satisfies    Satisfies    Satisfy

Logical Groups                         X
Support for Traffic Separation                       X
Wireless Terminal Transparency         X
Configuration Consistency                                        X
Firmware Trigger                       X
Monitoring and Exchange of 
     System-wide Resource State        X
Resource Control Objective                           X
CAPWAP Protocol Security               X
System-wide Security                   X
IEEE 802.11i Considerations                                      X
Interoperability Objective             X
Protocol Specifications                              X
Vendor Independence                    X
Vendor Flexibility                     X
Multiple Authentication Mechanisms                   X
Support for Future Wireless
     Technologies                      X
Support for New IEEE Requirements                    X
Interconnection Objective              X
Access Control                         X
Support for Non-CAPWAP WTPs            X
Technical Specifications                             X
AP Fast Handoff                        X
Thoughts?

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Wednesday, May 11, 2005 4:28 PM
> To: [email-masked]
> Subject: [Capwap] CAPWAP poll results and next steps
> 
> Hi WG,
> 
> Sorry for the delay in this email.  I thought I sent this out 
> last week on Friday, but I just noticed the address was misspelled!
> Thanks for your patience and participation in the poll.
> 
> Regards,
> Dorothy
> 
> 
> >  -----Original Message-----
> > From: 	Gellert Dorothy (Nokia-ES/MtView)  
> > Sent:	Monday, May 09, 2005 1:59 AM
> > To:	[email-masked]'
> > Cc:	Bert Wijnen (E-mail); Mani Mahalingam (E-mail); Kessens 
> David (Nokia-NET/MtView); Gellert Dorothy (Nokia-ES/MtView)
> > Subject:	CAPWAP poll results and next steps
> > 
> > The CAPWAP poll concluded on May 5th.  The results of the 
> "CAPWAP protocols to evaluate" poll are as follows:
> > 
> > CTP:       YES: 37  NO: 2
> > WICOP:  YES: 36  NO: 3
> > SLAPP:   YES: 21  NO: 18
> > LWAPP:  YES: 38  NO:  1
> > 
> > The protocol most in question was SLAPP.  Since 21 out 39 
> people felt SLAPP should be evaluated, rough consensus 
> dictates that we will evaluate all 4 protocols.
> > 
> > The next step is for the champion of each protocol to 
> submit an individual draft describing how their protocol 
> meets the Objectives draft, the taxonomy draft and the 
> Problem statement.   The first version of these drafts should 
> be submitted to the WG by Tuesday, May 31st.
> > 
> > Note the Objectives draft is still subject to change, and 
> these conformance drafts will have to be updated to reflect 
> the new objectives.  We are requesting these individual 
> evaluations before finalizing the Objectives so the WG can 
> begin commenting towards the protocol evaluation as soon as possible.
> > 
> > Thanks to everyone who participated in the poll.   
> > 
> > Regards,
> > WG Chairs
> > 
> > 
> _______________________________________________
> Capwap mailing list
> [email-masked]
> http://mail.frascone.com/mailman/listinfo/capwap
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap
_______________________________________________
Capwap mailing list
[email-masked]
http://mail.frascone.com/mailman/listinfo/capwap

---

From: "Dick Eckard" <[email-masked]>
Date: Tue, 17 May 2005 19:53:41 -0400

Agreed - just looking for a common starting point and format.

Dick Eckard
Chief RF scientist
Bluesocket, Inc.

-----Original Message-----
From: Pat Calhoun [mailto:[email-masked]] 
Sent: Wednesday, May 18, 2005 8:46 AM
To: Dick Eckard; [email-masked]; [email-masked]
Subject: RE: [Capwap] CAPWAP poll results and next steps

Ah - yes, I agree, with the understanding that the evaluation team may
end
up with different conformance ratings based on their assessment.

Pat Calhoun

> [mailto:[email-masked]] On Behalf Of Dick Eckard
> Sent: Tuesday, May 17, 2005 2:58 PM
> To: Pat Calhoun; [email-masked]; [email-masked]
> I agree that each claim needs to be justified by the authors. 
>  I was looking at what you supplied as a good start towards a 
> summary table, with references back to the text.  As a 
> summary table, a column per proposal seems like a good 
> presentation form.
> 
> Dick Eckard
> Chief RF Scientist
> Bluesocket, Inc.
> 
> From: Pat Calhoun [mailto:[email-masked]]
> Sent: Tuesday, May 17, 2005 3:56 PM
> To: Dick Eckard; [email-masked]; [email-masked]
> I suppose I'm confused as to what the expectation from the WG 
> is on the authors of the proposals. I would expect that even 
> if an 'S' is supplied, sufficient justification is required 
> to be able to make the claim. This is why I had envisioned 
> that there would be a complete section for every requirement, 
> and whether the protocol was in compliance, partially in 
> compliance or not in compliance, there would be specific 
> pointers to help the evaluators make a determination.
> 
> That said, I like the 'S', 'P' or 'X' in the table - it would 
> increase the readability.
> 
> Pat Calhoun
> > [mailto:[email-masked]] On Behalf Of Dick Eckard
> > Sent: Monday, May 16, 2005 5:22 PM
> > To: [email-masked]; [email-masked]; 
> [email-masked]
> > I agree that this seems a reasonable approach.  Perhaps a single 
> > column response with S, P or X, instead of Pat's three columns, and 
> > then a list of numbered notes explaining any deviations at 
> the bottom.
> > 
> > Dick Eckard
> > Chief RF Scientist
> > Bluesocket, Inc.
> > 
> > Sent: Tuesday, May 17, 2005 9:58 AM
> > To: [email-masked]; [email-masked]
> > This suggestion seems reasonable to me.  Are there any 
> comments from 
> > the WG and especially the individual protocol draft editors?
> > 
> > Regards,
> > Dorothy
> > 
> > I think it is important to make sure that we have a consistent 
> > approach at documenting protocol conformance. The lack of such 
> > consistency will cause the evaluation phase to be unnecessarily 
> > complex.
> > 
> > From the e-mail below, you state that a protocol needs to 
> comply with 
> > the problem statement, the taxonomy document and the objectives 
> > document. I can easily understand how one can specify 
> conformance (or 
> > not) against the objectives document, but it is much less 
> clear when 
> > it comes to the taxonomy and problem statement draft (which 
> the latter 
> > was included in the objectives document).
> > 
> > What I would like to propose is that the authors of the 
> documents use 
> > every objectives in the document, and for every objective 
> provide some 
> > text describing the conformance, and finally a conformance 
> rating in 
> > the form of (satisfies objective, partially satisfies objective or 
> > does not satify objective).
> > 
> > For example:
> > 
> >    3.0 Mandatory Objectives
> > 	The CAPWAP protocol must include sufficient 
> capabilities negotiations
> > Lastly, it would be a good idea for the documents to include a 
> > compliance summary table, in the following form:
> > 
> > 
> >                                                  Partially  
>   Does not
> >                                     Satisfies    Satisfies  
>   Satisfy
> > 
> > Logical Groups                         X
> > CTO, Wireless Networking Business Unit Cisco Systems
> > 
> >  
> > 
> > > Sorry for the delay in this email.  I thought I sent this 
> out last 
> > > week on Friday, but I just noticed the address was misspelled!
> meets the 
> > > Objectives draft, the taxonomy draft and the
> > > these conformance drafts will have to be updated to 
> reflect the new 
> > > objectives.  We are requesting these individual 
> evaluations before 
> > > finalizing the Objectives so the WG can begin commenting
> > towards the
> > > protocol evaluation as soon as possible.
> > > >