Subject: RE: [Capwap] Issue 61: Justification Required

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 28 Mar 2006 10:40:35 -0800

But as I understand the original recommendation, the change 
request was to make the WLAN configuration a two step process, where
the WTP simply uses an index (base BSSID + WLAN ID) and the AC can
assume what the BSSID for the WLAN is. This is the simplest solution
but does have a requirement that the MAC addresses allocated on the WTP
are contiguous (which is really not an unrealistic requirement anyhow).

Based on your comment below, it appears that you are ok with the
protocol
as-is. Correct?

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems

> -----Original Message-----
> From: Michael Montemurro [mailto:[email-masked]] 
> Sent: Tuesday, March 28, 2006 10:34 AM
> To: Pat Calhoun (pacalhou); capwap
> Subject: RE: [Capwap] Issue 61: Justification Required
> 
> Pat,
> 
> The idea behind the recommendation was that you could define 
> a WLAN ID and map it to an VLAN/ESS/Broadcast domain and 
> include it in the CAPWAP header for data traffic. In this 
> way, the fast path would not have to interpret the BSSID to 
> make forwarding decisions.
> 
> I don't have particularily strong feelings for this feature.
> 
> Cheers,
> 
> 	Mike
> 
> > -----Original Message-----
> > From: Pat Calhoun (pacalhou) [mailto:[email-masked]]
> > Sent: March 28, 2006 1:06 PM
> > To: capwap
> > Subject: [Capwap] Issue 61: Justification Required
> > 
> > The original request stated:
> > > Page 108, Section 11.8.1.1. I would like to suggest a slightly 
> > > different behavior for configuring a WLAN on a WTP.
> > > The AC would send a WLAN ID as part of the Configuration
> > Request and
> > > the WTP would respond with the BSSID that would be used for
> > the WLAN
> > > as part of the Configuration Response.
> > > In that way, the WTP is responsible for maintaining BSSID
> > to WLAN ID
> > > mappings.
> > 
> > I'd like to better understand the justification for making such a 
> > change. Anyone have strong feelings, and reasons, for this feature?
> >  
> > 
> > Pat Calhoun
> > CTO, Wireless Networking Business Unit
> > Cisco Systems
> > _________________________________________________________________
> > To unsubscribe or modify your subscription options, please visit:
> > http://lists.frascone.com/mailman/listinfo/capwap
> > 
> > Archives: http://lists.frascone.com/pipermail/capwap
> > 
> 
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: Partha Narasimhan <[email-masked]>
Date: Tue, 28 Mar 2006 10:46:16 -0800 (PST)

I am aware of implementations (not my own) where the BSSID map does not 
follow the mapping you have listed below. The MAC addresses are contiguous 
except not in the LSB bits. IMHO, it is cleaner to let the WTP manage that 
mapping and notify the AC of the same. Which, if I understood it 
correctly, is what the original comment was asking for.

Thanks
partha