Subject: RE: [Capwap] Issue 61: Justification Required

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Wed, 29 Mar 2006 10:36:22 -0800

> While the current mapping seems the simplest one to choose 
> from a design perspective, my earlier statement was to show 
> that there are other implementations out there that use a 
> different one. This is about a WTP vendor choosing a method 
> to manage their MAC address space and how they allocate 
> addresses to their devices. IMHO, we should leave it to the 
> WTP vendor to use their own MAC address management method(s) 
> rather than impose one particular scheme on them from a 
> protocol spec. 

Which is why I'm hoping that such vendors speak up now. Frankly,
I have a hard time understanding the manufacturing process that
allows for non-contiguous MAC addresses to be assigned to a WTP.
Given the rarity of MAC addresses, vendors generally try to use 
them as efficiently as possible.

So I would prefer we keep it simple vs. maximum flexibility, unless
vendors out there see a specific problem with this approach.

> Based on a very quick glance, it is not clear to me why this 
> would require new messages or changes to the state machine 
> (quite possible I am missing something). It does seem to 
> require adding a field or two to some messages.

You may be right - it depends on how we end up implementing it.

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: "David T. Perkins" <[email-masked]>
Date: Wed, 29 Mar 2006 10:51:54 -0800 (PST)

HI,

The use case is the following:

A manufacturer creates an AP that is designed to support
a single BSSID. Later on, new software is developed so that
the device can support multiple BSSIDs (and supports
CAPWAP.) The question is where does the device receive
the needed MAC addresses to support this increased
capability. One approach is to have the
AC manage a pool of MAC addresses that can be allocated
to WTPs (which were previously standalone APs). The
MAC addresses in the pool are typically a rare resource
not to be squandered. Thus, the AC might allocate them
to converted WTPs only as needed. If this approach
is followed, then the MAC address used for the BSSIDs
in the converted WTPs may not (and are probably not)
be contiguous.

> You may be right - it depends on how we end up implementing it.

Regards,
/david t. perkins

---

From: [email-masked]
Date: Wed, 29 Mar 2006 21:04:51 +0100

1 "extra" MAC address is available for free by using the locally 
administrated bit.