Subject: Re: [Capwap] Discovery operation in CAPWAP

From: "Scott G. Kelly" <[email-masked]>
Date: Mon, 20 Mar 2006 04:40:56 -0800 (GMT-08:00)

The discovery request is not dtls-encapsulated.

-----Original Message-----
>From: [email-masked]
>Sent: Mar 19, 2006 10:41 PM
>To: [email-masked]
>Subject: [Capwap] Discovery operation in CAPWAP
>
>Hi,
>
>CAPWAP Packet Formats described in section 4 (P#26) in the CAPWAP Protocol
>Specification states that:
>* For Data packers DTLS security is optional
>* For Control pakcets DTLS security is required
>
>Once Discovery phase completes, WTP will send ClientHello to its preferred
>AC and wait for outcome of DTLS handshake. At the end of this handshake,
>secured channel is established between AC and WTP.
>
>I have a query regarding discovery operation. DTLS phase starts after
>discovery phase (as per CAPWAP State Machine in section 2.2). If that is the
>case, how can we send a discovery request, which is a control packet, with
>DTLS header?
>
>With Best Regards,
>M.S. Basker

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: [email-masked]
Date: Mon, 20 Mar 2006 23:15:33 +0530

Hi Scott,

How can we tell the difference between Discovery Request and Client Hello?
On the AC, transition to DTLS-Init is after receiving Client Hello (and not
after transmitting Discovery Response). On the same port and in the same
state, we will be getting CAPWAP header and DTLS Header. We need to a way to
distinguish one from the other.

Regards,
-Rajesh Mohan