Subject: [Capwap] FW: 802.11 Specific - no result code for WLAN config command

From: <[email-masked]>
Date: Tue, 7 Mar 2006 12:14:52 +0530

-----Original Message-----
From: sujathav [mailto:[email-masked]]
Sent: Tuesday, March 07, 2006 11:04 AM
To: [email-masked]'
Subject: 802.11 Specific - no result code for WLAN config command

 Hi,

   1.  I found that in the CAPWAP specification, the WLAN configuration
request sent from the AC to the WTP is acked
by the WLAN Configuration Response. This Message does not have any message
elements.
And I presume it is sent irrespective of success / failure of configuration.

 Can we have the Radio Id , WLAN ID and Success Code Message Elements (tlvs)
to be sent
as part of WLAN Configure Response ? ?If not, is there any other means of
finding out
if my WLAN Configuration (Add / Update / Delete ) succeeded or not?

 2. The WTP Radio Information that lists the Radio type and Id is part of
the Discovery Request.
It is not sent as part of any Message after that.
 But since the AC does not keep any state for a Discovery Request,
the AC does not remember it. I assume that without knowing the Radio type,
the AC would not be able to
configure the WTP. I suggest we add Radio Type TLV to the Configure Request,
to avoid this.

Thanks

Sujatha V

_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: [email-masked]
Date: Tue, 7 Mar 2006 14:05:59 +0530

Hi,

Thanks

Sujatha V

---

From: Michael Montemurro <[email-masked]>
Date: Thu, 16 Mar 2006 12:39:49 -0500

I've recorded this issue as a bug. The issue number is 78.

Cheers,

	Mike 

> From: sujay [mailto:[email-masked]] 
> Sent: March 8, 2006 2:11 AM
> To: [email-masked]; [email-masked]
> Subject: RE: [Capwap] FW: 802.11 Specific - no result code 
> for WLAN config command
> 
> Sujatha,
> The first point you have mentioned could  be addressed thus;
> 
> Send WLAN Configuration reponse only when the operation is 
> successful.Using the sequence number in the request packet 
> you should be able identify which WLAN configuration request 
> has failed and thus the Radio ID. WLAN Id etc.
> 
> 
> Second point;
> 
> (In the expired lwapp-03.txt this message was being sent in the Join
> Request Message,
> not so in the current.)
> 
> It could be handled in two ways;
> 1. the AC should not send the Discovery Response if it is unable to
> configure the WTP
> With its given WTP radio information, that automatically means the
> ClientHello SHOULD
> not be expected from the that non-supported WTP.
> 
> 2. It could be added as a part of the 802.11 binding message, IEEE
> 802.11 WTP WLAN Radio Configuration,
> message another "Radio Type". 
> 
> 
> Any comments?
> 
> Regards,
> Sujay
> 
> My Location;
> http://maps.google.com/maps?ll=14.626109,76.959229&spn=4.72485
2,7.525085
> &t=h&hl=en
> request sent from the AC to the WTP is acked by the WLAN Configuration
> Response. This Message does not have any message elements. 
> And I presume
> it is sent irrespective of success / failure of configuration.
> 
>  Can we have the Radio Id , WLAN ID and Success Code Message Elements
> (tlvs) to be sent as part of WLAN Configure Response ? ?If 
> not, is there
> any other means of finding out if my WLAN Configuration (Add 
> / Update /
> Delete ) succeeded or not?
> 
>  2. The WTP Radio Information that lists the Radio type and Id is part
> of the Discovery Request. It is not sent as part of any Message after
> that.  But since the AC does not keep any state for a 
> Discovery Request,
> the AC does not remember it. I assume that without knowing the Radio
> type, the AC would not be able to configure the WTP. I suggest we add
> Radio Type TLV to the Configure Request, to avoid this.
> 
> 
> 
> Thanks
> 
> Sujatha V
> 
>