Subject: RE: [Capwap] Proposal for updated State Machine

From: Michael Montemurro <[email-masked]>
Date: Mon, 20 Mar 2006 14:22:04 -0500

I created Issue 85 to track this request.

Cheers,

	Mike  

> -----Original Message-----
> From: David T. Perkins [mailto:[email-masked]] 
> Sent: March 20, 2006 11:24 AM
> To: [email-masked]
> Subject: [Capwap] Proposal for updated State Machine
> 
> HI,
> 
> Below is a proposal for an updated state machine:
> 
>    /-------------\                                                    
>    |             v                                            
>           
>    |       +------------+                                     
>           
>    |       | WTP-start  
> |<---------------------------------------+      
>    |       +------------+                                     
>   |       
>    |        ^    |a                                           
>   |       
>    |        |    |                            y               
>   |       
>    |        |    |              +-------------+------------+  
>   |       
>    |        |    |              |             | DTLS-rekey |  
>   |       
>    |        |    |              |  +--------->+------------+  
>   |       
>    |        |    |              |  |                  |6      
>   ^       
>    |        |    |              V  | x                V       
>   |       
>    |        |    |        +--------+--+       +------------+  
>   |       
>    |       /     |        |    Run    |------>| DTLS-Reset 
> |<---|----\  
>    |     /       |       r+-----------+     u +------------+  
>   |     | 
>    |    /        |              ^                ^     v|     
>   |     | 
>    |   |         v              |                |      |     
>   |     | 
>    |   |   +--------------+     |          /----/       V     
>   |     | 
>    |   |   |  Discovery   |    q|        k|           
> +-------+ |     | 
>    |   |  b+--------------+    +-------------+        | Reset 
> |-+ w   | 
>    |   |     |d     f|  ^      |  Configure  |<--\    
> +-------+       | 
>    |   |     |       |  |      +-------------+   |            
>         | 
>    |   |e    v       |  |                        \----------\ 
>         | 
>    |  +---------+    v  |i                                  
> |2        | 
>    |  | Sulking |   +------------+    +--------------+    
> +---------+ | 
>    |  +---------+   | DTLS-Init  |--->| DTLS-Complete|--->| 
> Config1 | | 
>    |                +------------+ z  +--------------+ x3 
> +---------+ | 
>    |                   |h  ^                               |4 
>         | 
>    |                   |   |                               v  
>       o / 
>     \                  |   |                    
> +------------+-------/  
>      \-----------------/   |x2                  | Image Data 
> |          
>                          +----------+           +------------+n
>                          | AC-Start |           
>                        x1+----------+           
>                                                          
> 
> Changes:
> 1) Removed the "C" in all states
> 2) Renamed state "Idle" to "WTP start"
> 3) Removed transition "t" from "Run" to "WTP start(Idle)"
> 4) Added state "AC start" and "x1" and "x2"
>    States:
>      WTP-Start - the "start state" for WTPs
>      AC-Start - the "start state for ACs
>    Transitions:
>      x1 - AC-Start to AC-Start - the AC recieves a Discover
>           request message and responds with a Discovery
>           response message
>      x2 - AC-Start to DTLS-Init - the AC does this transition
>           when it receives a ClientHello from a WTP
> 5) Added start "Config1", renamed state "Configure" to "Config2",
>    moved transition "2" from "DTLS-Complete" to "Configure"
>    to "Config1" to "Config2", added transition "x3", and
>    moved transition "4" from "DTL-Complete" to "Image Data"
>    to "Config1" to "Image Data". The results are:
>    States:
>      Config1 - image version determination for the WTP
>      Config2 - the "complete" initial configuration of
>                a WTP
>    Transitions:
>      x3 - the DTLS session is established transition to
>           state where the AC determines
>           the WTP physical configuration, and the list of
>           images available on the WTP, and the image that
>           the WTP is running. 
>      2 - The AC determined that the image that the WTP is
>          running is appropriate and proceeds to a state
>          to set the initial configuration of the WTP.
>      4 - The AC determined that either that the WTP needs
>          a new image, or that the WTP needs to be running
>          a different image. Thus, it proceeds to a state
>          to put (if needed) a new image on the WTP and
>          set it to be used after the WTP resets.
> 
> Regards,
> /david t. perkins
> 
> _________________________________________________________________
> To unsubscribe or modify your subscription options, please visit:
> http://lists.frascone.com/mailman/listinfo/capwap
> 
> Archives: http://lists.frascone.com/pipermail/capwap
> 
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 20 Mar 2006 16:37:15 -0800

Dear all,
  Before we forget, I wanted to wrap up the issues arising from today's 
presentation:
- Puneet's question on roaming, STA roaming not WTP roaming is what we 
are trying to do
- France Telecom colleague's question on the relationship with NEMO, 
NEMO and MIP try to provide the session continuity, i.e. try to keep the 
same IP address so that the sessions do not break after handover. This 
is not what CAPWAPHP is after. We are interested in roaming support  
that is needed to be included in the CAPWAP protocol.
- Pat mentioned that he was concerned on our model for Local MAC roaming 
handling in CAPWAPHP.
- Pat claimed that the Split MAC solution is already in CAPWAP protocol, 
however, of the two scenarios we have in CAPWAPHP only one of them is 
partially covered in CAPWAP.
 - Pat asked on inter-AC roaming, here the roaming scenario is where STA 
moves from a WTP in one domain, e.g. Verizon to a WTP in another domain, 
e.g. T-Mobile.
  Have I missed anything?
 
Regards,

--behcet