Subject: [Capwap] Issue 61: Justification Required

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 28 Mar 2006 10:05:55 -0800

The original request stated:
> Page 108, Section 11.8.1.1. I would like to suggest a 
> slightly different behavior for configuring a WLAN on a WTP. 
> The AC would send a WLAN ID as part of the Configuration 
> Request and the WTP would respond with the BSSID that would 
> be used for the WLAN as part of the Configuration Response. 
> In that way, the WTP is responsible for maintaining BSSID to 
> WLAN ID mappings.

I'd like to better understand the justification for making such
a change. Anyone have strong feelings, and reasons, for this
feature?

Pat Calhoun
CTO, Wireless Networking Business Unit
Cisco Systems
_________________________________________________________________
To unsubscribe or modify your subscription options, please visit:
http://lists.frascone.com/mailman/listinfo/capwap

Archives: http://lists.frascone.com/pipermail/capwap

---

From: Michael Montemurro <[email-masked]>
Date: Tue, 28 Mar 2006 13:34:10 -0500

Pat,

The idea behind the recommendation was that you could define a WLAN ID and
map it to an VLAN/ESS/Broadcast domain and include it in the CAPWAP header
for data traffic. In this way, the fast path would not have to interpret the
BSSID to make forwarding decisions.

I don't have particularily strong feelings for this feature.

Cheers,

	Mike

> -----Original Message-----
> From: Pat Calhoun (pacalhou) [mailto:[email-masked]] 
> Sent: March 28, 2006 1:06 PM
> To: capwap
> Subject: [Capwap] Issue 61: Justification Required
> 
> > Page 108, Section 11.8.1.1. I would like to suggest a slightly 
> > different behavior for configuring a WLAN on a WTP.
> Request and 
> > the WTP would respond with the BSSID that would be used for 
> the WLAN 
> > as part of the Configuration Response.
> > In that way, the WTP is responsible for maintaining BSSID 
> to WLAN ID 
> > mappings.
> 
> I'd like to better understand the justification for making 
> such a change. Anyone have strong feelings, and reasons, for 
> this feature?
>  
> 
> Pat Calhoun

---

From: Michael Montemurro <[email-masked]>
Date: Tue, 28 Mar 2006 13:42:34 -0500

Yes I am.

	Mike 

> Sent: March 28, 2006 1:41 PM
> To: Michael Montemurro; capwap
> Subject: RE: [Capwap] Issue 61: Justification Required
> 
> But as I understand the original recommendation, the change 
> request was to make the WLAN configuration a two step 
> process, where the WTP simply uses an index (base BSSID + 
> WLAN ID) and the AC can assume what the BSSID for the WLAN 
> is. This is the simplest solution but does have a requirement 
> that the MAC addresses allocated on the WTP are contiguous 
> (which is really not an unrealistic requirement anyhow).
> 
> Based on your comment below, it appears that you are ok with 
> the protocol as-is. Correct?
> 
> Pat Calhoun
> > From: Michael Montemurro [mailto:[email-masked]]
> > Sent: Tuesday, March 28, 2006 10:34 AM
> > To: Pat Calhoun (pacalhou); capwap
> > Subject: RE: [Capwap] Issue 61: Justification Required
> > 
> > Pat,
> > 
> > The idea behind the recommendation was that you could 
> define a WLAN ID 
> > and map it to an VLAN/ESS/Broadcast domain and include it in the 
> > CAPWAP header for data traffic. In this way, the fast path 
> would not 
> > have to interpret the BSSID to make forwarding decisions.
> > 
> > > I'd like to better understand the justification for making such a 
> > > change. Anyone have strong feelings, and reasons, for 
> this feature?
> > >  
> > > 
> > > Pat Calhoun
> > > CTO, Wireless Networking Business Unit Cisco Systems

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Tue, 28 Mar 2006 10:56:47 -0800

You are correct, Partha. My point is that it involves new messages
that don't exist, possible changes to the state machine (not sure).
So I'm trying to find out how much people care about this feature
Before I go ahead and start writing significant text.

So far, looks like you think it would be a neat idea, but not
necessary (based on your comment "I am aware of implementations
(not my own)". Correct?

Pat Calhoun

> From: Partha Narasimhan [mailto:[email-masked]] 
> Sent: Tuesday, March 28, 2006 10:46 AM
> To: Pat Calhoun (pacalhou)
> Cc: Michael Montemurro; capwap
> I am aware of implementations (not my own) where the BSSID 
> map does not follow the mapping you have listed below. The 
> MAC addresses are contiguous except not in the LSB bits. 
> IMHO, it is cleaner to let the WTP manage that mapping and 
> notify the AC of the same. Which, if I understood it 
> correctly, is what the original comment was asking for.
> 
> Thanks
> partha
> 
> On Tue, 28 Mar 2006, Pat Calhoun (pacalhou) wrote:
> 
> > But as I understand the original recommendation, the change request 
> > was to make the WLAN configuration a two step process, 
> where the WTP 
> > simply uses an index (base BSSID + WLAN ID) and the AC can 
> assume what 
> > the BSSID for the WLAN is. This is the simplest solution 
> but does have 
> > a requirement that the MAC addresses allocated on the WTP are 
> > contiguous (which is really not an unrealistic requirement anyhow).
> >
> > Based on your comment below, it appears that you are ok with the 
> > protocol as-is. Correct?
> >
> > Pat Calhoun
> >> The idea behind the recommendation was that you could define
> >> a WLAN ID and map it to an VLAN/ESS/Broadcast domain and
> >> include it in the CAPWAP header for data traffic. In this
> >> way, the fast path would not have to interpret the BSSID to
> >> make forwarding decisions.
> >>

---

From: "Partha Narasimhan" <[email-masked]>
Date: Tue, 28 Mar 2006 12:26:14 -0800

Pat

While the current mapping seems the simplest one to choose from a design
perspective, my earlier statement was to show that there are other
implementations out there that use a different one. This is about a WTP
vendor choosing a method to manage their MAC address space and how they
allocate addresses to their devices. IMHO, we should leave it to the WTP
vendor to use their own MAC address management method(s) rather than
impose one particular scheme on them from a protocol spec. 

Based on a very quick glance, it is not clear to me why this would
require new messages or changes to the state machine (quite possible I
am missing something). It does seem to require adding a field or two to
some messages.

Thanks
partha
 
> Sent: Tuesday, March 28, 2006 10:57 AM
> To: Partha Narasimhan
request
> > >>> I'd like to better understand the justification for making such
a

---

From: "Saravanan Govindan" <[email-masked]>
Date: Wed, 29 Mar 2006 09:20:50 +0800

Pat,

I like the idea of specifying a default mode for WLAN configuration
because it helps implementers with an exact spec. In a slight change
from the request below, I would like to see the AC decide the WLAN ID
and its corresponding BSSID (for the WTP) and notify this mapping within
the Configuration Response. 

Saravanan

-----Original Message-----
From: Pat Calhoun (pacalhou) [mailto:[email-masked]] 
Sent: Wednesday, March 29, 2006 2:06 AM
To: capwap
Subject: [Capwap] Issue 61: Justification Required

Pat Calhoun

---

From: zhaoyujin 31390 <[email-masked]>
Date: Thu, 30 Mar 2006 18:07:02 +0500

Hi all:

  I think current protocol mechanism is ok. 

  The map of WLAN ID and BSSID is very simple, and it is only an offset from based BSSID.

  The WLAN ID length is shorter than BSSID, and easy to used than BSSID (It is a MAC address).

  Another if keep BSSID on AC is based on vendor, and it is out of protocol scope.

Best regard
Michael

> Yes, Pat.
> 
> 
> 
> ----Original Message Follows----
> From: "Pat Calhoun (pacalhou)" <[email-masked]>
> To: "Saravanan Govindan" 
> <[email-masked]>,"capwap" 
> <[email-masked]>
> Date: Wed, 29 Mar 2006 10:36:22 -0800
> 
> So if I understand properly, you'd like the AC to also include the
> BSSID the WTP should use, in addition to the WLAN ID?
> 
> Pat Calhoun
> > From: Saravanan Govindan [[email-masked]]
> > Sent: Tuesday, March 28, 2006 5:21 PM
> > I like the idea of specifying a default mode for WLAN
> > configuration because it helps implementers with an exact
> > spec. In a slight change from the request below, I would like
> > to see the AC decide the WLAN ID and its corresponding BSSID
> > (for the WTP) and notify this mapping within the
> > Configuration Response.
> >
> > Saravanan
> >
> >
> >
> >
> > From: Pat Calhoun (pacalhou) [[email-masked]]
> Get an advanced look at the new version of MSN Messenger. 
> http://messenger.msn.com.sg/Beta/Default.aspx
>

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Fri, 31 Mar 2006 07:03:39 -0800

With the understanding that the WTP would have a contiguous range of MAC
addresses.

Pat Calhoun

> From: Saravanan Govindan [mailto:[email-masked]] 
> Sent: Wednesday, March 29, 2006 1:35 PM
> To: Pat Calhoun (pacalhou); 
> [email-masked]; [email-masked]
> So if I understand properly, you'd like the AC to also 
> include the BSSID the WTP should use, in addition to the WLAN ID?
> 
> Pat Calhoun
>  > From: Saravanan Govindan 
> [mailto:[email-masked]]
>  > Sent: Tuesday, March 28, 2006 5:21 PM  > To: Pat Calhoun 
> (pacalhou); capwap  > Subject: RE: [Capwap] Issue 61: 
> Justification Required  >  > Pat,  >  > I like the idea of 
> specifying a default mode for WLAN  > configuration because 
> it helps implementers with an exact  > spec. In a slight 
> change from the request below, I would like  > to see the AC 
> decide the WLAN ID and its corresponding BSSID  > (for the 
> WTP) and notify this mapping within the  > Configuration Response.
>  >
>  > Saravanan
>  >
>  >
>  >
>  >
> > Sent: Wednesday, March 29, 2006 2:06 AM  > To: capwap  > 
> Subject: [Capwap] Issue 61: Justification Required  >  > The 
> original request stated:
> slightly  > > different behavior for configuring a WLAN on a WTP.
>  > Request and  > > the WTP would respond with the BSSID that 
> would be used for  > the WLAN  > > as part of the 
> Configuration Response.
>  > > In that way, the WTP is responsible for maintaining 
> BSSID  > to WLAN ID  > > mappings.
>  >
>  > such a change. Anyone have strong feelings, and reasons, 
> for  > this feature?
>  >
>  >
>  > Pat Calhoun
>  > CTO, Wireless Networking Business Unit  > Cisco Systems  >

---

From: "Pat Calhoun (pacalhou)" <[email-masked]>
Date: Fri, 31 Mar 2006 07:05:05 -0800

Unfortunately, radios have BSSIDs, not the ACs.

Pat Calhoun

> From: zhaoyujin 31390 [mailto:[email-masked]] 
> Sent: Thursday, March 30, 2006 5:07 AM
> To: Saravanan Govindan
> Cc: Pat Calhoun (pacalhou); 
> Subject: RE:RE: [Capwap] Issue 61: Justification Required
> 
> Hi all:
> 
> configuration 
> > > from the request below, I would like to see the AC decide 
> the WLAN 
> > > ID and its corresponding BSSID (for the WTP) and notify 
> this mapping 
> > > within the Configuration Response.
> > >
> > > Saravanan
> > >
> > >
> > >
> > >